aboutsummaryrefslogtreecommitdiffstats
path: root/news/pan
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-28 21:01:01 +0800
committerpav <pav@FreeBSD.org>2006-05-28 21:01:01 +0800
commit3969b6b099437c374e1a141551dea2d441fc1e4d (patch)
treeee5b0d456a5c22d84662ae3c60f41a0cfbbcb322 /news/pan
parent8b4077858a5c9338f64546e7a1a9d47ecb49df12 (diff)
downloadfreebsd-ports-gnome-3969b6b099437c374e1a141551dea2d441fc1e4d.tar.gz
freebsd-ports-gnome-3969b6b099437c374e1a141551dea2d441fc1e4d.tar.zst
freebsd-ports-gnome-3969b6b099437c374e1a141551dea2d441fc1e4d.zip
- Rename port news/pan2 -> news/pan
Diffstat (limited to 'news/pan')
-rw-r--r--news/pan/Makefile46
-rw-r--r--news/pan/distinfo3
-rw-r--r--news/pan/files/patch-Makefile.in11
-rw-r--r--news/pan/files/patch-pan.desktop.in7
-rw-r--r--news/pan/files/patch-pan_base_text-massager.c36
-rw-r--r--news/pan/pkg-descr6
-rw-r--r--news/pan/pkg-plist39
7 files changed, 148 insertions, 0 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
new file mode 100644
index 000000000000..af09715cc35c
--- /dev/null
+++ b/news/pan/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: pan2
+# Date created: 19 August 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pan
+PORTVERSION= 0.14.2.91
+PORTREVISION= 4
+CATEGORIES= news gnome
+MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/SOURCE/ \
+ http://pan.rebelbase.com/download/obsolete/${PORTVERSION}/SOURCE/
+DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Threaded GNOME 2 newsreader based on Agent for Windows
+
+LIB_DEPENDS= gnet-2.0.0:${PORTSDIR}/net/gnet2 \
+ pcre.0:${PORTSDIR}/devel/pcre-utf8
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack gnometarget libxml2 gtk20
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -lgnuregex"
+
+OPTIONS= GTKSPELL "Enable spell checking support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GTKSPELL)
+CONFIGURE_ARGS+= --disable-gtkspell
+.else
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|apps/Internet|applications|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/news/pan/distinfo b/news/pan/distinfo
new file mode 100644
index 000000000000..8f6d26a61224
--- /dev/null
+++ b/news/pan/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/pan-0.14.2.91.tar.bz2) = 4770d899a1c1ba968ce96bc5aeb07b62
+SHA256 (gnome2/pan-0.14.2.91.tar.bz2) = 1658c22fbe29ac0b88d2ae8e487247bad40618809719819297ecf0b7ae69a9ab
+SIZE (gnome2/pan-0.14.2.91.tar.bz2) = 1919099
diff --git a/news/pan/files/patch-Makefile.in b/news/pan/files/patch-Makefile.in
new file mode 100644
index 000000000000..1ffb18687e4c
--- /dev/null
+++ b/news/pan/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Jul 24 22:49:46 2003
++++ Makefile.in Thu Jul 24 22:49:56 2003
+@@ -116,7 +116,7 @@
+ XML_CFLAGS = @XML_CFLAGS@
+ XML_LIBS = @XML_LIBS@
+
+-SUBDIRS = po gmime pan docs tests
++SUBDIRS = po gmime pan docs
+
+ DESKTOP_IN_FILES = pan.desktop.in
+ DESKTOP_FILES = $(DESKTOP_IN_FILES:.desktop.in=.desktop)
diff --git a/news/pan/files/patch-pan.desktop.in b/news/pan/files/patch-pan.desktop.in
new file mode 100644
index 000000000000..19781ac29ab6
--- /dev/null
+++ b/news/pan/files/patch-pan.desktop.in
@@ -0,0 +1,7 @@
+--- pan.desktop.in.orig Sun Feb 27 16:13:23 2005
++++ pan.desktop.in Sun Feb 27 16:14:07 2005
+@@ -6,3 +6,4 @@
+ Icon=pan.png
+ Terminal=false
+ Type=Application
++Categories=Application;Network;News;
diff --git a/news/pan/files/patch-pan_base_text-massager.c b/news/pan/files/patch-pan_base_text-massager.c
new file mode 100644
index 000000000000..0d17a321bdb0
--- /dev/null
+++ b/news/pan/files/patch-pan_base_text-massager.c
@@ -0,0 +1,36 @@
+--- pan/base/text-massager.c.orig Mon Jan 26 00:51:26 2004
++++ pan/base/text-massager.c Mon Jan 26 00:55:48 2004
+@@ -250,23 +250,29 @@
+ char * pch;
+ char * line_start;
+ char * end;
++ int pos;
+
+ /* walk through the entire string */
+ linefeed_here = NULL;
+- for (line_start=pch=str->str, end=line_start+str->len; pch!=end; )
++ for (pos = 0, line_start=pch=str->str, end=line_start+str->len; pch<end; )
+ {
+ /* a linefeed could go here; remember this space */
+- if (isspace((guchar)*pch) || *pch=='\n')
++ if (g_unichar_isspace(g_utf8_get_char (pch)) || *pch=='\n')
+ linefeed_here = pch;
+
+ /* line's too long; add a linefeed if we can */
+- if (pch-line_start>=column && linefeed_here!=NULL)
++ if (pos>=column && linefeed_here!=NULL)
+ {
+ *linefeed_here = '\n';
+ pch = line_start = linefeed_here + 1;
+ linefeed_here = NULL;
++ pos = 0;
++ }
++ else
++ {
++ pch = g_utf8_next_char (pch);
++ ++ pos;
+ }
+- else ++pch;
+ }
+ }
+
diff --git a/news/pan/pkg-descr b/news/pan/pkg-descr
new file mode 100644
index 000000000000..7dba56b05697
--- /dev/null
+++ b/news/pan/pkg-descr
@@ -0,0 +1,6 @@
+A powerful and easy to use newsreader for GNOME 2.
+
+Pan has many features for easy reading and posting, displaying
+and saving attachments, and offline newsreading.
+
+WWW: http://pan.rebelbase.com/
diff --git a/news/pan/pkg-plist b/news/pan/pkg-plist
new file mode 100644
index 000000000000..bc80927dfa34
--- /dev/null
+++ b/news/pan/pkg-plist
@@ -0,0 +1,39 @@
+bin/pan
+share/gnome/applications/pan.desktop
+share/gnome/pixmaps/pan.png
+share/locale/am/LC_MESSAGES/pan.mo
+share/locale/az/LC_MESSAGES/pan.mo
+share/locale/ca/LC_MESSAGES/pan.mo
+share/locale/cs/LC_MESSAGES/pan.mo
+share/locale/da/LC_MESSAGES/pan.mo
+share/locale/de/LC_MESSAGES/pan.mo
+share/locale/el/LC_MESSAGES/pan.mo
+share/locale/en_GB/LC_MESSAGES/pan.mo
+share/locale/es/LC_MESSAGES/pan.mo
+share/locale/et/LC_MESSAGES/pan.mo
+share/locale/fi/LC_MESSAGES/pan.mo
+share/locale/fr/LC_MESSAGES/pan.mo
+share/locale/ga/LC_MESSAGES/pan.mo
+share/locale/gl/LC_MESSAGES/pan.mo
+share/locale/hu/LC_MESSAGES/pan.mo
+share/locale/it/LC_MESSAGES/pan.mo
+share/locale/ja/LC_MESSAGES/pan.mo
+share/locale/ko/LC_MESSAGES/pan.mo
+share/locale/lt/LC_MESSAGES/pan.mo
+share/locale/lv/LC_MESSAGES/pan.mo
+share/locale/ms/LC_MESSAGES/pan.mo
+share/locale/nl/LC_MESSAGES/pan.mo
+share/locale/no/LC_MESSAGES/pan.mo
+share/locale/pl/LC_MESSAGES/pan.mo
+share/locale/pt/LC_MESSAGES/pan.mo
+share/locale/pt_BR/LC_MESSAGES/pan.mo
+share/locale/ru/LC_MESSAGES/pan.mo
+share/locale/sk/LC_MESSAGES/pan.mo
+share/locale/sl/LC_MESSAGES/pan.mo
+share/locale/sr/LC_MESSAGES/pan.mo
+share/locale/sr@Latn/LC_MESSAGES/pan.mo
+share/locale/sv/LC_MESSAGES/pan.mo
+share/locale/tr/LC_MESSAGES/pan.mo
+share/locale/uk/LC_MESSAGES/pan.mo
+share/locale/vi/LC_MESSAGES/pan.mo
+share/locale/zh_CN/LC_MESSAGES/pan.mo