aboutsummaryrefslogtreecommitdiffstats
path: root/news/s-news/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-06-21 00:18:29 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2013-06-21 00:18:29 +0800
commita7ee38adaf250f710f86c96750b89de8866aa064 (patch)
tree088b1501035085de576c28ccf5cd839ed017a58c /news/s-news/Makefile
parent42d5100ca2d2bb7fc46096c2adb5c996d562db77 (diff)
downloadfreebsd-ports-gnome-a7ee38adaf250f710f86c96750b89de8866aa064.tar.gz
freebsd-ports-gnome-a7ee38adaf250f710f86c96750b89de8866aa064.tar.zst
freebsd-ports-gnome-a7ee38adaf250f710f86c96750b89de8866aa064.zip
- Trim Makefile header
- Convert to PORT_OPTIONS - Add a missing directory to pkg-plist
Diffstat (limited to 'news/s-news/Makefile')
-rw-r--r--news/s-news/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/news/s-news/Makefile b/news/s-news/Makefile
index 99fff7f4b164..6331e8f7a719 100644
--- a/news/s-news/Makefile
+++ b/news/s-news/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: s-news
-# Date created: Jul 13 13:29:47 EEST 2004
-# Whom: Andrey Slusar <anray@FreeBSD.org>
-#
+# Created by: Andrey Slusar <anray@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= s-news
PORTVERSION= 0.1.11
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news
MASTER_SITES= http://www.lost.org.uk/
@@ -33,12 +29,14 @@ MAN8= expire.8 listactive.8 makehistory.8 newgroup.8 nntpd.8 overview.8 \
PORTDOCS= README README.conf README.suck TODO
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>