aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-14 05:05:03 +0800
committerpav <pav@FreeBSD.org>2005-09-14 05:05:03 +0800
commit2d31877cfc9c0d045df79be03cdc79b9f3e171d3 (patch)
tree3254cab1289583c7fe653537bf978b68b5ec8280 /news
parent9ff04752647b1238e02fa0ebc0e8c9770bbf033d (diff)
downloadfreebsd-ports-gnome-2d31877cfc9c0d045df79be03cdc79b9f3e171d3.tar.gz
freebsd-ports-gnome-2d31877cfc9c0d045df79be03cdc79b9f3e171d3.tar.zst
freebsd-ports-gnome-2d31877cfc9c0d045df79be03cdc79b9f3e171d3.zip
- Fix xover head filtering
PR: ports/86045 Submitted by: SANETO Takanori <sanewo@ba2.so-net.ne.jp>
Diffstat (limited to 'news')
-rw-r--r--news/nntpcache/Makefile2
-rw-r--r--news/nntpcache/files/patch-src-acc.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index b51ca5da3e33..53060d21c9c3 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nntpcache
PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news
MASTER_SITES= ftp://ftp.cs.tu-berlin.de/pub/net/news/nntpcache/ \
ftp://ftp.sbs.de/pub/news/servers/nntpcache/ \
diff --git a/news/nntpcache/files/patch-src-acc.c b/news/nntpcache/files/patch-src-acc.c
new file mode 100644
index 000000000000..f5de8a38b1e2
--- /dev/null
+++ b/news/nntpcache/files/patch-src-acc.c
@@ -0,0 +1,11 @@
+--- src/acc.c.orig Sat Feb 19 12:16:21 2000
++++ src/acc.c Tue Sep 13 23:00:32 2005
+@@ -195,7 +195,7 @@
+ loge (("bad filter header/scope %s in file %s: %s", scope, fi, buf));
+ Exit(1);
+ }
+- *p='\0';
++ /* *p='\0'; */
+ f->scope = sc_header;
+ f->scope_header = Sstrdup(scope);
+ }