aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-03-13 20:27:28 +0800
committerJohan van Selst <johans@FreeBSD.org>2011-03-13 20:27:28 +0800
commit58760bf42d70d1be87b15a78ab685a140b04d359 (patch)
treefe785cd61597ba9164df4cc82df150420c452026 /news
parentb256c38cb5ef79dc2637bef27d8e078ec0761c04 (diff)
downloadfreebsd-ports-gnome-58760bf42d70d1be87b15a78ab685a140b04d359.tar.gz
freebsd-ports-gnome-58760bf42d70d1be87b15a78ab685a140b04d359.tar.zst
freebsd-ports-gnome-58760bf42d70d1be87b15a78ab685a140b04d359.zip
Port cleanup
- Honour WITHOUT_NLS - Explicitly remove rw locale directory (fixes plist) - Set maintainer explicitly (this is not a master port) - Set CFLAGS/CPPFLAGS (these are passed automatically these days) - Remove MD5 checksum - Bump portrevision
Diffstat (limited to 'news')
-rw-r--r--news/tin/Makefile23
-rw-r--r--news/tin/distinfo1
-rw-r--r--news/tin/pkg-plist18
3 files changed, 26 insertions, 16 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 5f87181eadea..ac2d2095f948 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tin
PORTVERSION= 1.8.3
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES+= news ipv6
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/stable/ \
ftp://ftp.sunet.se/pub/news/readers/tin/stable/ \
@@ -22,7 +22,7 @@ MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/stable/ \
ftp://ftp.cs.tu-berlin.de/pub/net/news/tin/stable/ \
ftp://ftp.informatik.uni-hamburg.de/pub/soft/news/tin/stable/
-MAINTAINER?= johans@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= Easy-to-use threaded newsreader with NOV/NNTP support
LIB_DEPENDS= uu.3:${PORTSDIR}/converters/uulib \
@@ -30,7 +30,6 @@ LIB_DEPENDS= uu.3:${PORTSDIR}/converters/uulib \
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
@@ -58,16 +57,15 @@ CONFIGURE_ARGS+=--with-nntp-default-server=news \
--with-libdir=${PREFIX}/news/lib \
--with-defaults-dir=${PREFIX}/etc \
--with-editor=${TIN_EDITOR} \
- --enable-nls \
--with-pcre=yes \
--with-screen=${TIN_SCREEN} \
--enable-break-long-lines \
--with-libiconv-prefix=${LOCALBASE} \
--with-mime-default-charset=US-ASCII \
--enable-ipv6
-CONFIGURE_ENV= CFLAGS='${CFLAGS} -DNNTP_SERVER_FILE="\"${PREFIX}/etc/nntpserver\""' \
- CPPFLAGS='${CPPFLAGS} -I${LOCALBASE}/include' \
- LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
+CFLAGS+= -DNNTP_SERVER_FILE=\\\"${PREFIX}/etc/nntpserver\\\"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
ALL_TARGET= build
MAN1= tin.1 w2r.pl.1 opt-case.pl.1 tinews.pl.1
MAN5= tin.5 tin_mbox.5 tin_mmdf.5
@@ -99,6 +97,15 @@ RUN_DEPENDS+= metamail:${PORTSDIR}/mail/metamail
CONFIGURE_ARGS+= --with-metamail=${PREFIX}/bin/metamail
.endif
+.ifdef WITHOUT_NLS
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+CONFIGURE_ARGS+= --enable-nls
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
post-patch:
${REINPLACE_CMD} -Ee 's:5/(mmdf|mbox):5/tin_\1:g' \
${WRKSRC}/src/Makefile.in
@@ -128,7 +135,9 @@ pre-build:
.endif
post-build:
+.ifndef WITHOUT_NLS
cd ${WRKSRC}/po; ${GMAKE}
+.endif
post-install:
cd ${WRKSRC}/doc; ${INSTALL_DATA} tin.defaults ${PREFIX}/etc/tin.defaults.dist
diff --git a/news/tin/distinfo b/news/tin/distinfo
index 3904b98613c5..348457f55b40 100644
--- a/news/tin/distinfo
+++ b/news/tin/distinfo
@@ -1,3 +1,2 @@
-MD5 (tin-1.8.3.tar.bz2) = e6ed45205020665c097556822b0d575b
SHA256 (tin-1.8.3.tar.bz2) = 5ed70aff723181b6c8e26923a96054f7e2376204bf62b9a49fdf2b677f283f9f
SIZE (tin-1.8.3.tar.bz2) = 1437604
diff --git a/news/tin/pkg-plist b/news/tin/pkg-plist
index 32f2f75fbbc9..8dca56eda8c4 100644
--- a/news/tin/pkg-plist
+++ b/news/tin/pkg-plist
@@ -9,11 +9,13 @@ bin/w2r.pl
@unexec if cmp -s %D/etc/tin.defaults %D/etc/tin.defaults.dist; then rm -f %D/etc/tin.defaults; fi
etc/tin.defaults.dist
@exec [ -f %B/tin.defaults ] || cp %B/%f %B/tin.defaults
-share/locale/de/LC_MESSAGES/tin.mo
-share/locale/en_GB/LC_MESSAGES/tin.mo
-share/locale/et/LC_MESSAGES/tin.mo
-share/locale/fr/LC_MESSAGES/tin.mo
-share/locale/ru/LC_MESSAGES/tin.mo
-share/locale/rw/LC_MESSAGES/tin.mo
-share/locale/sv/LC_MESSAGES/tin.mo
-share/locale/tr/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/de/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/et/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/tin.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/tin.mo
+%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/rw