aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2019-05-10 12:31:53 +0800
committertcberner <tcberner@FreeBSD.org>2019-05-10 12:31:53 +0800
commit66b35a629f70f81398f2e8b64dbe745632f1e434 (patch)
tree34bf56c1b8236bb0b96699b57d0a2240274f510f /news
parent9b1c921512897ba699762f61fb6a5867a659913d (diff)
downloadfreebsd-ports-gnome-66b35a629f70f81398f2e8b64dbe745632f1e434.tar.gz
freebsd-ports-gnome-66b35a629f70f81398f2e8b64dbe745632f1e434.tar.zst
freebsd-ports-gnome-66b35a629f70f81398f2e8b64dbe745632f1e434.zip
news/nzbhydra2: Update to 2.6.2
- USE flag for python changed to python:2.7 as 3.x is not supported at this time. Changelog can be viewed at: https://github.com/theotherp/nzbhydra2/blob/master/changelog.md Submitted by: Daniel Shafer <daniel shafer cc> (maintainer) Differential Revision: https://reviews.freebsd.org/D20164
Diffstat (limited to 'news')
-rw-r--r--news/nzbhydra2/Makefile6
-rw-r--r--news/nzbhydra2/distinfo6
-rw-r--r--news/nzbhydra2/files/nzbhydra2wrapper.py.in2
3 files changed, 7 insertions, 7 deletions
diff --git a/news/nzbhydra2/Makefile b/news/nzbhydra2/Makefile
index 3c9864997fd8..74076fe364b2 100644
--- a/news/nzbhydra2/Makefile
+++ b/news/nzbhydra2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= nzbhydra2
-DISTVERSION= 2.3.16
+DISTVERSION= 2.6.2
DISTVERSIONSUFFIX= -linux
CATEGORIES= news java
MASTER_SITES= https://github.com/theotherp/${PORTNAME}/releases/download/v${DISTVERSION}/
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64
-USES= python shebangfix zip
+USES= python:2.7 shebangfix zip
USE_JAVA= yes
USE_RC_SUBR= nzbhydra2
@@ -32,7 +32,7 @@ JAVA_RUN= yes
USERS= nzbhydra2
GROUPS= nzbhydra2
-PLIST_FILES= ${DATADIR}/lib/core-2.3.16-exec.jar \
+PLIST_FILES= ${DATADIR}/lib/core-2.6.2-exec.jar \
${DATADIR}/nzbhydra2 \
${DATADIR}/nzbhydra2wrapper.py \
${DATADIR}/changelog.md \
diff --git a/news/nzbhydra2/distinfo b/news/nzbhydra2/distinfo
index 980da7c2cacd..b8570d52b9ab 100644
--- a/news/nzbhydra2/distinfo
+++ b/news/nzbhydra2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1552779735
-SHA256 (nzbhydra2-2.3.16-linux.zip) = 9cf8fde9f1e40c2894fff6798c8a1dc22be4904c9542e7e9250409f2dbae5e33
-SIZE (nzbhydra2-2.3.16-linux.zip) = 70170041
+TIMESTAMP = 1557086555
+SHA256 (nzbhydra2-2.6.2-linux.zip) = c25c893e064509f74bcb2b4861790773497412b83a7e39794bfdf2f6674d5101
+SIZE (nzbhydra2-2.6.2-linux.zip) = 71193980
diff --git a/news/nzbhydra2/files/nzbhydra2wrapper.py.in b/news/nzbhydra2/files/nzbhydra2wrapper.py.in
index ea28452b407e..d4d6e83da834 100644
--- a/news/nzbhydra2/files/nzbhydra2wrapper.py.in
+++ b/news/nzbhydra2/files/nzbhydra2wrapper.py.in
@@ -490,7 +490,7 @@ def getJavaVersion(javaExecutable):
if len(lines) == 0:
raise Exception("Unable to get output from call to java -version")
versionLine = lines[0].replace("\n", "").replace("\r", "")
- match = re.match('(java|openjdk) version "(?P<major>\d+)(\.(?P<minor>\d+)\.(?P<patch>\d)+[\-_\w]*)?".*', versionLine)
+ match = re.match('(java|openjdk) version "(?P<major>\d+)((\.(?P<minor>\d+)\.(?P<patch>\d)+)?[\-_\w]*)?".*', versionLine)
if match is None:
raise Exception("Unable to determine java version from string " + lines[0])
javaMajor = int(match.group("major"))