aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2014-04-16 23:14:29 +0800
committerfeld <feld@FreeBSD.org>2014-04-16 23:14:29 +0800
commit8c4ca0ca91bdd847809eb3611dbd5432c2abe0d6 (patch)
tree11b89d3cd6a9628da6243b060b28bb4da20bddcf /news
parentadeff42fc0f48fe258b8d0de1ad29f9d2a1e5873 (diff)
downloadfreebsd-ports-gnome-8c4ca0ca91bdd847809eb3611dbd5432c2abe0d6.tar.gz
freebsd-ports-gnome-8c4ca0ca91bdd847809eb3611dbd5432c2abe0d6.tar.zst
freebsd-ports-gnome-8c4ca0ca91bdd847809eb3611dbd5432c2abe0d6.zip
Just spotted in the 0.7.17 changelog they implemented my request for full
control over the pidfile! Now we no longer scrape the config file to guess its name, which was based on both the hostname of the server and the port. Previously, if you changed the hostname of your server you could no longer signal the running sabnzbd process through the rc framework...
Diffstat (limited to 'news')
-rw-r--r--news/sabnzbdplus/Makefile1
-rw-r--r--news/sabnzbdplus/files/sabnzbd.in6
2 files changed, 5 insertions, 2 deletions
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 51af27e4625f..73abb558b8c3 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sabnzbdplus
PORTVERSION= 0.7.17
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
DISTNAME= SABnzbd-${PORTVERSION}-src
diff --git a/news/sabnzbdplus/files/sabnzbd.in b/news/sabnzbdplus/files/sabnzbd.in
index 44d7e6bac831..c00f110a683d 100644
--- a/news/sabnzbdplus/files/sabnzbd.in
+++ b/news/sabnzbdplus/files/sabnzbd.in
@@ -22,6 +22,7 @@
# you want it to be. It uses '_sabnzbd' group by
# default. Do not sets it as empty or it will run
# as wheel.
+# sabnzbd_pidfile: Set the location of the sabnzbd pidfile
. /etc/rc.subr
@@ -33,14 +34,15 @@ load_rc_config ${name}
: ${sabnzbd_user:=_sabnzbd}
: ${sabnzbd_group:=_sabnzbd}
: ${sabnzbd_conf_dir="%%PREFIX%%/sabnzbd"}
+: ${sabnzbd_pidfile:="/var/run/sabnzbd/sabnzbd.pid"}
-pidfile=/var/run/sabnzbd/sabnzbd-$(grep -m1 ^port ${sabnzbd_conf_dir}/sabnzbd.ini | tr -dc '[0-9]').pid
+pidfile=${sabnzbd_pidfile}
start_precmd="${name}_prestart"
extra_commands="status"
command_interpreter="%%PYTHON_CMD%%"
command="%%PREFIX%%/bin/SABnzbd.py"
-command_args="--daemon -f ${sabnzbd_conf_dir}/sabnzbd.ini --pid ${pidfile%/*}"
+command_args="--daemon -f ${sabnzbd_conf_dir}/sabnzbd.ini --pidfile ${pidfile}"
sabnzbd_prestart()
{