aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authortorstenb <torstenb@FreeBSD.org>1995-10-06 22:33:05 +0800
committertorstenb <torstenb@FreeBSD.org>1995-10-06 22:33:05 +0800
commit8ce403d05f8cc4372615f628367ce8ccd14113b3 (patch)
treea25b711d29b8b669942e39d8d204e04a453eeb31 /news
parentdd50157b0da8a46a33bdb260cc1d2645fa2a4e6e (diff)
downloadfreebsd-ports-gnome-8ce403d05f8cc4372615f628367ce8ccd14113b3.tar.gz
freebsd-ports-gnome-8ce403d05f8cc4372615f628367ce8ccd14113b3.tar.zst
freebsd-ports-gnome-8ce403d05f8cc4372615f628367ce8ccd14113b3.zip
- add an `update' target (won't overwrite configuration files
- install libinn.a and it's header files
Diffstat (limited to 'news')
-rw-r--r--news/inn-current/Makefile17
-rw-r--r--news/inn-stable/Makefile17
-rw-r--r--news/inn/Makefile17
3 files changed, 48 insertions, 3 deletions
diff --git a/news/inn-current/Makefile b/news/inn-current/Makefile
index 94edbb483983..22f53c31cf36 100644
--- a/news/inn-current/Makefile
+++ b/news/inn-current/Makefile
@@ -3,7 +3,7 @@
# Date created: 20 Oct 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.9 1995/07/02 10:08:13 torstenb Exp $
+# $Id: Makefile,v 1.10 1995/08/08 21:50:39 torstenb Exp $
#
DISTNAME= inn1.4sec
@@ -25,7 +25,19 @@ NO_WRKSUBDIR= YES
pre-install:
mkdir -p ${PREFIX}/news
+update: build
+ @(cd ${WRKSRC} ; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} update)
+ @${MAKE} ${.MAKEFLAGS} post-install
+
post-install:
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/lib/libinn.a \
+ ${PREFIX}/lib/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/inndcomm.h \
+ ${PREFIX}/include/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/libinn.h \
+ ${PREFIX}/include/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/qio.h \
+ ${PREFIX}/include/
if [ -d /var/spool/news ] && [ ! -d /var/news ]; then \
mkdir -m 0775 -p /var/spool/news/over.view; \
chown news.news /var/spool/news/over.view; \
@@ -33,6 +45,9 @@ post-install:
mkdir -m 0775 -p /var/news/over.view; \
chown news.news /var/news/over.view; \
fi
+ -mkdir ${PREFIX}/news/locks
+ chown news.news ${PREFIX}/news/locks
+ chmod 0755 ${PREFIX}/news/locks
gzip -9nf ${PREFIX}/man/man1/convdate.1 ${PREFIX}/man/man1/getlist.1 \
${PREFIX}/man/man1/grephistory.1 ${PREFIX}/man/man1/inews.1 \
${PREFIX}/man/man1/innconfval.1 ${PREFIX}/man/man1/installit.1 \
diff --git a/news/inn-stable/Makefile b/news/inn-stable/Makefile
index 94edbb483983..22f53c31cf36 100644
--- a/news/inn-stable/Makefile
+++ b/news/inn-stable/Makefile
@@ -3,7 +3,7 @@
# Date created: 20 Oct 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.9 1995/07/02 10:08:13 torstenb Exp $
+# $Id: Makefile,v 1.10 1995/08/08 21:50:39 torstenb Exp $
#
DISTNAME= inn1.4sec
@@ -25,7 +25,19 @@ NO_WRKSUBDIR= YES
pre-install:
mkdir -p ${PREFIX}/news
+update: build
+ @(cd ${WRKSRC} ; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} update)
+ @${MAKE} ${.MAKEFLAGS} post-install
+
post-install:
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/lib/libinn.a \
+ ${PREFIX}/lib/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/inndcomm.h \
+ ${PREFIX}/include/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/libinn.h \
+ ${PREFIX}/include/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/qio.h \
+ ${PREFIX}/include/
if [ -d /var/spool/news ] && [ ! -d /var/news ]; then \
mkdir -m 0775 -p /var/spool/news/over.view; \
chown news.news /var/spool/news/over.view; \
@@ -33,6 +45,9 @@ post-install:
mkdir -m 0775 -p /var/news/over.view; \
chown news.news /var/news/over.view; \
fi
+ -mkdir ${PREFIX}/news/locks
+ chown news.news ${PREFIX}/news/locks
+ chmod 0755 ${PREFIX}/news/locks
gzip -9nf ${PREFIX}/man/man1/convdate.1 ${PREFIX}/man/man1/getlist.1 \
${PREFIX}/man/man1/grephistory.1 ${PREFIX}/man/man1/inews.1 \
${PREFIX}/man/man1/innconfval.1 ${PREFIX}/man/man1/installit.1 \
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 94edbb483983..22f53c31cf36 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -3,7 +3,7 @@
# Date created: 20 Oct 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.9 1995/07/02 10:08:13 torstenb Exp $
+# $Id: Makefile,v 1.10 1995/08/08 21:50:39 torstenb Exp $
#
DISTNAME= inn1.4sec
@@ -25,7 +25,19 @@ NO_WRKSUBDIR= YES
pre-install:
mkdir -p ${PREFIX}/news
+update: build
+ @(cd ${WRKSRC} ; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} update)
+ @${MAKE} ${.MAKEFLAGS} post-install
+
post-install:
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/lib/libinn.a \
+ ${PREFIX}/lib/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/inndcomm.h \
+ ${PREFIX}/include/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/libinn.h \
+ ${PREFIX}/include/
+ install -c -o bin -g bin -m 0444 ${WRKSRC}/include/qio.h \
+ ${PREFIX}/include/
if [ -d /var/spool/news ] && [ ! -d /var/news ]; then \
mkdir -m 0775 -p /var/spool/news/over.view; \
chown news.news /var/spool/news/over.view; \
@@ -33,6 +45,9 @@ post-install:
mkdir -m 0775 -p /var/news/over.view; \
chown news.news /var/news/over.view; \
fi
+ -mkdir ${PREFIX}/news/locks
+ chown news.news ${PREFIX}/news/locks
+ chmod 0755 ${PREFIX}/news/locks
gzip -9nf ${PREFIX}/man/man1/convdate.1 ${PREFIX}/man/man1/getlist.1 \
${PREFIX}/man/man1/grephistory.1 ${PREFIX}/man/man1/inews.1 \
${PREFIX}/man/man1/innconfval.1 ${PREFIX}/man/man1/installit.1 \