aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-25 00:23:43 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-25 00:23:43 +0800
commit9a2734904c37b83ec05ca199e4c52be2d926a084 (patch)
treeb61e1c2a3e71083bcbefc2ae3ed69eeee6413fcd /news
parentaf36f69a8b78d659db7570da5da28eb2360c6031 (diff)
downloadfreebsd-ports-gnome-9a2734904c37b83ec05ca199e4c52be2d926a084.tar.gz
freebsd-ports-gnome-9a2734904c37b83ec05ca199e4c52be2d926a084.tar.zst
freebsd-ports-gnome-9a2734904c37b83ec05ca199e4c52be2d926a084.zip
- Try to unbreak parallel builds (-jX); respect CC/LD and CFLAGS
- Trim Makefile header, fix a typo in email address - Convert USE_GMAKE, define LICENSE (GPLv2), sort the knobs - Allow non-root installation: pre-install should be pre-su-install since it touches non-user writable directory - Make INSTALL_DATA command atomic and $cwd-agnostic - While here, fix port description: drop explicit author attribution and use space, not tab, after WWW: per PH section 3.2.1 Approved by: miwi, bapt (portmgr, implicit)
Diffstat (limited to 'news')
-rw-r--r--news/sn/Makefile31
-rw-r--r--news/sn/pkg-descr9
2 files changed, 22 insertions, 18 deletions
diff --git a/news/sn/Makefile b/news/sn/Makefile
index 23e81cff64e2..b2af8da0b6c7 100644
--- a/news/sn/Makefile
+++ b/news/sn/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sn
-# Date created: 2004-02-21
-# Whom: Andreas Fehlner <fehlner@gmx.del>
-#
+# Created by: Andreas Fehlner <fehlner@gmx.de>
# $FreeBSD$
-#
PORTNAME= sn
PORTVERSION= 0.3.8
@@ -15,28 +11,39 @@ MASTER_SITES= http://www.infa.abo.fi/~patrik/sn/files/ \
MAINTAINER= fehlner@gmx.de
COMMENT= Small news system for small sites serving
+LICENSE= GPLv2
+
+USES= gmake
+USE_BZIP2= yes
+MAKE_ARGS= PREFIX="${PREFIX}" CC="${CC}" LD="${CC}"
+
PORTDOCS= README CHANGES FAQ INSTALL INTERNALS \
THANKS TODO INSTALL.notes INSTALL.notes2 \
INSTALL.run INSTALL.upgrade
-USE_BZIP2= yes
-USE_GMAKE= yes
-
MAN8= sn.8 sncancel.8 sncat.8 sndelgroup.8 sndumpdb.8 \
snexpire.8 snfetch.8 snget.8 sngetd.8 snmail.8 \
snnewgroup.8 snntpd.8 snprimedb.8 snscan.8 snsend.8 \
snsplit.8 snstore.8
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+# Try to fix parallel builds (-jX); respect CFLAGS
post-patch:
- @${REINPLACE_CMD} -e 's|^PREFIX|#PREFIX|g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|sn\.a$$|& lib/libstuff.a| ; \
+ s|snlockf\.o$$|& lib/libstuff.a| ; \
+ s|-g -Wall -pedantic -O|${CFLAGS} -Wall -pedantic|' \
+ ${WRKSRC}/Makefile
-pre-install:
+pre-su-install:
@${MKDIR} /var/spool/news
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/news/sn/pkg-descr b/news/sn/pkg-descr
index 37c5e7a70f60..0bc60b400f37 100644
--- a/news/sn/pkg-descr
+++ b/news/sn/pkg-descr
@@ -1,10 +1,7 @@
sn a small news system for small sites serving perhaps a few dozen
-newsgroups, and with a slow connection to the internet. It is similar
-to Leafnode. The target user is a home or SOHO with a single modem
+newsgroups, and with a slow connection to the internet; similar to
+Leafnode. The target user is a home or SOHO with a single modem
connection to the Internet, maybe running IP masq or similar, and
serving a few workstations.
-WWW: http://infa.abo.fi/~patrik/sn/
-
--Andreas Fehlner
-fehlner@gmx.de
+WWW: http://infa.abo.fi/~patrik/sn/