aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-07 01:29:37 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-07 01:29:37 +0800
commitb7a376cd6f8a55e2c6827a4ef3cb8272286d7f78 (patch)
tree03d68b4323c8b1d4f72c06376749dbad614741ba /news
parent5cf549dd6fc9e4293745270a1c8b3ef142dd4fc2 (diff)
downloadfreebsd-ports-gnome-b7a376cd6f8a55e2c6827a4ef3cb8272286d7f78.tar.gz
freebsd-ports-gnome-b7a376cd6f8a55e2c6827a4ef3cb8272286d7f78.tar.zst
freebsd-ports-gnome-b7a376cd6f8a55e2c6827a4ef3cb8272286d7f78.zip
add newsgrag
Download and uuencode binary files from USENET using regexps PR: 280687 Submitted by: Pete Fritchman <petef@databits.net>
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/newsgrab/Makefile27
-rw-r--r--news/newsgrab/distinfo1
-rw-r--r--news/newsgrab/pkg-comment1
-rw-r--r--news/newsgrab/pkg-descr8
-rw-r--r--news/newsgrab/pkg-plist3
6 files changed, 41 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index 2cdca185f57c..92d125a7e38c 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -25,6 +25,7 @@
SUBDIR += leafnode+
SUBDIR += newsfetch
SUBDIR += newsfish
+ SUBDIR += newsgrab
SUBDIR += newsx
SUBDIR += nn
SUBDIR += nntp
diff --git a/news/newsgrab/Makefile b/news/newsgrab/Makefile
new file mode 100644
index 000000000000..38c5a830e633
--- /dev/null
+++ b/news/newsgrab/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: newsgrab
+# Date Created: 11 June 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newsgrab
+PORTVERSION= 0.1.1
+CATEGORIES= news
+MASTER_SITES= http://phunkbros.dk/newsgrab/
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/News/NNTPClient.pm:${PORTSDIR}/news/p5-NNTPClient
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/newsgrab.pl ${PREFIX}/bin/newsgrab
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/newsgrab
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/newsgrab
+.endif
+
+.include <bsd.port.mk>
diff --git a/news/newsgrab/distinfo b/news/newsgrab/distinfo
new file mode 100644
index 000000000000..cdd365165822
--- /dev/null
+++ b/news/newsgrab/distinfo
@@ -0,0 +1 @@
+MD5 (newsgrab-0.1.1.tar.gz) = 04d59241c5759363ff4c39f63e6f28c0
diff --git a/news/newsgrab/pkg-comment b/news/newsgrab/pkg-comment
new file mode 100644
index 000000000000..3b8db6b0a912
--- /dev/null
+++ b/news/newsgrab/pkg-comment
@@ -0,0 +1 @@
+Download and uuencode binary files from USENET using regexps
diff --git a/news/newsgrab/pkg-descr b/news/newsgrab/pkg-descr
new file mode 100644
index 000000000000..8f4a979b2682
--- /dev/null
+++ b/news/newsgrab/pkg-descr
@@ -0,0 +1,8 @@
+Based on a given regular expression and news group, newsgrab will
+connect to your NNTP server and download all the binaries in articles
+that match the given regexp and uudecode them.
+
+WWW: http://phunkbros.dk/?page=goodiebag
+
+- Pete
+petef@databits.net
diff --git a/news/newsgrab/pkg-plist b/news/newsgrab/pkg-plist
new file mode 100644
index 000000000000..ba97a275ca13
--- /dev/null
+++ b/news/newsgrab/pkg-plist
@@ -0,0 +1,3 @@
+bin/newsgrab
+%%PORTDOCS%%share/doc/newsgrab/README
+%%PORTDOCS%%@dirrm share/doc/newsgrab