aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-06-16 23:03:10 +0800
committerdinoex <dinoex@FreeBSD.org>2002-06-16 23:03:10 +0800
commitfd64cc1ce59cc2c7732d14183fbb09c1530a6fca (patch)
treef2b90f36648fe13ed28fdddbabab21b4f8e0d784 /news
parent95776cd25c1f4f9a7a4a975fd6c165ae559dc920 (diff)
downloadfreebsd-ports-gnome-fd64cc1ce59cc2c7732d14183fbb09c1530a6fca.tar.gz
freebsd-ports-gnome-fd64cc1ce59cc2c7732d14183fbb09c1530a6fca.tar.zst
freebsd-ports-gnome-fd64cc1ce59cc2c7732d14183fbb09c1530a6fca.zip
- Get rid of PERL and use SED
Diffstat (limited to 'news')
-rw-r--r--news/cnews/Makefile2
-rw-r--r--news/ifmail/Makefile5
-rw-r--r--news/suck/Makefile14
3 files changed, 12 insertions, 9 deletions
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index ea268ad77977..3f970e59bb6a 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -86,7 +86,7 @@ pre-configure:
-e "s=/var/news/over.view=${NEWSOV}=" \
-e "s=/var/news=${NEWSARTS}=" \
-e "s=/usr/local/bin=${PREFIX}/bin=" \
- ${WRKSRC}/${i}.sed >${WRKSRC}/${i}
+ ${WRKSRC}/${i}.sed > ${WRKSRC}/${i}
.endfor
do-install:
diff --git a/news/ifmail/Makefile b/news/ifmail/Makefile
index 32bd80815e25..b83847383cef 100644
--- a/news/ifmail/Makefile
+++ b/news/ifmail/Makefile
@@ -19,8 +19,9 @@ MAN8= ifmail.8 iftoss.8
.if defined(IFMAIL_RUNAS)
pre-configure:
- @${PERL5} -pi -e "s/OWNER = ifmail/OWNER = ${IFMAIL_RUNAS}/" \
- ${WRKSRC}/CONFIG
+ @${MV} ${WRKSRC}/CONFIG ${WRKSRC}/CONFIG.sed
+ ${SED} -e "s/OWNER = ifmail/OWNER = ${IFMAIL_RUNAS}/" \
+ ${WRKSRC}/CONFIG.sed > ${WRKSRC}/CONFIG
.endif
pre-install:
diff --git a/news/suck/Makefile b/news/suck/Makefile
index 92f4c61eb287..02536a38d043 100644
--- a/news/suck/Makefile
+++ b/news/suck/Makefile
@@ -31,18 +31,20 @@ BUILD_DEPENDS+= ${LOCALBASE}/news/lib/libinn.a:${PORTSDIR}/news/inn
.include <bsd.port.pre.mk>
.if defined(SUCK_WITH_SSL) || defined(WITH_SSL)
-.include <${PORTSDIR}/security/openssl/Makefile.ssl>
+.include "${PORTSDIR}/security/openssl/Makefile.ssl"
MAKE_ENV+= SSL_LIB="-lssl -lcrypto"
MAKE_ENV+= SSL_DEFS="-I${OPENSSLINC} -DHAVE_LIBSSL"
MAKE_ENV+= SSL_LIB_LOC="-L${OPENSSLLIB}"
.endif
post-patch:
- @${PERL5} -pi -e "s=/usr/local/=${LOCALBASE}/=" ${WRKSRC}/Makefile.in
- @${PERL5} -pi -e "s=/usr/local/lib/suck=${PREFIX}/lib/suck=" \
- ${WRKSRC}/suck_config.h
- @${PERL5} -pi -e "s=/usr/local/news/lib=${LOCALBASE}/news/lib=" \
- ${WRKSRC}/suck_config.h
+ @${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.sed
+ ${SED} -e "s=/usr/local/=${LOCALBASE}/=" \
+ ${WRKSRC}/Makefile.in.sed > ${WRKSRC}/Makefile.in
+ @${MV} ${WRKSRC}/suck_config.h ${WRKSRC}/suck_config.h.sed
+ ${SED} -e "s=/usr/local/lib/suck=${PREFIX}/lib/suck=" \
+ -e "s=/usr/local/news/lib=${LOCALBASE}/news/lib=" \
+ ${WRKSRC}/suck_config.h.sed > ${WRKSRC}/suck_config.h
.if !defined(NOPORTDOCS)
post-install: