aboutsummaryrefslogtreecommitdiffstats
path: root/palm/coldsync/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-12-28 05:11:59 +0800
committermi <mi@FreeBSD.org>2002-12-28 05:11:59 +0800
commit9fcdcb89a45677a18e68161b9588fbc22ae798fa (patch)
treeda2547a970973f51f538f2aff420cd66c5f47435 /palm/coldsync/Makefile
parentf86890b79ba0e3bf8a0d34a0430c46d0b2d0a375 (diff)
downloadfreebsd-ports-gnome-9fcdcb89a45677a18e68161b9588fbc22ae798fa.tar.gz
freebsd-ports-gnome-9fcdcb89a45677a18e68161b9588fbc22ae798fa.tar.zst
freebsd-ports-gnome-9fcdcb89a45677a18e68161b9588fbc22ae798fa.zip
Upgrade to the latest stable version -- 2.2.5, which supports Palms in
addition to Handspring, so there is no need for patch-palm any more. Remove the Perl parts of this port. They will be turned into the new p5-coldsync. Now, that the port no longer uses Perl, switch back to REINPLACE and rephrase the regexps, so they work (\S was a perlism). Make patch-in6 a little nicer by making coldsync.c define _POSIX_SOURCE as 200112 -- the only way to cause netinet/in.h to include netinet6/in6.h, apparently. Reviewed by: knu (portmgr) Approved by: maintainer, portmgr
Diffstat (limited to 'palm/coldsync/Makefile')
-rw-r--r--palm/coldsync/Makefile43
1 files changed, 28 insertions, 15 deletions
diff --git a/palm/coldsync/Makefile b/palm/coldsync/Makefile
index 0af6dde0ab30..07b73f4d1737 100644
--- a/palm/coldsync/Makefile
+++ b/palm/coldsync/Makefile
@@ -6,46 +6,59 @@
#
PORTNAME= coldsync
-PORTVERSION= 2.1.3
-PORTREVISION= 3
+PORTVERSION= 2.2.5
CATEGORIES= palm comms
MASTER_SITES= http://www.coldsync.org/download/
MAINTAINER= arensb+freebsd-ports@ooblick.com
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Palm/PDB.pm:${PORTSDIR}/palm/p5-Palm
-USE_PERL= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i "" -E
GNU_CONFIGURE= yes
-# The ColdSync.3 man page describes a Perl package. That's why it goes
-# in the Perl manpage directory.
-MAN1= send-mail.1 \
- todo-text.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= ColdSync.3 \
- ColdSync::SPC.3
+MAN3= libpconn.3 DlpAddSyncLogEntry.3 DlpCallApplication.3 \
+ DlpCleanUpDataBase.3 DlpDeleteRecord.3 DlpEndOfSync.3 \
+ DlpGetSysDateTime.3 DlpMoveCategory.3 DlpOpenConduit.3 \
+ DlpOpenDB.3 DlpRPC.3 DlpReadAppBlock.3 \
+ DlpReadAppPreference.3 DlpReadDBList.3 DlpReadFeature.3 \
+ DlpReadNetSyncInfo.3 DlpReadOpenDBInfo.3 \
+ DlpReadRecordByID.3 DlpReadRecordIDList.3 \
+ DlpReadResourceByIndex.3 DlpReadStorageInfo.3 \
+ DlpReadSysInfo.3 DlpReadUserInfo.3 DlpResetRecordIndex.3 \
+ DlpResetSyncFlags.3 DlpResetSystem.3 DlpWriteRecord.3 \
+ DlpWriteResource.3 PConnClose.3 PConn_bind.3 \
+ RDLP_Backlight.3 RDLP_BatteryDialog.3 \
+ RDLP_GetOSVersionString.3 RDLP_MemHandleNew.3 \
+ RDLP_PluggedIn.3 RDLP_ROMToken.3 new_PConnection.3 \
+ time_dlp2palmtime.3 libpdb.3 new_Record.3 \
+ new_pdb.3 pdb_AppendRecord.3 pdb_CopyRecord.3 \
+ pdb_DeleteRecordByID.3 pdb_FindRecordByID.3 \
+ pdb_LoadHeader.3 pdb_Read.3
MAN8= coldsync.8
MANCOMPRESSED= no
.include <bsd.port.pre.mk>
CFLAGS+= -D__BSD_VISIBLE=1
-CONFIGURE_ARGS+= --with-i18n --disable-pedantic
+CONFIGURE_ARGS+= --with-i18n --disable-pedantic --without-perl
# I don't know how to test for a version of {Net,Open}BSD that supports USB.
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 400000
CONFIGURE_ARGS+= --with-usb
.if ${OSVERSION} >= 450000
post-patch:
- ${PERL} -pi -e 's,udi\.(\S+),udi.udi_\1,g;' \
- -e 's,ur\.(\S+),ur.ucr_\1,g;' \
+ ${REINPLACE_CMD} -e 's,udi\.([A-Za-z0-9]+),udi.udi_\1,g;' \
+ -e 's,ur\.([A-Za-z0-9]+),ur.ucr_\1,g;' \
${WRKSRC}/configure ${WRKSRC}/libpconn/PConnection_usb.c
.endif
.endif
post-install:
- @install-info ${PREFIX}/info/conduits.info ${PREFIX}/info/dir
+ install-info ${PREFIX}/info/conduits.info ${PREFIX}/info/dir
+ ${MKDIR} ${PREFIX}/include/pconn
+ ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/include/pconn/*.h ${PREFIX}/include/pconn/
.include <bsd.port.post.mk>