aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-06-09 08:25:42 +0800
committersteve <steve@FreeBSD.org>1999-06-09 08:25:42 +0800
commitda9028dc2b7a6c53821c92c0ca64ee8c4627cdd1 (patch)
tree05aaa7962b39811022437e0ad66351c918e81ff1 /palm
parent99c4250cec01ab817a21ecdf642c5406c6b2bd18 (diff)
downloadfreebsd-ports-gnome-da9028dc2b7a6c53821c92c0ca64ee8c4627cdd1.tar.gz
freebsd-ports-gnome-da9028dc2b7a6c53821c92c0ca64ee8c4627cdd1.tar.zst
freebsd-ports-gnome-da9028dc2b7a6c53821c92c0ca64ee8c4627cdd1.zip
Initial impoirt of syncal version 0.5.
Synchronize your PalmPilot with ical. PR: 11304 Submitted by: Lars Koeller <lkoeller@cc.fh-lippe.de>
Diffstat (limited to 'palm')
-rw-r--r--palm/syncal/Makefile39
-rw-r--r--palm/syncal/distinfo1
-rw-r--r--palm/syncal/files/patch-aa69
-rw-r--r--palm/syncal/pkg-comment1
-rw-r--r--palm/syncal/pkg-descr9
-rw-r--r--palm/syncal/pkg-plist1
6 files changed, 120 insertions, 0 deletions
diff --git a/palm/syncal/Makefile b/palm/syncal/Makefile
new file mode 100644
index 000000000000..038deddd3db3
--- /dev/null
+++ b/palm/syncal/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: tclock
+# Version required: 1.0.1
+# Date created: So 7 Feb 1999 20:50:43 MET
+# Whom: Lars Koeller <lkoeller@cc.fh-lippe.de>
+#
+# $Id$
+#
+
+DISTNAME= syncal-0.5
+CATEGORIES= palm comms deskutils
+MASTER_SITES= ftp://ryeham.ee.ryerson.ca/pub/PalmOS/ \
+ http://www.daveltd.com/pilot/PalmOS/ \
+ ftp://ftp.uni-bielefeld.de/pub/systems/FreeBSD/lkoeller/
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeled.DE
+
+LIB_DEPENDS= pisock:${PORTSDIR}/palm/pilot-link
+RUN_DEPENDS= ical:${PORTSDIR}/deskutils/ical
+
+NO_PACKAGE= patches installed ical port
+
+PREFIX= ${LOCALBASE}/pilot
+
+MAN1= syncal.1
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.patched
+ ${SED} -e "s:@@PREFIX@@:${PREFIX}:g" ${WRKSRC}/Makefile.patched > ${WRKSRC}/Makefile
+
+#
+# ical V2.2 needs a little patch, don't know how to do better
+# perhaps the patch should be included int ical port by default
+# Please have a look at this experts :-)
+#
+post-install:
+ -cd ${LOCALBASE}/lib/ical/v2.2; \
+ ${PATCH} -f < ${WRKSRC}/ical.patch
+
+.include <bsd.port.mk>
diff --git a/palm/syncal/distinfo b/palm/syncal/distinfo
new file mode 100644
index 000000000000..455fce7b28b3
--- /dev/null
+++ b/palm/syncal/distinfo
@@ -0,0 +1 @@
+MD5 (syncal-0.5.tar.gz) = 0487b952f0bcea6a521b664c68114214
diff --git a/palm/syncal/files/patch-aa b/palm/syncal/files/patch-aa
new file mode 100644
index 000000000000..af8499e91e1a
--- /dev/null
+++ b/palm/syncal/files/patch-aa
@@ -0,0 +1,69 @@
+*** Makefile.org Fri Apr 9 19:54:00 1999
+--- Makefile Sat Apr 24 13:26:57 1999
+***************
+*** 13,19 ****
+ #
+ # top_builddir = /home/john/pilot/src/pilot-link.0.9.1
+ #
+! top_builddir = .
+
+ ##########
+ # Pick your C compiler
+--- 13,19 ----
+ #
+ # top_builddir = /home/john/pilot/src/pilot-link.0.9.1
+ #
+! top_builddir = @@PREFIX@@
+
+ ##########
+ # Pick your C compiler
+***************
+*** 25,31 ****
+ ##########
+ # Where should I be installed?
+ #
+! INSTALLTOP = /usr/local
+ INSTALLBIN = $(INSTALLTOP)/bin
+ INSTALLMAN = $(INSTALLTOP)/man
+
+--- 25,31 ----
+ ##########
+ # Where should I be installed?
+ #
+! INSTALLTOP = @@PREFIX@@
+ INSTALLBIN = $(INSTALLTOP)/bin
+ INSTALLMAN = $(INSTALLTOP)/man
+
+***************
+*** 58,65 ****
+ #
+ # Unless you're smarter than me, which is entirely possible. [JTL]
+ #
+! LIBDIR = -L$(top_builddir)
+! INCDIR = -I$(top_builddir)
+ CFLAGS = -Wall $(INCDIR)
+ SYNCAL_OBJS = syncal.o syncal_list.o syncal_dates.o syncal_reconcile.o
+ LIBTOOL = $(top_builddir)/libtool
+--- 58,65 ----
+ #
+ # Unless you're smarter than me, which is entirely possible. [JTL]
+ #
+! LIBDIR = -L$(top_builddir)/lib
+! INCDIR = -I$(top_builddir)/include
+ CFLAGS = -Wall $(INCDIR)
+ SYNCAL_OBJS = syncal.o syncal_list.o syncal_dates.o syncal_reconcile.o
+ LIBTOOL = $(top_builddir)/libtool
+***************
+*** 81,86 ****
+ install:
+ install -d $(INSTALLBIN)
+ install -d $(INSTALLMAN)/man1
+! install -s -g root -o root -m 755 syncal $(INSTALLBIN)
+!
+! install -g root -o root -m 644 syncal.1 $(INSTALLMAN)/man1
+--- 81,85 ----
+ install:
+ install -d $(INSTALLBIN)
+ install -d $(INSTALLMAN)/man1
+! install -c -s -g bin -o bin -m 755 syncal $(INSTALLBIN)
+! install -c -m 644 syncal.1 $(INSTALLMAN)/man1
diff --git a/palm/syncal/pkg-comment b/palm/syncal/pkg-comment
new file mode 100644
index 000000000000..6dd3bec7efef
--- /dev/null
+++ b/palm/syncal/pkg-comment
@@ -0,0 +1 @@
+Synchronize your PalmPilot with ical
diff --git a/palm/syncal/pkg-descr b/palm/syncal/pkg-descr
new file mode 100644
index 000000000000..f1e26d71ee84
--- /dev/null
+++ b/palm/syncal/pkg-descr
@@ -0,0 +1,9 @@
+ Syncal reads a current ical calendar file, an archived
+ ical calendar file from the last time syncal was run, and
+ a Palm device DateBook database and reconciles them. It
+ creates a new ical calendar file which replaces both the
+ current and archived ones and updates the Pilot DateBookDB
+ to coincide with them.
+
+ Once syncal is started, the user must invoke HotSync on
+ the target device.
diff --git a/palm/syncal/pkg-plist b/palm/syncal/pkg-plist
new file mode 100644
index 000000000000..423c80208ba4
--- /dev/null
+++ b/palm/syncal/pkg-plist
@@ -0,0 +1 @@
+bin/syncal
nsertions'>+4 * - Update libsodium to 1.0.15 [1]vsevolod2017-10-225-3/+5 * Update net-im/qTox to 1.12.1tcberner2017-10-213-28/+19 * multimedia/ffmpeg: update to 3.4jbeich2017-10-213-2/+3 * net-im/pidgin-rocketchat: create portswills2017-10-214-0/+38 * net-im/mastodon: Update to version 2.0.0.jrm2017-10-2012-6978/+7465 * net-im/openfire: update to 4.1.6gahr2017-10-172-4/+4 * Update net-im/py-python-telegram-bot to version 8.1.1.olgeni2017-10-162-4/+4 * - Update to 3.5.12tota2017-10-153-10/+19 * Update net-im/py-python-telegram-bot to version 8.1.0.olgeni2017-10-152-4/+4 * Remove WANT_GNOME and HAVE_GNOME.mat2017-10-122-4/+1 * net-im/linux-telegram-desktop: Update from 1.1.7 to 1.1.23joneum2017-10-083-6/+11 * Remove the mention of MSN and Yahoo! from pkg-descrs.marcus2017-10-053-6/+3 * Remove non functional portbapt2017-10-046-165/+0 * net-im/py-matrix-synapse: Update to 0.23.0feld2017-10-033-5/+119 * Remove net-im/py-twistedWordssunpoet2017-09-304-35/+0 * Make sure we do not include gconf2 when we're notmarcus2017-09-282-2/+2 * net-im/mastodon: Remove Gemfile.lock in the rc scripts before starting webjrm2017-09-273-0/+3 * Update net-im/py-fbmq to version 2.3.1.olgeni2017-09-262-4/+4 * devel/boost-*: update to 1.65.1jbeich2017-09-257-7/+7 * devel/boost-*: enable C++11 featuresjbeich2017-09-257-7/+7 * net-im/mastodon: Fix install with non-default ruby versions by removingjrm2017-09-251-29/+29 * - Update to 17.08ashish2017-09-244-176/+165 * 1: upgrade to 4.0.0.vanilla2017-09-233-2/+3 * Remove USES=execinfo.mat2017-09-223-3/+3 * net-im/sayaka: unbreak build with vala 0.36cpm2017-09-201-0/+29 * Update empathy to 3.12.14.kwm2017-09-193-291/+369 * net-im/mastodon: Update to version 1.6.1jrm2017-09-194-217/+243 * Sort *_DEPENDSsunpoet2017-09-181-3/+3 * net-im/mastodon: Fix issue running database migration scriptjrm2017-09-162-5/+13 * net-im/mastodon: Update to version 1.6.0jrm2017-09-167-130/+19048 * Fix license information for portgs that use "the same license as Perl".mat2017-09-155-5/+5 * unMessage is a peer-to-peer instant messaging application designed to enhanceultima2017-09-144-0/+48 * Chase Emacs updateashish2017-09-121-1/+1 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-1114-10/+14 * Update net-im/py-slackclient to version 1.0.9.olgeni2017-09-082-4/+4 * - Update to 3.5.11tota2017-09-052-4/+4 * Change from USES=twisted to devel/py-twistedsunpoet2017-09-041-2/+5 * Mark BROKEN: fails to buildantoine2017-09-021-0/+2 * Update net-im/py-python-telegram-bot to version 8.0.olgeni2017-09-022-4/+4 * - Update to 3.5.9tota2017-08-202-9/+10 * Mark DEPRECATED and set EXPIRATION_DATE to 2017-09-30sunpoet2017-08-201-0/+3 * net-im/gloox: Update to 1.0.20swills2017-08-1814-6/+149 * Update devel/protobuf to 3.4.0sunpoet2017-08-161-1/+1 * net-im/oysttyer: update 2.9.0 -> 2.9.1pi2017-08-112-4/+4 * - Update The Glorious Glasgow Haskell Compiler to version 8.0.2tcberner2017-08-091-1/+1 * net-im/mastodon: Update to version 1.5.1jrm2017-08-073-70/+70 * net-im/mastodon: Work around www/node (node version 8) bug [1] on FreeBSDjrm2017-08-063-4/+28 * net-im/py-matrix-synapse: Forgot the PORTREVISION bumpfeld2017-08-041-1/+1 * Reserve GID for synapse userfeld2017-08-041-1/+2 * net-im/mastodon: Add run-time dependencies necessary for installing nodejrm2017-08-032-17/+5 * Update net-im/py-fbmq to version 2.1.0.olgeni2017-08-022-4/+4 * net-im/mastodon: Update to version 1.5.0jrm2017-08-012-4/+4 * net-im/mastodon: Update to 1.5.0r3jrm2017-07-315-11/+28 * Update net-im/py-python-telegram-bot to version 7.0.1.olgeni2017-07-292-4/+4 * net-im/mastodon: Update to version 1.5.0r2jrm2017-07-2910-178/+160 * Add NO_ARCHsunpoet2017-07-272-49/+50 * Update net-im/jabberd to 2.6.1mm2017-07-262-5/+4 * Update net-im/py-python-telegram-bot to version 7.0.0.olgeni2017-07-262-4/+4 * Update GStreamer1 ports to 1.12.2.kwm2017-07-221-1/+1 * net-im/oysttyer: update 2.8.1 -> 2.9.0pi2017-07-202-5/+4 * net-im/qTox: Update to 1.11.0tcberner2017-07-195-51/+45 * Change RUN_DEPENDS from rubygem-rack-cors to rubygem-rack-cors0sunpoet2017-07-171-2/+2 * Update to 2.2.8sunpoet2017-07-162-5/+4 * Update WWWsunpoet2017-07-161-1/+1 * - Import diff from ejabberd repository, commitid: d4cdc3aashish2017-07-152-3/+18 * net-im/mastodon: Fix plist and patch issues; bump PORTREVISIONjrm2017-07-123-3/+4 * Fix gemspec for rubygem-activerecord4 4.2.1 update (r389119)sunpoet2017-07-122-6/+8 * - Update to 17.07ashish2017-07-106-289/+309 * net-im/openfire: update to 4.1.5gahr2017-07-102-4/+4 * - Update to 1.5.1cpm2017-07-097-41/+11 * net-im/py-matrix-synapse: Update to 0.22.1feld2017-07-082-4/+4 * Update to 1.6.0sunpoet2017-07-072-4/+4 * Add ports for future KDE Telepathy versionstcberner2017-07-068-0/+138 * net-im/mastodon: Update to version 1.4.7jrm2017-07-066-16/+29 * Remove Perl core modulessunpoet2017-06-301-2/+2 * Remove Perl core modulessunpoet2017-06-302-16/+16 * - Silence explicitly called commandcpm2017-06-281-1/+1 * Update devel/readline to 7.0 patch 3sunpoet2017-06-274-3/+4 * Update net-im/py-slackclient to version 1.0.6.olgeni2017-06-262-4/+6 * Make ninja opt-out in cmake.mktcberner2017-06-263-3/+3 * net-im/mastodon: Update to version 1.4.6jrm2017-06-243-5/+5 * net-im/mastodon: Update to version 1.4.5jrm2017-06-233-4/+5 * net-im/mastodon: Update to version 1.4.4jrm2017-06-224-18/+21 * - Fix build on powerpc64 adding compiler:c++11-lang feature to USEScpm2017-06-211-4/+2 * Limit net-im/telepathy*-qt* components to use python2 only as it hardcoded in...fluffy2017-06-202-2/+2 * net-im/py-matrix-synapse: Update to 0.21.1feld2017-06-202-4/+4 * Update net-im/py-python-telegram-bot to version 6.1.0.olgeni2017-06-192-4/+4 * net-im/mastodon: Update to version 1.4.3jrm2017-06-164-132/+215 * Linux version of the official desktop client for Telegram, a cloud-baseddanfe2017-06-145-0/+61 * - Update to 17.04ashish2017-06-133-126/+207 * Chase evolution-data-server shared library bump.kwm2017-06-133-3/+3 * net-im/py-matrix-synapse: Update to 0.21.0feld2017-06-112-4/+4 * net-im/mastodon: Add www/npm to RUN_DEPENDS and fix the false postivejrm2017-06-092-88/+89 * Upgrade to 0.8.0.thierry2017-06-093-6/+28 * net-im/gajim: update to 0.16.8rm2017-06-073-7/+8 * net-im/py-nbxmpp: update to 0.5.6rm2017-06-072-4/+4 * Update net-im/py-fbmq to version 2.0.3.olgeni2017-06-062-4/+4 * Change from USES=twisted to devel/py-twistedsunpoet2017-06-051-2/+5 * - Update to 1.1.0amdmi32017-06-052-5/+4 * Allow these ports to build with PACKAGE_BUILDING_FLAVORS set.bdrewery2017-06-051-1/+2 * Update net-im/qTox to 1.10.2tcberner2017-06-033-8/+7 * Mark some ports failing on powerpc64. These ports are either newlinimon2017-06-021-0/+2 * net-im/mastodon: No need to patch ${WRKSRC}/bin/yarn now, because www/yarnjrm2017-06-012-12/+0 * Update net-im/py-python-telegram-bot to version 6.0.2.olgeni2017-05-312-4/+4 * net-im/mastodon: Update to version 1.4.1jrm2017-05-295-8/+10 * Mark some ports failing on armv6, for errors classified as "linker_error".linimon2017-05-281-2/+3 * Mark some ports failing on armv6, for errors classified as "compiler_error".linimon2017-05-281-2/+3 * net-im/mastodon: Update to version 1.4rc5jrm2017-05-285-9/+16 * Mark some ports failing on armv6, for errors classified as "clang_werror".linimon2017-05-281-1/+2 * New port, net-im/mastodon: GNU Social-compatible microblogging serverjrm2017-05-2718-0/+5865 * Revision bump of all ports with USE_GL after consolidation of mesa-libsrezny2017-05-238-7/+8 * Update net-im/py-python-telegram-bot to version 6.0.1.olgeni2017-05-212-4/+4 * Update net-im/py-python-telegram-bot to version 6.0.0.olgeni2017-05-202-8/+6 * - Enable spellchecking supportcpm2017-05-191-3/+3 * Update to newer tag.tcberner2017-05-193-6/+8 * Re-add net-im/pidgin-manualsize removed with revision 418057 with following c...eugen2017-05-184-0/+43 * Chase evolution-data-server shlib bump.kwm2017-05-171-4/+3 * Chase evolution-data-server shlib bumps.kwm2017-05-173-2/+3 * Forgot to remove "USE_GCC".kevlo2017-05-151-1/+0 * Remove USE_GCC which is not needed anymore.kevlo2017-05-151-1/+2 * net-im/pecl-stomp2: Update to 2.0.1dbaio2017-05-102-4/+4 * Update my email addressdbaio2017-05-092-2/+2 * net-im/openfire: update to 4.1.4gahr2017-05-082-5/+5 * Update net-im/py-python-telegram-bot to version 5.3.1.olgeni2017-05-082-4/+4 * This port requires egrep to have working GNU extensions; in this case, itkwm2017-05-071-1/+3 * Fix shebangstcberner2017-05-041-2/+5 * - Update to 1.5cpm2017-05-046-8/+20 * - Update to 3.5.7tota2017-05-042-4/+4 * devel/boost-*: update to 1.64.0jbeich2017-05-027-7/+7 * 2017-04-30 devel/stormlib-ghost++: Unfetchable for more than six months (goog...ler2017-04-3033-724/+0 * Update to 0.6.0sunpoet2017-04-301-1/+1 * Provide more descriptive error messages for ports failing on powerpc64.linimon2017-04-301-1/+1 * Update devel/protobuf to 3.3.0sunpoet2017-04-291-1/+1 * Chase editors/emacs update to version 25.2jrm2017-04-291-1/+1 * Upgrade to v0.1.8.thierry2017-04-292-6/+6 * New port net-im/prosody-modulestcberner2017-04-276-0/+307 * Update net-im/py-fbmq to version 2.0.2.olgeni2017-04-262-4/+4 * Chase ffmpeg 3.3 update (ABI changes)riggs2017-04-2540-27/+40 * - Fix shebangsmiwi2017-04-241-2/+4 * - Fix shebangsmiwi2017-04-222-11/+4 * - Fix Shebangsmiwi2017-04-191-1/+3 * Attempt to fix build on packagebuild.arved2017-04-181-1/+7 * Move net/py-matrix-synapse to the net-im categoryfeld2017-04-179-0/+709 * Enable pluginsupport.arved2017-04-163-3/+22 * graphics/opencv: back out r423216 and r423063 (replaying r423316)jbeich2017-04-142-5/+5 * Update to 1.3.1kevlo2017-04-133-6/+7 * Remove Perl core modulessunpoet2017-04-111-4/+3 * Convert all PECL ports to USES=php:pecl.mat2017-04-103-10/+5 * These ports now build on powerpc64.linimon2017-04-101-1/+0 * - Add LICENSE_FILEamdmi32017-04-082-1/+2 * Remove Perl core modulessunpoet2017-04-061-1/+1 * Fix plist after r437491.rakuco2017-04-032-1/+1 * - Update to 3.5.6tota2017-04-032-4/+4 * Update to 20170324cs2017-04-022-5/+5 * Bump PORTREVISIONs for ports depending on the canonical version of GCC andgerald2017-04-0114-7/+14 * Maintainer's email address bounces.linimon2017-03-302-3/+3 * - Update to 3.5.5tota2017-03-263-16/+132 * net-im/ricochet: Fix build with LibreSSLbrnrd2017-03-263-5/+23 * - Update MASTER_SITES to unbreak the portak2017-03-263-8/+4 * Maintainer's email address bounces.linimon2017-03-241-1/+1 * net-im/corebird: fix play videos with https linkscpm2017-03-231-2/+2 * Update net-im/qTox to 1.9.0krion2017-03-232-4/+4 * Update to 2.12.0. See https://bitbucket.org/pidgin/www/src/tip/htdocs/ChangeLogmarcus2017-03-184-66/+11 * Remove all USE_OPENSSL occurrences.mat2017-03-15