aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-06-17 23:50:47 +0800
committeranray <anray@FreeBSD.org>2006-06-17 23:50:47 +0800
commitf161b0365a33eeecef152d8ea8f07fb87624f0a5 (patch)
treed6cebfe183b519126eba2a4b28c50da0e327b3c3 /palm
parent558c565486fde28e55339218b6e6abd6f914a33f (diff)
downloadfreebsd-ports-gnome-f161b0365a33eeecef152d8ea8f07fb87624f0a5.tar.gz
freebsd-ports-gnome-f161b0365a33eeecef152d8ea8f07fb87624f0a5.tar.zst
freebsd-ports-gnome-f161b0365a33eeecef152d8ea8f07fb87624f0a5.zip
Fix crash on startup when compiled with latest GTK2.
PR: ports/98929 [1], ports/98994 [2] Reported by: Guy Brand <gb@isis.u-strasbg.fr> [1] Submitted by: maintainer [2]
Diffstat (limited to 'palm')
-rw-r--r--palm/jpilot/Makefile2
-rw-r--r--palm/jpilot/files/patch-jpilot18
2 files changed, 19 insertions, 1 deletions
diff --git a/palm/jpilot/Makefile b/palm/jpilot/Makefile
index 80cc7af20887..6daee25ac333 100644
--- a/palm/jpilot/Makefile
+++ b/palm/jpilot/Makefile
@@ -8,7 +8,7 @@
PORTNAME= jpilot
PORTVERSION= 0.99.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES+= palm comms
MASTER_SITES= http://jpilot.org/
diff --git a/palm/jpilot/files/patch-jpilot b/palm/jpilot/files/patch-jpilot
new file mode 100644
index 000000000000..6be41c16cf62
--- /dev/null
+++ b/palm/jpilot/files/patch-jpilot
@@ -0,0 +1,18 @@
+diff -u -r1.127 -r1.128
+--- jpilot.c 28 Nov 2005 07:22:22 -0000 1.127
++++ jpilot.c 16 Dec 2005 13:33:27 -0000 1.128
+@@ -1,4 +1,4 @@
+-/* $Id: jpilot.c,v 1.127 2005/11/28 07:22:22 rikster5 Exp $ */
++/* $Id: jpilot.c,v 1.128 2005/12/16 13:33:27 rousseau Exp $ */
+
+ /*******************************************************************************
+ * jpilot.c
+@@ -1367,7 +1367,7 @@
+ gdk_pixdata_from_pixbuf(pixdata, pixbuf, FALSE);
+ data = gdk_pixdata_serialize(pixdata, &len);
+
+- g_free(pixbuf);
++ g_object_unref(pixbuf);
+ g_free(pixdata);
+
+ return data;