aboutsummaryrefslogtreecommitdiffstats
path: root/polish/ekg/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-04 18:48:50 +0800
committerbapt <bapt@FreeBSD.org>2012-10-04 18:48:50 +0800
commitb2e3ee2711e47f42230af5362804ca314287e9b1 (patch)
treeaea79b8d9b683f52f70634531007aeb451f8f1ed /polish/ekg/Makefile
parent783ffa8c21937b71f5fcd2602eaecee0cbaab3a9 (diff)
downloadfreebsd-ports-gnome-b2e3ee2711e47f42230af5362804ca314287e9b1.tar.gz
freebsd-ports-gnome-b2e3ee2711e47f42230af5362804ca314287e9b1.tar.zst
freebsd-ports-gnome-b2e3ee2711e47f42230af5362804ca314287e9b1.zip
Convert to new options framework
Diffstat (limited to 'polish/ekg/Makefile')
-rw-r--r--polish/ekg/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index f6c4e4cb03c8..c17b049f9666 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -27,17 +27,17 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo ${PTHREAD_LIBS}
CFLAGS+= -I${LOCALBASE}/include
-OPTIONS= ASPELL "Build with ASPELL support" off \
- OPENSSL "Build with OPENSSL support" on
+OPTIONS_DEFINE= ASPELL OPENSSL
+OPTIONS_DEFAULT= OPENSSL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_ASPELL)
+.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell.16:${PORTSDIR}/polish/aspell
CONFIGURE_ARGS+= --enable-aspell
.endif
-.if defined(WITHOUT_OPENSSL)
+.if empty(PORT_OPTIONS:MOPENSSL)
CONFIGURE_ARGS+= --without-openssl
.endif
@@ -50,4 +50,4 @@ MANCOMPRESSED= no
post-install:
${STRIP_CMD} ${PREFIX}/bin/ekg
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>