aboutsummaryrefslogtreecommitdiffstats
path: root/polish/hunspell/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-07-21 13:51:08 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-07-21 13:51:08 +0800
commitbabf787652ac5561e252f2d68b3f0f3ff0bb77f8 (patch)
tree831de5ad5cedce13cc9745121de7cb5ff45a55d9 /polish/hunspell/Makefile
parentce07bfe88723686032fc3e62285b2a40edc6b883 (diff)
downloadfreebsd-ports-gnome-babf787652ac5561e252f2d68b3f0f3ff0bb77f8.tar.gz
freebsd-ports-gnome-babf787652ac5561e252f2d68b3f0f3ff0bb77f8.tar.zst
freebsd-ports-gnome-babf787652ac5561e252f2d68b3f0f3ff0bb77f8.zip
Add Polish hunspell dictionaries
Diffstat (limited to 'polish/hunspell/Makefile')
-rw-r--r--polish/hunspell/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/polish/hunspell/Makefile b/polish/hunspell/Makefile
new file mode 100644
index 000000000000..011ed0900300
--- /dev/null
+++ b/polish/hunspell/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pl-hunspell
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pl-hunspell
+PORTVERSION= 20110721
+CATEGORIES= textproc
+MASTER_SITES= http://sjp.pl/slownik/ort/
+DISTNAME= sjp-myspell-pl-${PORTVERSION}
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Polish hunspell dictionaries
+
+LICENSE= LGPL21 GPLv2 MPL
+LICENSE_COMB= dual
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/hunspell/pl_PL.aff \
+ share/hunspell/pl_PL.dic
+PLIST_DIRS= share/hunspell
+
+post-extract:
+ @${MKDIR} ${WRKSRC}
+ @${EXTRACT_CMD} ${WRKDIR}/pl_PL.zip -d ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/hunspell
+ @${INSTALL_DATA} ${WRKSRC}/pl_PL.* ${PREFIX}/share/hunspell
+
+.include <bsd.port.mk>