aboutsummaryrefslogtreecommitdiffstats
path: root/polish/kadu/files
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-12-13 23:51:05 +0800
committerpawel <pawel@FreeBSD.org>2014-12-13 23:51:05 +0800
commit38a6b68e60b2b8229219d1400e83334dbb46ed3b (patch)
tree9a566c6b69d5281c8e68c6696ebc0994fa2d5eb1 /polish/kadu/files
parent65b5b5ed93abbe93bcf2a246dec42640daa4a460 (diff)
downloadfreebsd-ports-gnome-38a6b68e60b2b8229219d1400e83334dbb46ed3b.tar.gz
freebsd-ports-gnome-38a6b68e60b2b8229219d1400e83334dbb46ed3b.tar.zst
freebsd-ports-gnome-38a6b68e60b2b8229219d1400e83334dbb46ed3b.zip
- Update to version 1.3
- Remove lots of upstreamed fixes
Diffstat (limited to 'polish/kadu/files')
-rw-r--r--polish/kadu/files/patch-kadu-core_CMakeLists.txt11
-rw-r--r--polish/kadu/files/patch-kadu-core__formatted-string__formatted-string-factory.h10
-rw-r--r--polish/kadu/files/patch-kadu-core_plugin_metadata_plugin-metadata-finder.cpp11
-rw-r--r--polish/kadu/files/patch-kadu-core_plugin_plugin-conflict-resolver.cpp11
-rw-r--r--polish/kadu/files/patch-plugins_encryption__otr_CMakeLists.txt11
-rw-r--r--polish/kadu/files/patch-plugins_single__window_CMakeLists.txt11
-rw-r--r--polish/kadu/files/patch-plugins_tabs_CMakeLists.txt11
7 files changed, 0 insertions, 76 deletions
diff --git a/polish/kadu/files/patch-kadu-core_CMakeLists.txt b/polish/kadu/files/patch-kadu-core_CMakeLists.txt
deleted file mode 100644
index 3a9721553de5..000000000000
--- a/polish/kadu/files/patch-kadu-core_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- kadu-core/CMakeLists.txt.orig 2014-12-04 20:45:39 UTC
-+++ kadu-core/CMakeLists.txt
-@@ -60,7 +60,7 @@ endif ()
- # The rest of NETWORK_IMPLEMENTATION stuff is handled in network/CMakeLists.txt.
-
- configure_file (kadu-config.h.in "${CMAKE_CURRENT_BINARY_DIR}/kadu-config.h" ESCAPE_QUOTES)
--include_directories ("${CMAKE_CURRENT_BINARY_DIR}")
-+include_directories ("${CMAKE_CURRENT_BINARY_DIR}" ${X11_X11_INCLUDE_PATH})
-
- set (kadu_SRCS
- activate.cpp
diff --git a/polish/kadu/files/patch-kadu-core__formatted-string__formatted-string-factory.h b/polish/kadu/files/patch-kadu-core__formatted-string__formatted-string-factory.h
deleted file mode 100644
index d87b61cf2d9e..000000000000
--- a/polish/kadu/files/patch-kadu-core__formatted-string__formatted-string-factory.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- kadu-core/formatted-string/formatted-string-factory.h.orig 2014-11-06 20:56:16 UTC
-+++ kadu-core/formatted-string/formatted-string-factory.h
-@@ -22,6 +22,7 @@
- #define FORMATTED_STRING_FACTORY_H
-
- #include <memory>
-+#include <vector>
- #include <QtCore/QPointer>
-
- #include "formatted-string/formatted-string.h"
diff --git a/polish/kadu/files/patch-kadu-core_plugin_metadata_plugin-metadata-finder.cpp b/polish/kadu/files/patch-kadu-core_plugin_metadata_plugin-metadata-finder.cpp
deleted file mode 100644
index a20f6ba770d8..000000000000
--- a/polish/kadu/files/patch-kadu-core_plugin_metadata_plugin-metadata-finder.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kadu-core/plugin/metadata/plugin-metadata-finder.cpp.orig 2014-12-04 20:24:51 UTC
-+++ kadu-core/plugin/metadata/plugin-metadata-finder.cpp
-@@ -48,7 +48,7 @@ void PluginMetadataFinder::setPluginMeta
- std::map<QString, PluginMetadata> PluginMetadataFinder::provide() noexcept
- {
- if (m_directory.isEmpty() || !m_pluginMetadataReader)
-- return {};
-+ return std::map<QString, PluginMetadata>{};
-
- auto result = std::map<QString, PluginMetadata>{};
-
diff --git a/polish/kadu/files/patch-kadu-core_plugin_plugin-conflict-resolver.cpp b/polish/kadu/files/patch-kadu-core_plugin_plugin-conflict-resolver.cpp
deleted file mode 100644
index 649dc0617fb1..000000000000
--- a/polish/kadu/files/patch-kadu-core_plugin_plugin-conflict-resolver.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kadu-core/plugin/plugin-conflict-resolver.cpp.orig 2014-12-04 20:28:55 UTC
-+++ kadu-core/plugin/plugin-conflict-resolver.cpp
-@@ -40,7 +40,7 @@ void PluginConflictResolver::setPluginDe
- std::set<QString> PluginConflictResolver::conflictingPlugins(const std::set<QString> &activePluginSet, const QString &pluginName)
- {
- if (!m_pluginDependencyHandler || contains(activePluginSet, pluginName))
-- return {};
-+ return std::set<QString>{};
-
- auto withDependencies = m_pluginDependencyHandler->withDependencies(pluginName);
- auto withoutActive = decltype(withDependencies){};
diff --git a/polish/kadu/files/patch-plugins_encryption__otr_CMakeLists.txt b/polish/kadu/files/patch-plugins_encryption__otr_CMakeLists.txt
deleted file mode 100644
index d83eaae4fb4c..000000000000
--- a/polish/kadu/files/patch-plugins_encryption__otr_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/encryption_otr/CMakeLists.txt.orig 2014-12-04 20:34:30 UTC
-+++ plugins/encryption_otr/CMakeLists.txt
-@@ -102,6 +102,8 @@ pkg_check_modules (LIBOTR REQUIRED libot
-
- set (LIBRARIES ${QCA2_LIBRARIES} ${LIBOTR_LDFLAGS} gcrypt)
-
-+include_directories (${LIBOTR_INCLUDE_DIRS})
-+
- kadu_plugin (encryption_otr
- PLUGIN_SOURCES ${SOURCES}
- PLUGIN_MOC_SOURCES ${MOC_SOURCES}
diff --git a/polish/kadu/files/patch-plugins_single__window_CMakeLists.txt b/polish/kadu/files/patch-plugins_single__window_CMakeLists.txt
deleted file mode 100644
index 5e74595616a6..000000000000
--- a/polish/kadu/files/patch-plugins_single__window_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/single_window/CMakeLists.txt.orig 2014-12-04 20:56:15 UTC
-+++ plugins/single_window/CMakeLists.txt
-@@ -19,6 +19,8 @@ set (CONFIGURATION_FILES
- configuration/single_window.ui
- )
-
-+include_directories (${X11_X11_INCLUDE_PATH})
-+
- kadu_plugin (single_window
- PLUGIN_SOURCES ${SOURCES}
- PLUGIN_MOC_SOURCES ${MOC_SOURCES}
diff --git a/polish/kadu/files/patch-plugins_tabs_CMakeLists.txt b/polish/kadu/files/patch-plugins_tabs_CMakeLists.txt
deleted file mode 100644
index f77095f63a78..000000000000
--- a/polish/kadu/files/patch-plugins_tabs_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/tabs/CMakeLists.txt.orig 2014-12-04 20:58:52 UTC
-+++ plugins/tabs/CMakeLists.txt
-@@ -23,6 +23,8 @@ set (CONFIGURATION_FILES
- configuration/tabs.ui
- )
-
-+include_directories (${X11_X11_INCLUDE_PATH})
-+
- kadu_plugin (tabs
- PLUGIN_SOURCES ${SOURCES}
- PLUGIN_MOC_SOURCES ${MOC_SOURCES}