aboutsummaryrefslogtreecommitdiffstats
path: root/polish/kadu
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-11-06 02:34:22 +0800
committerrakuco <rakuco@FreeBSD.org>2013-11-06 02:34:22 +0800
commit905304d05f3b7a9a489cd782748daf74e8d882e1 (patch)
treef32ee7b1238a5be5178c342fb367d0842295aaf9 /polish/kadu
parentc863663a01f64ec3981c680ae99e6365fc7485fa (diff)
downloadfreebsd-ports-gnome-905304d05f3b7a9a489cd782748daf74e8d882e1.tar.gz
freebsd-ports-gnome-905304d05f3b7a9a489cd782748daf74e8d882e1.tar.zst
freebsd-ports-gnome-905304d05f3b7a9a489cd782748daf74e8d882e1.zip
Welcome CMake 2.8.12!
With contributions from Schaich Alonso <alonsoschaich@fastmail.fm>, including stage support for devel/cmake-gui. This update took much longer than expected due to CMake changing the arguments to an internal macro that ended up being used by some ports: http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=9ce60ff5 I have also started a discussion about this on CMake's development list: http://article.gmane.org/gmane.comp.programming.tools.cmake.devel/8464 It required adjusting the affected ports, and these changes have approved by portmgr (bdrewery). PR: ports/182981 Approved by: portmgr (bdrewery)
Diffstat (limited to 'polish/kadu')
-rw-r--r--polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt b/polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt
new file mode 100644
index 000000000000..6f1d6216ab0a
--- /dev/null
+++ b/polish/kadu/files/patch-plugins-jabber_protocol-3rdparty-CMakeLists.txt
@@ -0,0 +1,16 @@
+CMake 2.8.12 fix.
+
+http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=9ce60ff509c4ff27fe861fc5b2080f50897a68c4
+changed the arguments of the internal macro QT4_CREATE_MOC_COMMAND which the
+port uses directly, so we have to adapt.
+--- plugins/jabber_protocol/3rdparty/CMakeLists.txt.orig 2013-11-03 19:28:58.000000000 +0200
++++ plugins/jabber_protocol/3rdparty/CMakeLists.txt 2013-11-03 19:29:04.000000000 +0200
+@@ -26,7 +26,7 @@
+ get_filename_component (_basename ${_current_MOC} NAME_WE)
+ set (_header ${_abs_FILE})
+ set (_moc ${_abs_PATH}/${_current_MOC})
+- QT4_CREATE_MOC_COMMAND (${_header} ${_moc} "${_moc_INCS}" "")
++ QT4_CREATE_MOC_COMMAND (${_header} ${_moc} "${_moc_INCS}" "" "")
+ MACRO_ADD_FILE_DEPENDENCIES (${_abs_FILE} ${_moc})
+ endforeach (_current_MOC_INC)
+ endif (_match)