aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/chucky
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-24 18:31:58 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-24 18:31:58 +0800
commit041a834d3cc4c2a24d09c205c0a1b1f8bbeb7e27 (patch)
tree4f126560f1ed621c813ebd8894c252a470cee1cc /ports-mgmt/chucky
parent649faa8553150f97324d649c8d6395d078b8c402 (diff)
downloadfreebsd-ports-gnome-041a834d3cc4c2a24d09c205c0a1b1f8bbeb7e27.tar.gz
freebsd-ports-gnome-041a834d3cc4c2a24d09c205c0a1b1f8bbeb7e27.tar.zst
freebsd-ports-gnome-041a834d3cc4c2a24d09c205c0a1b1f8bbeb7e27.zip
Fix even more issues with the upstream Makefile:
- Respect CFLAGS - Respect CC - Don't hardcode /usr/local Notified by: olli hauer <ohauer@gmx.de>
Diffstat (limited to 'ports-mgmt/chucky')
-rw-r--r--ports-mgmt/chucky/Makefile4
-rw-r--r--ports-mgmt/chucky/files/patch-Makefile16
2 files changed, 16 insertions, 4 deletions
diff --git a/ports-mgmt/chucky/Makefile b/ports-mgmt/chucky/Makefile
index 22467d9a5d23..b23ddf96614c 100644
--- a/ports-mgmt/chucky/Makefile
+++ b/ports-mgmt/chucky/Makefile
@@ -15,7 +15,7 @@ LICENSE_NAME= CHUCKY BSD LICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
-LIB_DEPENDS= pkg:${PORTSDIR}/ports-mgmt/pkg \
+LIB_DEPENDS= libpkg.so:${PORTSDIR}/ports-mgmt/pkg \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
USE_GITHUB= yes
@@ -24,8 +24,6 @@ GH_PROJECT= chucky
GH_TAGNAME= 075defe
GH_COMMIT= ${GH_TAGNAME}
-WRKSRC= ${WRKDIR}/waitman-chucky-075defe
-
SUB_FILES= pkg-message
SUB_LIST= MAN7PREFIX="${MAN7PREFIX}"
PORTDOCS= *
diff --git a/ports-mgmt/chucky/files/patch-Makefile b/ports-mgmt/chucky/files/patch-Makefile
index 4e3145c159f3..ed1a87c8da1e 100644
--- a/ports-mgmt/chucky/files/patch-Makefile
+++ b/ports-mgmt/chucky/files/patch-Makefile
@@ -1,5 +1,19 @@
--- ./Makefile.orig 2013-03-22 05:11:27.000000000 +0100
-+++ ./Makefile 2014-02-24 09:55:51.627688711 +0100
++++ ./Makefile 2014-02-24 11:23:24.503330584 +0100
+@@ -1,8 +1,8 @@
+-prefix=/usr/local
+-man7dir=/usr/local/man/man7
+-CC=clang
+-CFLAGS=-I/usr/local/include
+-LDFLAGS=-L/usr/local/lib -lsqlite3
++prefix=${PREFIX}
++man7dir=${MANPREFIX}/man/man7
++CC?=clang
++CFLAGS+=-I${LOCALBASE}/include
++LDFLAGS+=-L${LOCALBASE}/lib -lsqlite3
+
+ all: chucky
+
@@ -12,8 +12,9 @@
rm chucky