aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/pkg
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-10-14 06:33:48 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-10-14 06:33:48 +0800
commit2b3b5df68fd1648ce55183314af867e890de84ae (patch)
tree97713d81ba290eb4b0eb46194fab90c13b59ea3d /ports-mgmt/pkg
parent22527b2a2de090e7fe374de74bb13307dfcb7767 (diff)
downloadfreebsd-ports-gnome-2b3b5df68fd1648ce55183314af867e890de84ae.tar.gz
freebsd-ports-gnome-2b3b5df68fd1648ce55183314af867e890de84ae.tar.zst
freebsd-ports-gnome-2b3b5df68fd1648ce55183314af867e890de84ae.zip
- Force pkg to not use base libbsdyml, which was available in head|stable/10
for some months. libbsdyml is being removed for 10-R. The bundled libyaml will be used instead. Discussed with: bapt With hat: portmgr
Diffstat (limited to 'ports-mgmt/pkg')
-rw-r--r--ports-mgmt/pkg/Makefile2
-rw-r--r--ports-mgmt/pkg/files/patch-external__Makefile11
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__Makefile15
-rw-r--r--ports-mgmt/pkg/files/patch-pkg-static__Makefile15
4 files changed, 42 insertions, 1 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index aa793c161ea1..f666452193fe 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.1.4
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= ports-mgmt
MASTER_SITES= http://files.etoilebsd.net/pkg/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg/files/patch-external__Makefile b/ports-mgmt/pkg/files/patch-external__Makefile
new file mode 100644
index 000000000000..b7c61154374a
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-external__Makefile
@@ -0,0 +1,11 @@
+--- ./external/Makefile.orig 2013-07-06 05:48:19.000000000 -0500
++++ ./external/Makefile 2013-10-12 07:25:25.353758158 -0500
+@@ -1,8 +1,6 @@
+ SUBDIR= sqlite
+
+-.if !exists(/usr/include/bsdyml.h)
+ SUBDIR+= libyaml
+-.endif
+
+ .if defined(WITH_BUNDLED_LIBELF)
+ SUBDIR+= libelf
diff --git a/ports-mgmt/pkg/files/patch-libpkg__Makefile b/ports-mgmt/pkg/files/patch-libpkg__Makefile
new file mode 100644
index 000000000000..f72e4f7fadc1
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__Makefile
@@ -0,0 +1,15 @@
+--- ./libpkg/Makefile.orig 2013-07-06 05:48:19.000000000 -0500
++++ ./libpkg/Makefile 2013-10-12 07:25:25.353758158 -0500
+@@ -82,12 +82,8 @@
+ -I${.CURDIR}/../external/sqlite \
+ -I${.CURDIR}/../external/uthash
+
+-.if !exists(/usr/include/bsdyml.h)
+ CFLAGS+= -DBUNDLED_YAML -I ${.CURDIR}/../external/libyaml/include
+ LDADD+= -L${.OBJDIR}/../external/libyaml -lyaml
+-.else
+-LDADD+= -lbsdyml
+-.endif
+
+ .if defined(WITH_BUNDLED_LIBELF)
+ CFLAGS+= -I${.CURDIR}/../external/libelf \
diff --git a/ports-mgmt/pkg/files/patch-pkg-static__Makefile b/ports-mgmt/pkg/files/patch-pkg-static__Makefile
new file mode 100644
index 000000000000..b05db45bc478
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-pkg-static__Makefile
@@ -0,0 +1,15 @@
+--- ./pkg-static/Makefile.orig 2013-07-06 05:48:19.000000000 -0500
++++ ./pkg-static/Makefile 2013-10-12 07:25:25.352756808 -0500
+@@ -6,12 +6,8 @@
+ NOMAN= yes
+ LDADD_STATIC= -L${.OBJDIR}/../external/sqlite
+
+-.if !exists(/usr/include/bsdyml.h)
+ LDADD_STATIC+= -L${.OBJDIR}/../external/libyaml \
+ -lyaml
+-.else
+-LDADD_STATIC+= -lbsdyml
+-.endif
+
+ .if defined(WITH_BUNDLED_LIBELF)
+ LDADD_STATIC+= -L${.OBJDIR}/../external/libelf