aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/pkg_tree
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2010-05-27 20:58:20 +0800
committeredwin <edwin@FreeBSD.org>2010-05-27 20:58:20 +0800
commita32d589d340cca26192fe28108a5e116469dc232 (patch)
tree30cd9b25e1976af532620a924c44753a25b3b24f /ports-mgmt/pkg_tree
parentc281e43538428939358c9b1d04cd1517a4a51de2 (diff)
downloadfreebsd-ports-gnome-a32d589d340cca26192fe28108a5e116469dc232.tar.gz
freebsd-ports-gnome-a32d589d340cca26192fe28108a5e116469dc232.tar.zst
freebsd-ports-gnome-a32d589d340cca26192fe28108a5e116469dc232.zip
From Tom Hukins:
I notice it looks for a perl executable in /usr/bin/perl. However, a perl executable may not exist here, so this small patch changes the port to use the PERL5 variable to determine the correct location of perl as determined by the ports system.
Diffstat (limited to 'ports-mgmt/pkg_tree')
-rw-r--r--ports-mgmt/pkg_tree/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ports-mgmt/pkg_tree/Makefile b/ports-mgmt/pkg_tree/Makefile
index d3199fc41b26..84d4c386e1e4 100644
--- a/ports-mgmt/pkg_tree/Makefile
+++ b/ports-mgmt/pkg_tree/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg_tree
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= http://www.mavetju.org/download/
@@ -23,5 +23,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|__PREFIX__|${PREFIX}|g ; \
s|__INSTALL_MAN__|${INSTALL_MAN}|g ; \
s|__INSTALL_SCRIPT__|${INSTALL_SCRIPT}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/perl -w|#!${PERL5} -w|' \
+ ${WRKSRC}/pkg_tree
.include <bsd.port.mk>