aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/porteasy
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2003-07-08 17:20:24 +0800
committerdes <des@FreeBSD.org>2003-07-08 17:20:24 +0800
commit8b1cacb5cf482d517a0a95de64f607608d0cc5b8 (patch)
tree6301322bb9b0ca35d738bc276f8740c317d9a1dd /ports-mgmt/porteasy
parent1b123b769ebde14ce435be5cf647c61fb66194e2 (diff)
downloadfreebsd-ports-gnome-8b1cacb5cf482d517a0a95de64f607608d0cc5b8.tar.gz
freebsd-ports-gnome-8b1cacb5cf482d517a0a95de64f607608d0cc5b8.tar.zst
freebsd-ports-gnome-8b1cacb5cf482d517a0a95de64f607608d0cc5b8.zip
Add support for {EXTRACT,PATCH}_DEPENDS.
Diffstat (limited to 'ports-mgmt/porteasy')
-rw-r--r--ports-mgmt/porteasy/Makefile2
-rw-r--r--ports-mgmt/porteasy/src/porteasy.pl4
2 files changed, 4 insertions, 2 deletions
diff --git a/ports-mgmt/porteasy/Makefile b/ports-mgmt/porteasy/Makefile
index 38731390b3a1..cceb64632afd 100644
--- a/ports-mgmt/porteasy/Makefile
+++ b/ports-mgmt/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.7.7
+PORTVERSION= 2.7.8
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/porteasy/src/porteasy.pl b/ports-mgmt/porteasy/src/porteasy.pl
index 6bbba53e75ce..643438774ab3 100644
--- a/ports-mgmt/porteasy/src/porteasy.pl
+++ b/ports-mgmt/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.7.7";
+my $VERSION = "2.7.8";
my $COPYRIGHT = "Copyright (c) 2000-2003 Dag-Erling Smørgrav. " .
"All rights reserved.";
@@ -611,6 +611,8 @@ sub find_dependencies($) {
or bsd::errx(1, "failed to obtain dependency list");
add_dependencies($port, \&find_library, split(' ', $dependvars));
$dependvars = capture(\&make, ($port,
+ "-VEXTRACT_DEPENDS",
+ "-VPATCH_DEPENDS",
"-VFETCH_DEPENDS",
"-VBUILD_DEPENDS",
"-VRUN_DEPENDS",