aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/porteasy
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2003-10-01 23:15:37 +0800
committerdes <des@FreeBSD.org>2003-10-01 23:15:37 +0800
commit9df6877b9bbfe35a6fa9ffcc91ff45be8e049e80 (patch)
tree327db49168a100baf171e6d268e9198fbad47214 /ports-mgmt/porteasy
parentdb7b34a75d138ce100f2949c69b32aae3d678c81 (diff)
downloadfreebsd-ports-gnome-9df6877b9bbfe35a6fa9ffcc91ff45be8e049e80.tar.gz
freebsd-ports-gnome-9df6877b9bbfe35a6fa9ffcc91ff45be8e049e80.tar.zst
freebsd-ports-gnome-9df6877b9bbfe35a6fa9ffcc91ff45be8e049e80.zip
If no CVS root was specified, but a (possibly out-of-date) ports tree
already exists, use the CVS root specified by $portsdir/CVS/Root.
Diffstat (limited to 'ports-mgmt/porteasy')
-rw-r--r--ports-mgmt/porteasy/Makefile2
-rw-r--r--ports-mgmt/porteasy/src/porteasy.82
-rw-r--r--ports-mgmt/porteasy/src/porteasy.pl11
3 files changed, 12 insertions, 3 deletions
diff --git a/ports-mgmt/porteasy/Makefile b/ports-mgmt/porteasy/Makefile
index 1a0429c53c57..0c034ce667c6 100644
--- a/ports-mgmt/porteasy/Makefile
+++ b/ports-mgmt/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.7.9
+PORTVERSION= 2.7.10
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/porteasy/src/porteasy.8 b/ports-mgmt/porteasy/src/porteasy.8
index f6ed5aad624d..9cdcd20a78a8 100644
--- a/ports-mgmt/porteasy/src/porteasy.8
+++ b/ports-mgmt/porteasy/src/porteasy.8
@@ -27,7 +27,7 @@
.\"
.\" $FreeBSD$
.\"
-.Dd July 21, 2003
+.Dd October 1, 2003
.Dt PORTEASY 8
.Os
.Sh NAME
diff --git a/ports-mgmt/porteasy/src/porteasy.pl b/ports-mgmt/porteasy/src/porteasy.pl
index da54066dc48c..af31490f9653 100644
--- a/ports-mgmt/porteasy/src/porteasy.pl
+++ b/ports-mgmt/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.7.9";
+my $VERSION = "2.7.10";
my $COPYRIGHT = "Copyright (c) 2000-2003 Dag-Erling Smørgrav. " .
"All rights reserved.";
@@ -1119,6 +1119,15 @@ MAIN:{
if (!$cvsroot) {
$cvsroot = $ENV{'CVSROOT'};
}
+ if (!$cvsroot && -f "$portsdir/CVS/Root") {
+ local *FILE;
+
+ if (sysopen(FILE, "$portsdir/CVS/Root", O_RDONLY)) {
+ $cvsroot = <FILE>;
+ chomp($cvsroot);
+ close(FILE);
+ }
+ }
if ($update && !$cvsroot) {
bsd::errx(1, "No CVS root, please use the -r option or set \$CVSROOT");
}