aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/porteasy
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2002-02-20 08:30:32 +0800
committerdes <des@FreeBSD.org>2002-02-20 08:30:32 +0800
commitabac6d2c37398b937664440f73dd404a4d1c813b (patch)
tree37c21a6942d65684698243dca5fb9d2cc23200fe /ports-mgmt/porteasy
parentc5e9dddfa3fba0a48a44385d08c1567df5caa065 (diff)
downloadfreebsd-ports-gnome-abac6d2c37398b937664440f73dd404a4d1c813b.tar.gz
freebsd-ports-gnome-abac6d2c37398b937664440f73dd404a4d1c813b.tar.zst
freebsd-ports-gnome-abac6d2c37398b937664440f73dd404a4d1c813b.zip
Add a hack to the master detection code to cater for mail/postfix.
Clean up each dependency after building it, to conserve disk space.
Diffstat (limited to 'ports-mgmt/porteasy')
-rw-r--r--ports-mgmt/porteasy/Makefile2
-rw-r--r--ports-mgmt/porteasy/src/porteasy.pl6
2 files changed, 4 insertions, 4 deletions
diff --git a/ports-mgmt/porteasy/Makefile b/ports-mgmt/porteasy/Makefile
index 5c738edd1aa7..42e591dddf4e 100644
--- a/ports-mgmt/porteasy/Makefile
+++ b/ports-mgmt/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.6.3
+PORTVERSION= 2.6.4
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/porteasy/src/porteasy.pl b/ports-mgmt/porteasy/src/porteasy.pl
index 115efa23eaa4..5adb0efc4641 100644
--- a/ports-mgmt/porteasy/src/porteasy.pl
+++ b/ports-mgmt/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.6.3";
+my $VERSION = "2.6.4";
my $COPYRIGHT = "Copyright (c) 2000 Dag-Erling Smørgrav. All rights reserved.";
# Constants
@@ -479,7 +479,7 @@ sub find_master($) {
} elsif (/^\.?include \"([^\"]+)\/Makefile(?:[^\/\"]*)\"\s*$/) {
$master = $1;
}
- if (defined($master)) {
+ if (defined($master) && $master !~ m/WRKDIRPREFIX/) {
$master =~ s/^\$\{.CURDIR\}//;
$master = "/$port/$master";
$master =~ s|/+|/|g;
@@ -904,7 +904,7 @@ sub build_port($) {
my @makeargs; # Arguments to make()
if ($packages) {
- push(@makeargs, "package", "DEPENDS_TARGET=package");
+ push(@makeargs, "package", "DEPENDS_TARGET=package clean", "-DNOCLEANDEPENDS");
} else {
push(@makeargs, "install");
}