aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint/Makefile
diff options
context:
space:
mode:
authoritojun <itojun@FreeBSD.org>1999-01-05 20:23:28 +0800
committeritojun <itojun@FreeBSD.org>1999-01-05 20:23:28 +0800
commit179d08ec99aea611d8e60d5a2633ddfea03b6462 (patch)
tree543fcd46959d072d8d38f8119bed5b31b4c313fb /ports-mgmt/portlint/Makefile
parent93cb564416799a3a6c649c969be12103086566fe (diff)
downloadfreebsd-ports-gnome-179d08ec99aea611d8e60d5a2633ddfea03b6462.tar.gz
freebsd-ports-gnome-179d08ec99aea611d8e60d5a2633ddfea03b6462.tar.zst
freebsd-ports-gnome-179d08ec99aea611d8e60d5a2633ddfea03b6462.zip
being tired of maintaining portlint only by myself, I decided to
put the source code for "portlint" into FreeBSD port tree. The imported revision is 1.65 (in my local RCS file). (pseudo) version number for the port is now 2.0. Whoever make changes to bsd.port.mk is advised to update portlint.pl too :-) Note that portlint.pl MUST be portable enough to handle (Net|Open|Free)BSD bsd.port.mk. There are people using portlint.pl on non-FreeBSD platforms.
Diffstat (limited to 'ports-mgmt/portlint/Makefile')
-rw-r--r--ports-mgmt/portlint/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 9392ace79cae..22227e56de21 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -1,28 +1,29 @@
# New ports collection makefile for: portlint
-# Version required: 1.61
+# Version required: (self contained)
# Date created: 13 Jun 1997
# Whom: Jun-ichiro itojun Itoh <itojun@itojun.org>
#
-# $Id: Makefile,v 1.19 1997/11/25 11:43:15 itojun Exp $
+# $Id: Makefile,v 1.20 1998/06/27 05:18:50 asami Exp $
#
-DISTNAME= portlint-1.61
+DISTNAME= portlint-2.0
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.foretune.co.jp/pub/tools/portlint/
-EXTRACT_SUFX= .shar
MAINTAINER= itojun@itojun.org
-EXTRACT_CMD= ${CAT}
-EXTRACT_BEFORE_ARGS= # yes, it is blank
-EXTRACT_AFTER_ARGS= |sh
-NO_WRKSUBDIR= yes
+NO_WRKDIR= yes
+NO_EXTRACT= yes
NO_BUILD= yes
+SRCDIR= ${.CURDIR}/src
+
MAN1= portlint.1
+do-fetch:
+ @${DO_NADA}
+
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/portlint.pl ${PREFIX}/bin/portlint
- ${INSTALL_MAN} ${WRKDIR}/portlint.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/portlint.pl ${PREFIX}/bin/portlint
+ ${INSTALL_MAN} ${WRKSRC}/portlint.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>