aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2018-05-13 06:14:30 +0800
committermarcus <marcus@FreeBSD.org>2018-05-13 06:14:30 +0800
commitd9e1e4b6447ac9e4d8b8b00798e5bd26c980ae02 (patch)
tree9e8bc8af6e087668c5f6b6107375d105e9ea494d /ports-mgmt/portlint
parentd2746770282b67b83f8f5c1341a72d01850c4552 (diff)
downloadfreebsd-ports-gnome-d9e1e4b6447ac9e4d8b8b00798e5bd26c980ae02.tar.gz
freebsd-ports-gnome-d9e1e4b6447ac9e4d8b8b00798e5bd26c980ae02.tar.zst
freebsd-ports-gnome-d9e1e4b6447ac9e4d8b8b00798e5bd26c980ae02.zip
Bump version to 2.18.2.
Fix a regression in the mae makepatch check. Make sure only the patch header is checked, but make sure to read in the entire patch file. This regression was introduced in 2.18.0. PR: 228203
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl9
2 files changed, 6 insertions, 5 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index c3445fa15e7c..1e2cf4c752da 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.18.1
+PORTVERSION= 2.18.2
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 7d5dd07dad4f..9c55d01fa1e3 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.461 2018/05/12 18:55:45 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.463 2018/05/12 22:12:18 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 18;
-my $micro = 1;
+my $micro = 2;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1037,16 +1037,17 @@ sub checkpatch {
open(IN, "< $file") || return 0;
$whole = '';
+ my $checked_header = 0;
while (<IN>) {
$whole .= $_;
- if (/^--- /) {
+ if (/^--- / && !$checked_header) {
+ $checked_header = 1;
if ($_ !~ /UTC\s*$/) {
&perror("WARN", $file, -1, "patch was not generated using ".
"``make makepatch''. It is recommended to use ".
"``make makepatch'' when you need to [re-]generate a ".
"patch to ensure proper patch format.");
}
- # last;
}
}