aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2018-10-15 01:50:32 +0800
committermarcus <marcus@FreeBSD.org>2018-10-15 01:50:32 +0800
commitfc3d401daf0680a20bb5ae4f261967eec8a6611d (patch)
tree34de41e7db4480ae6b0f8ca7c1e45ce7cfe5e012 /ports-mgmt/portlint
parent63bd2215308a1a84eff7df86cb711275adf561fc (diff)
downloadfreebsd-ports-gnome-fc3d401daf0680a20bb5ae4f261967eec8a6611d.tar.gz
freebsd-ports-gnome-fc3d401daf0680a20bb5ae4f261967eec8a6611d.tar.zst
freebsd-ports-gnome-fc3d401daf0680a20bb5ae4f261967eec8a6611d.zip
Update to 2.18.6.
Fix an uninitialized variable warning in non-Python ports. Reported by: leres
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl6
2 files changed, 4 insertions, 4 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index b541f161537f..504eba6fbb15 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.18.5
+PORTVERSION= 2.18.6
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index c4e103a3f15c..6af24f451a88 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.480 2018/10/13 15:34:05 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.482 2018/10/14 17:47:55 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 18;
-my $micro = 5;
+my $micro = 6;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1501,7 +1501,7 @@ sub checkmakefile {
#
print "OK: checking PLIST_FILES and PLIST_DIRS.\n" if ($verbose);
my $python_plist = 0;
- if ($makevar{USE_PYTHON} =~ /\bautoplist\b/) {
+ if ($makevar{USE_PYTHON} && $makevar{USE_PYTHON} =~ /\bautoplist\b/) {
$python_plist = 1;
if (-f 'pkg-plist') {
&perror("WARN", $file, -1, "If you are using python and using autoplist ".