aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portmanager
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-09 20:48:10 +0800
committerpav <pav@FreeBSD.org>2005-02-09 20:48:10 +0800
commitd731881d0bbc1859707b9a9a432113d20d8dd3f9 (patch)
tree0f2dcaf8e97a0a1eb195cbf09208c813e02d2ff7 /ports-mgmt/portmanager
parent5616b89fc93b317a3b166293d8cdfa3e26d16b1d (diff)
downloadfreebsd-ports-gnome-d731881d0bbc1859707b9a9a432113d20d8dd3f9.tar.gz
freebsd-ports-gnome-d731881d0bbc1859707b9a9a432113d20d8dd3f9.tar.zst
freebsd-ports-gnome-d731881d0bbc1859707b9a9a432113d20d8dd3f9.zip
- Update to 0.2.6_2:
There may be a bug in edge cases where a port name originates from multiple usr/ports directories. Patch allows printing of useful information if this happens and hopefully traps the bug with assert statements. PR: ports/77276 Submitted by: Michael C. Shultz <reso3w83@verizon.net> (maintainer)
Diffstat (limited to 'ports-mgmt/portmanager')
-rw-r--r--ports-mgmt/portmanager/Makefile29
-rw-r--r--ports-mgmt/portmanager/files/patch-0.2.6_265
-rw-r--r--ports-mgmt/portmanager/pkg-descr4
3 files changed, 89 insertions, 9 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index aa8ea4929e4c..013f51e0440c 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portmanager
PORTVERSION= 0.2.6
-PORTREVISION= 1
+PORTREVISION= 2
#-----------------------------------------
#for local use, remove before submitting PR
CATEGORIES= sysutils
@@ -41,18 +41,31 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
#CONFIGURE_ARGS= --with-debug=yes
#.endif
-#CONFIGURE_ARGS= --with-prefix=${PREFIX} \
-# --with-bindir=/bin \
-# --with-etcdir=${PREFIX}/etc/portmanager \
-# --with-pkgdbdir=${PKG_DBDIR} \
-# --with-portsdir=${PORTSDIR} \
-# --with-sharedir=${DATADIR} \
-# --with-tempdir=/tmp
+#
+# if --with-bin=something then withvar=${PREFIX} + something
+# else defaults to withvar=${PREFIX} + /bin
+#
+# so --with-bindir=/bin will become ${PREFIX}/bin at configure
+# time.
+#
+CONFIGURE_ARGS= --with-prefix=${PREFIX} \
+ --with-bindir=/bin \
+ --with-etcdir=/etc/portmanager \
+ --with-pkgdbdir=/var/db/pkg \
+ --with-portsdir=${PORTSDIR} \
+ --with-sharedir=/share/portmanager \
+ --with-tempdir=/tmp
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
# Need INSTALL_TARGET to install ${PREFIX}/etc/portmanager/pm-020.conf.SAMPLE
INSTALL_TARGET= install info
+post-configure:
+ @${REINPLACE_CMD} -e \
+ 's|VERSION "${PORTVERSION}"|VERSION "${PORTVERSION}_${PORTREVISION}"|g' \
+ ${WRKSRC}/externVars.h
+
post-install:
@${ECHO} "***********************************************************************"
@${ECHO} "* portmanager *"
diff --git a/ports-mgmt/portmanager/files/patch-0.2.6_2 b/ports-mgmt/portmanager/files/patch-0.2.6_2
new file mode 100644
index 000000000000..5eb66057ccfc
--- /dev/null
+++ b/ports-mgmt/portmanager/files/patch-0.2.6_2
@@ -0,0 +1,65 @@
+diff -ruN ./libPMGR/src/PMGRrUpgrade.c ../../branch/0.2.6_2/libPMGR/src/PMGRrUpgrade.c
+--- ./libPMGR/src/PMGRrUpgrade.c Mon Feb 7 11:46:39 2005
++++ ../../branch/0.2.6_2/libPMGR/src/PMGRrUpgrade.c Tue Feb 8 08:30:07 2005
+@@ -247,23 +247,56 @@
+ MGdbGetRecno( property->strikesDb ) - 1 );
+ MGdbAdd( property->strikesDb, oldPortDir, "2", NULL );
+
+- /**********************************************************************/
+- /* look for mismatch between looping port's +CONTENTS file dependency */
+- /* directories and and the dependency's actual point of origin */
+- /**********************************************************************/
+- MGdbGoTop( property->dependencyPortsDb );
++ /*
++ * look for mismatch between looping port's +CONTENTS file dependency
++ * directories and and the dependency's actual point of origin
++ *
++ * if dependency.db (looping port name) (dependency name) dependencyDir
++ * != installed.db ( dependency.name) dependency.dir
++ *
++ */
+
++ /*
++ * get looping port's +CONTENTS file dependency name
++ */
++ MGdbGoTop( property->dependencyPortsDb );
+ dependencyPortName = MGdbSeek( property->dependencyPortsDb,
+ property->fieldChildPortName,
+ oldPortName, property->fieldDependencyPortName );
++ if( !dependencyPortName )
++ {
++ fprintf( stderr,
++ "%s not found in dependencyPortsDb property->fieldChildPortName\n",
++ oldPortName );
++ assert(0);
++ }
++printf( "%s %s DEBUG: get looping port's +CONTENTS file dependency name = %s\n", id, VERSION, dependencyPortName );
+
++ /*
++ * get looping port's +CONTENTS file dependency dir
++ */
+ dependencyPortDir = MGdbGet( property->dependencyPortsDb,
+ MGdbGetRecno( property->dependencyPortsDb ) -1,
+ property->fieldDependencyPortDir );
+
++printf( "%s %s DEBUG: get looping port's +CONTENTS file dependency dir = %s\n", id, VERSION, dependencyPortDir );
++
++ /*
++ * get dependency's actual point of origin
++ */
+ MGdbGoTop( property->installedPortsDb );
+ origDir = MGdbSeek( property->installedPortsDb, property->fieldInstalledPortName,
+ dependencyPortName, property->fieldInstalledPortDir );
++ if( !origDir )
++ {
++ fprintf( stderr,
++ "%s not found in installedPortsDb property->fieldInstalledPortName\n",
++ dependencyPortName );
++ assert(0);
++ }
++
++printf( "%s %s DEBUG: get looping port's +CONTENTS file dependency actual point of ORIGIN dir = %s\n",
++ id, VERSION, origDir );
+
+ fprintf( stdout, "analysing problem:\n" );
+ while( dependencyPortName )
diff --git a/ports-mgmt/portmanager/pkg-descr b/ports-mgmt/portmanager/pkg-descr
index 95affb78a02c..569e3de78742 100644
--- a/ports-mgmt/portmanager/pkg-descr
+++ b/ports-mgmt/portmanager/pkg-descr
@@ -1,6 +1,8 @@
FreeBSD port collection management. Insures your ports are only built with
the most up to date sources. Great for users of KDE or GNOME who are always
-concerned over the way their underlying ports are built.
+concerned over the way their underlying ports are built. **New option**
+leaf port report: Shows ports with no other ports depending on them, these are
+ports that may be safely deinstalled.
WWW: http://portmanager.sourceforge.net/