aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/ports-tools/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2017-05-01 17:29:43 +0800
committerPawel Pekala <pawel@FreeBSD.org>2017-05-01 17:29:43 +0800
commit52ef87abe56c59b017043799588af0168b6b0c68 (patch)
treeddde9bddf821dc42344dbcf065b5376023953f37 /ports-mgmt/ports-tools/Makefile
parent8e8ba31ab1b6e98be3f79e3208f847f92e552c1e (diff)
downloadfreebsd-ports-gnome-52ef87abe56c59b017043799588af0168b6b0c68.tar.gz
freebsd-ports-gnome-52ef87abe56c59b017043799588af0168b6b0c68.tar.zst
freebsd-ports-gnome-52ef87abe56c59b017043799588af0168b6b0c68.zip
Update to version 1.2
Changelog: - Add pinstall, preinstall frontends to upgrade-ports script - Use ellipsis '...' to indicate time consuming operations - Clarify usage descriptions upgrade-ports: - backup self conflicting packages and use them to restore when upgrade fails - allow to remove conflicting package in install phase - show type of failure in upgrade summary when failed builds occur - improve conflicts handling - show removal reason in upgrade summary - check rebuilt ports for BROKEN and IGNORE flags - automatically change port name on move operation - implement option for only checking packages database for errors (-c) - improved MOVED entries tracking - don't offer recompilation of packages linked to libraries not found by system linker upgrade-base: - force sudo to preserve already set environment variables, this fixes PORTS_MODULES not being passed when user is non-root tbuilder: - improve detection of required option for library dependency - add profiles feature, it's files in $CONFIGDIR containing names of jails for use in one build test batch. pcommit: - print correct object type in file_add() function
Diffstat (limited to 'ports-mgmt/ports-tools/Makefile')
-rw-r--r--ports-mgmt/ports-tools/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/ports-mgmt/ports-tools/Makefile b/ports-mgmt/ports-tools/Makefile
index 85fcef74876c..b39e04185315 100644
--- a/ports-mgmt/ports-tools/Makefile
+++ b/ports-mgmt/ports-tools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ports-tools
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= ports-mgmt
MAINTAINER= pawel@FreeBSD.org
@@ -17,9 +17,4 @@ GH_ACCOUNT= ppekala
NO_BUILD= yes
NO_ARCH= yes
-PLIST_FILES= bin/mkpatch bin/pcheck bin/pclean bin/pcommit bin/pfind \
- bin/plist-sort bin/plist-update bin/plog bin/reinplace-check \
- sbin/pkg-deleaf sbin/tbuilder sbin/upgrade-base \
- sbin/upgrade-ports ${DOCSDIR}/README.md
-
.include <bsd.port.mk>