aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/poudriere-devel/Makefile
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2018-02-03 02:25:38 +0800
committerbdrewery <bdrewery@FreeBSD.org>2018-02-03 02:25:38 +0800
commitcd46e157dbf5e9b900ea4099e77419d6469c26a1 (patch)
tree58b1c81ba865db8214d5aadcab1211f312d8d791 /ports-mgmt/poudriere-devel/Makefile
parent761e2be15c5ac5fb5c87266914dfbd2d44776f0e (diff)
downloadfreebsd-ports-gnome-cd46e157dbf5e9b900ea4099e77419d6469c26a1.tar.gz
freebsd-ports-gnome-cd46e157dbf5e9b900ea4099e77419d6469c26a1.tar.zst
freebsd-ports-gnome-cd46e157dbf5e9b900ea4099e77419d6469c26a1.zip
- bulk: Fix skipping failed packages.
- Add CERTS option to allow disabling ca_root_nss and freebsd-release-manifests dependencies.
Diffstat (limited to 'ports-mgmt/poudriere-devel/Makefile')
-rw-r--r--ports-mgmt/poudriere-devel/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 753009306102..a8193c2ce733 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= poudriere
DISTVERSION= 3.2.99.20180202
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/bdrewery/${PORTNAME}/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
@@ -18,25 +18,24 @@ CONFLICTS_INSTALL= poudriere-[0-9]*
USE_GITHUB= yes
GH_ACCOUNT= freebsd
-GH_TAGNAME= 3.2.4-148-g1f555127
+GH_TAGNAME= 3.2.4-149-g9c388299
#DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${GH_TAGNAME}
GNU_CONFIGURE= yes
ETCDIR= ${PREFIX}/etc/poudriere.d
-OPTIONS_DEFINE= DIALOG4PORTS EXAMPLES QEMU ZSH
-OPTIONS_DEFAULT=DIALOG4PORTS ZSH
+OPTIONS_DEFINE= CERTS DIALOG4PORTS EXAMPLES QEMU ZSH
+OPTIONS_DEFAULT=CERTS DIALOG4PORTS ZSH
OPTIONS_SUB= yes
-IGNORE= bug with skipped packages
+CERTS_DESC= Install checksum and SSL certificates for jail creation
+CERTS_RUN_DEPENDS+= ca_root_nss>=0:security/ca_root_nss
+CERTS_RUN_DEPENDS+= freebsd-release-manifests>0:misc/freebsd-release-manifests
-RUN_DEPENDS+= ca_root_nss>=0:security/ca_root_nss
-RUN_DEPENDS+= freebsd-release-manifests>0:misc/freebsd-release-manifests
-
-DIALOG4PORTS_DESC= Install dialog4ports (necessary for options command) as runtime dependency
+DIALOG4PORTS_DESC= Install dialog4ports for options command
DIALOG4PORTS_RUN_DEPENDS= dialog4ports>0:ports-mgmt/dialog4ports
-QEMU_DESC= Add qemu-user-static to compile ports for non-x86 architectures
+QEMU_DESC= Add qemu-user-static for non-x86 architectures
QEMU_RUN_DEPENDS= qemu-user-static>0:emulators/qemu-user-static
.include <bsd.port.options.mk>