aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/tinderbox/Makefile
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-10-28 02:19:13 +0800
committerohauer <ohauer@FreeBSD.org>2013-10-28 02:19:13 +0800
commitf66bea5a918c0eef4724a653c1c3a9cf667abee9 (patch)
tree03b3ab1d30622f7cf923d011d94626e0c223cfde /ports-mgmt/tinderbox/Makefile
parentedfd08e976f6d543321d21026babfda05f7704bd (diff)
downloadfreebsd-ports-gnome-f66bea5a918c0eef4724a653c1c3a9cf667abee9.tar.gz
freebsd-ports-gnome-f66bea5a918c0eef4724a653c1c3a9cf667abee9.tar.zst
freebsd-ports-gnome-f66bea5a918c0eef4724a653c1c3a9cf667abee9.zip
- add stage support to tinderbox / tinderbox-devel
- sync OPTIONS - preserve use hooks / scrips by using dirrmtry - remove ' from DESC (don't break vim sytax) PR: ports/182615 Submitted by: ohauer Approved by: maintainer timeout (> 20 days)
Diffstat (limited to 'ports-mgmt/tinderbox/Makefile')
-rw-r--r--ports-mgmt/tinderbox/Makefile26
1 files changed, 7 insertions, 19 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 574b77712c5a..e51565e8385f 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= CHECK_ROOT EMAILS LSOF LOG_COMPRESS
CHECK_ROOT_DESC= Check if ./tc is run by uid 0
EMAILS_DESC= Support for build failure/completion emails
LSOF_DESC= For killMountProcesses() when using nullfs
-LOG_COMPRESS_DESC= Support bzip'ing the logs
+LOG_COMPRESS_DESC= Support bzip log compression
HIAWATHA_DESC= Hiawatha server
NGINX_DESC= Nginx server
@@ -38,10 +38,6 @@ NO_BUILD= yes
WANT_PERL= yes
SUB_FILES= pkg-message
-MAN1= tc-configCcache.1 tc-configDistfile.1 tc-configGet.1 \
- tc-configJail.1 tc-configTinderd.1 tc-init.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAPACHE} || ${PORT_OPTIONS:MHIAWATHA} || ${PORT_OPTIONS:MLIGHTTPD} || ${PORT_OPTIONS:MNGINX}
@@ -53,7 +49,6 @@ WANT_PHP_WEB= yes
USE_PHP= session
PLIST_SUB+= WEBUI=""
.else
-EXTRACT_BEFORE_ARGS= --exclude webui -xf
PLIST_SUB+= WEBUI="@comment "
.endif
@@ -107,20 +102,13 @@ post-patch:
${REINPLACE_CMD} -e 's/^if \[ `id -u` != 0 \]; then/if false; then/' \
${WRKSRC}/tc
.endif
- @cd ${WRKSRC} && ${FIND} -E . -regex '.*(orig|bak)' -exec ${RM} {} \;
do-install:
- @${MKDIR} ${PREFIX}/tinderbox/scripts
- @${ECHO_CMD} "Installing man pages ..."
- cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1 && \
- cd ${WRKSRC} && ${RM} -r ${WRKSRC}/man
- @${ECHO_CMD} "Installing rc script ..."
- ${INSTALL_SCRIPT} ${WRKSRC}/etc/rc.d/tinderd ${PREFIX}/etc/rc.d/${PORTNAME}
- @${ECHO_CMD} "Installing tinderbox ..."
- ${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts
- @${ECHO_CMD} "All Done"
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/tinderbox/scripts
+ ${TAR} -C ${WRKSRC} --exclude man --exclude '*.orig' --exclude '*.bak' -cf - . \
+ | tar -xf - --unlink -C ${STAGEDIR}${PREFIX}/tinderbox/scripts
+ ${TAR} -C ${WRKSRC}/man/man1 --exclude '*.orig' --exclude '*.bak' -cf - . \
+ | tar -xf - --unlink -C ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/etc/rc.d/tinderd ${STAGEDIR}${PREFIX}/etc/rc.d/${PORTNAME}
.include <bsd.port.mk>