aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/tinderbox
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-07-02 04:47:45 +0800
committerohauer <ohauer@FreeBSD.org>2012-07-02 04:47:45 +0800
commitcf10399edc28cd36391fe5b675ea3ac7de280f23 (patch)
tree36bc74629e36ba80fa34add5bf66b392de2c48c0 /ports-mgmt/tinderbox
parent888c685a3d6cbcebb755bf26f0ca9fcc86225d3e (diff)
downloadfreebsd-ports-gnome-cf10399edc28cd36391fe5b675ea3ac7de280f23.tar.gz
freebsd-ports-gnome-cf10399edc28cd36391fe5b675ea3ac7de280f23.tar.zst
freebsd-ports-gnome-cf10399edc28cd36391fe5b675ea3ac7de280f23.zip
- fix distinfo file (MD5_FILE -> DISTINFO_FILE)
Reference: http://marcuscom.com/pipermail/tinderbox-list/2012-March/002547.html PR: 165937 Submitted by: ohauer Approved by: maintainer timeout (3 months+)
Diffstat (limited to 'ports-mgmt/tinderbox')
-rw-r--r--ports-mgmt/tinderbox/Makefile1
-rw-r--r--ports-mgmt/tinderbox/files/patch-lib__tc_command.sh14
2 files changed, 15 insertions, 0 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 72540655f269..25ef18b932b2 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -6,6 +6,7 @@
PORTNAME= tinderbox
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
diff --git a/ports-mgmt/tinderbox/files/patch-lib__tc_command.sh b/ports-mgmt/tinderbox/files/patch-lib__tc_command.sh
new file mode 100644
index 000000000000..a4b4ccc42320
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-lib__tc_command.sh
@@ -0,0 +1,14 @@
+--- ./lib/tc_command.sh.orig 2012-03-11 18:29:27.000000000 +0100
++++ ./lib/tc_command.sh 2012-03-11 18:30:06.000000000 +0100
+@@ -2299,9 +2299,9 @@
+ oldcwd=${PWD}
+ path=$(tinderLoc portstree ${portstree})
+ cd "${path}/ports/${port}"
+- distinfo=$(env PORTSDIR="${path}/ports" make -V MD5_FILE)
++ distinfo=$(env PORTSDIR="${path}/ports" make -V DISTINFO_FILE)
+ if [ -f "${distinfo}" ]; then
+- for df in $(grep '^MD5' ${distinfo} | awk -F '[\(\)]' '{print $2}'); do
++ for df in $(grep '^SHA256' ${distinfo} | awk -F '[\(\)]' '{print $2}'); do
+ if ! grep -q "^${df}\$" ${disttmp}; then
+ echo ${df} >> ${disttmp}
+ fi