aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-04-04 16:49:25 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-04-04 16:49:25 +0800
commit0c0370fcedc031a5d43169d0035f28cb8c45c2c4 (patch)
tree0f176eb6dcf57155b1a1e7cb96328464e005545d /ports-mgmt
parent98dd6f174d7b1ff667a3851a4e3057b4967a4f0a (diff)
downloadfreebsd-ports-gnome-0c0370fcedc031a5d43169d0035f28cb8c45c2c4.tar.gz
freebsd-ports-gnome-0c0370fcedc031a5d43169d0035f28cb8c45c2c4.tar.zst
freebsd-ports-gnome-0c0370fcedc031a5d43169d0035f28cb8c45c2c4.zip
Support staging
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portless/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/ports-mgmt/portless/Makefile b/ports-mgmt/portless/Makefile
index e7e1170a6ad2..80d4cb8e19e7 100644
--- a/ports-mgmt/portless/Makefile
+++ b/ports-mgmt/portless/Makefile
@@ -7,24 +7,25 @@ PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= # empty
DISTFILES= # none
-EXTRACT_ONLY= # empty
MAINTAINER= mkamm@gmx.net
COMMENT= Quick display of files inside the FreeBSD ports tree
RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
-MAN1= portless.1
-MANCOMPRESSED= no
+USES= shebangfix
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
-PLIST_FILES= bin/portless
+PLIST_FILES= bin/portless man/man1/portless.1.gz
+SHEBANG_FILES= portless
+
+post-extract:
+ ${SED} -e 's;@BASH@;/bin/bash;g' \
+ ${FILESDIR}/portless.sh > ${WRKSRC}/portless
-NO_STAGE= yes
-do-build:
- ${SED} -e 's;@BASH@;${LOCALBASE}/bin/bash;g' \
- ${FILESDIR}/portless.sh >${WRKDIR}/portless
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/portless ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/portless.1 ${PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/portless ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/portless.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>