aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-16 02:52:43 +0800
committerpav <pav@FreeBSD.org>2005-07-16 02:52:43 +0800
commit387cc248722b2240a18882ff271eef5cd356c5a6 (patch)
tree1b6549325f3be0881a3f44ff42f5ce3640a63fc1 /ports-mgmt
parente3d3b7d57d01f9cba6282443d47832536afbe62a (diff)
downloadfreebsd-ports-gnome-387cc248722b2240a18882ff271eef5cd356c5a6.tar.gz
freebsd-ports-gnome-387cc248722b2240a18882ff271eef5cd356c5a6.tar.zst
freebsd-ports-gnome-387cc248722b2240a18882ff271eef5cd356c5a6.zip
- Fix finding original directory name for py- and ruby- ports
PR: ports/70156 Submitted by: clsung - Add detection of leftover empty directories to leftover checking code PR: ports/71363 Submitted by: leeym
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/porttools/Makefile4
-rw-r--r--ports-mgmt/porttools/files/patch-util_diff.in18
2 files changed, 20 insertions, 2 deletions
diff --git a/ports-mgmt/porttools/Makefile b/ports-mgmt/porttools/Makefile
index e88e07730939..56e5285654bb 100644
--- a/ports-mgmt/porttools/Makefile
+++ b/ports-mgmt/porttools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= porttools
PORTVERSION= 0.63
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,7 +29,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/newfile:${PORTSDIR}/devel/newfile
INSTALL_TARGET= install install-docs
.endif
-MAKE_ENV= PREFIX="${PREFIX}" DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
+MAKE_ENV= DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
MAN1= port.1
MAN5= porttools.5
diff --git a/ports-mgmt/porttools/files/patch-util_diff.in b/ports-mgmt/porttools/files/patch-util_diff.in
new file mode 100644
index 000000000000..bfa8d3650480
--- /dev/null
+++ b/ports-mgmt/porttools/files/patch-util_diff.in
@@ -0,0 +1,18 @@
+--- util_diff.in.orig Sat Aug 7 06:10:14 2004
++++ util_diff.in Sun Aug 8 16:26:26 2004
+@@ -70,10 +70,12 @@
+ # -d <dir> have been specified
+ # it should be Ports tree location
+ CATEGORY="`make -V CATEGORIES | sed -E 's/^([^ ]+).*$/\1/'`"
+- PKGNAMEPREFIX="`make -V PKGNAMEPREFIX`"
++ PYTHON_SUFFIX="`make -V PYTHON_SUFFIX`"
++ RUBY_SUFFIX="`make -V RUBY_SUFFIX`"
++ PKGNAMEPREFIX="`make -V PKGNAMEPREFIX | sed -E "s,py${PYTHON_SUFFIX}-,py-," | sed -E "s,ruby${RUBY_SUFFIX}-,ruby-,"`"
+ PKGNAMESUFFIX="`make -V PKGNAMESUFFIX`"
+- PORTNAME="`make -V PORTNAME`"
+- ORIG_DIR="${DIFF_MODE}/${CATEGORY}/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}"
++ PORTNAME="${PKGNAMEPREFIX}`make -V PORTNAME`${PKGNAMESUFFIX}"
++ ORIG_DIR="${DIFF_MODE}/${CATEGORY}/${PORTNAME}"
+ else
+ # -d <pattern> have been specified
+ # <pattern> is used to determine original port location