aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit4a4ec28d37b64039d4eff0f34ad66b543767d758 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /ports-mgmt
parenta5d24d4bb4a43375b4bbb7f8bc673f8c557f06b4 (diff)
downloadfreebsd-ports-gnome-4a4ec28d37b64039d4eff0f34ad66b543767d758.tar.gz
freebsd-ports-gnome-4a4ec28d37b64039d4eff0f34ad66b543767d758.tar.zst
freebsd-ports-gnome-4a4ec28d37b64039d4eff0f34ad66b543767d758.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/kpackagekit/Makefile4
-rw-r--r--ports-mgmt/pkg_add_it/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/ports-mgmt/kpackagekit/Makefile b/ports-mgmt/kpackagekit/Makefile
index bcedf94d100f..909c002e6acc 100644
--- a/ports-mgmt/kpackagekit/Makefile
+++ b/ports-mgmt/kpackagekit/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= 0.6.3.3
PORTREVISION= 3
CATEGORIES= ports-mgmt sysutils kde
MASTER_SITES= http://opendesktop.org/CONTENT/content-files/
-DISTNAME= 84745-${PORTNAME:L}-${PORTVERSION}
+DISTNAME= 84745-${PORTNAME:tl}-${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE interface for PackageKit
@@ -22,6 +22,6 @@ USES= cmake gettext pkgconfig
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME:L}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME:tl}-${PORTVERSION}
.include <bsd.port.mk>
diff --git a/ports-mgmt/pkg_add_it/Makefile b/ports-mgmt/pkg_add_it/Makefile
index 60e1ab79f151..646b23f179d3 100644
--- a/ports-mgmt/pkg_add_it/Makefile
+++ b/ports-mgmt/pkg_add_it/Makefile
@@ -20,7 +20,7 @@ PKG_RELEASE!= ${UNAME} -r | ${CUT} -d '-' -f 1,2 | ${SED} -e 's|\.[0-9]*.*|-STAB
post-patch:
${REINPLACE_CMD} -e 's|@PKG_ARCH@|${ARCH}|' \
- -e 's|@PKG_RELEASE@|${PKG_RELEASE:L}|' ${WRKSRC}/pkg_add_it.conf
+ -e 's|@PKG_RELEASE@|${PKG_RELEASE:tl}|' ${WRKSRC}/pkg_add_it.conf
do-install:
${INSTALL_DATA} ${WRKSRC}/pkg_add_it.conf ${PREFIX}/etc/