aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-05-27 07:28:15 +0800
committerlinimon <linimon@FreeBSD.org>2004-05-27 07:28:15 +0800
commit5b2dc5276489eae2e9a842399de83cc0d35c10c0 (patch)
tree8e7902733693d111af07ba5376ff0be9c8bd4bdb /ports-mgmt
parentd0c333dceb66160b9c7ed823ea9376bfab7d8ae5 (diff)
downloadfreebsd-ports-gnome-5b2dc5276489eae2e9a842399de83cc0d35c10c0.tar.gz
freebsd-ports-gnome-5b2dc5276489eae2e9a842399de83cc0d35c10c0.tar.zst
freebsd-ports-gnome-5b2dc5276489eae2e9a842399de83cc0d35c10c0.zip
Add two new metaports comprising a set of tools to work with the Ports
Collection. One is targeted to the audience of people who wish to install ports from source and then maintain their system; the other, more specialized, is intended for ports authors. These might be good candidates for a "start here" reference for those new to the ports collection and port maintenance. They might also serve to introduce more people to fastest-cvsup, pkg_cutleaves, libchk, and porttools, which IMHO would be A Good Thing. PR: ports/65161
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/port-authoring-tools/Makefile29
-rw-r--r--ports-mgmt/port-authoring-tools/pkg-descr2
-rw-r--r--ports-mgmt/port-maintenance-tools/Makefile32
-rw-r--r--ports-mgmt/port-maintenance-tools/pkg-descr5
4 files changed, 68 insertions, 0 deletions
diff --git a/ports-mgmt/port-authoring-tools/Makefile b/ports-mgmt/port-authoring-tools/Makefile
new file mode 100644
index 000000000000..90d00da88487
--- /dev/null
+++ b/ports-mgmt/port-authoring-tools/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: port-authoring-tools
+# Date created: 3 April 2004
+# Whom: Mark Linimon <linimon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= port-authoring-tools
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= linimon@FreeBSD.org
+COMMENT= "meta-port" for tools to test and submit changes to ports
+
+# note: portlint is brought in by porttools
+RUN_DEPENDS= \
+ cvsup:${PORTSDIR}/net/cvsup-without-gui \
+ fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
+ libchk:${PORTSDIR}/sysutils/libchk \
+ port:${PORTSDIR}/devel/porttools
+
+NO_BUILD= yes
+
+do-install: # empty
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/port-authoring-tools/pkg-descr b/ports-mgmt/port-authoring-tools/pkg-descr
new file mode 100644
index 000000000000..c2c9017f93cb
--- /dev/null
+++ b/ports-mgmt/port-authoring-tools/pkg-descr
@@ -0,0 +1,2 @@
+Here is a meta-port for a set of tools that will help port maintainers
+to test and submit changes to the FreeBSD Ports Collection.
diff --git a/ports-mgmt/port-maintenance-tools/Makefile b/ports-mgmt/port-maintenance-tools/Makefile
new file mode 100644
index 000000000000..849c61047575
--- /dev/null
+++ b/ports-mgmt/port-maintenance-tools/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: port-maintenance-tools
+# Date created: 3 April 2004
+# Whom: Mark Linimon <linimon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= port-maintenance-tools
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= linimon@FreeBSD.org
+COMMENT= "meta-port" for administrative tools to maintain ports
+
+# note: portuprade is brought in by pkg_cutleaves
+RUN_DEPENDS= \
+ cvsup:${PORTSDIR}/net/cvsup-without-gui \
+ fastest_cvsup:${PORTSDIR}/sysutils/fastest_cvsup \
+ pkg_cutleaves:${PORTSDIR}/sysutils/pkg_cutleaves \
+ pkg_tree:${PORTSDIR}/sysutils/pkg_tree \
+ porteasy:${PORTSDIR}/misc/porteasy \
+ portell:${PORTSDIR}/misc/portell \
+ portdowngrade:${PORTSDIR}/sysutils/portdowngrade
+
+NO_BUILD= yes
+
+do-install: # empty
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/port-maintenance-tools/pkg-descr b/ports-mgmt/port-maintenance-tools/pkg-descr
new file mode 100644
index 000000000000..e2f2646f3e94
--- /dev/null
+++ b/ports-mgmt/port-maintenance-tools/pkg-descr
@@ -0,0 +1,5 @@
+Here is a meta-port for a collection of tools that will help you
+manage your ports tree, both for installation, deinstallation,
+updating, and browsing. Many FreeBSD administrators and users
+find these tools to be helpful, especially when working with
+building ports from their sources.