aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-01-23 22:31:10 +0800
committerrakuco <rakuco@FreeBSD.org>2016-01-23 22:31:10 +0800
commit76c2f2d98edbbe418174fec8e8c29003c719f348 (patch)
treeb3228d0777526a983f8a354e6324178a948019a0 /ports-mgmt
parent247418e9c52e2f8685b40aee8bfccd3c3128e2d1 (diff)
downloadfreebsd-ports-gnome-76c2f2d98edbbe418174fec8e8c29003c719f348.tar.gz
freebsd-ports-gnome-76c2f2d98edbbe418174fec8e8c29003c719f348.tar.zst
freebsd-ports-gnome-76c2f2d98edbbe418174fec8e8c29003c719f348.zip
Fix build on FreeBSD 9.
Add the same -D_GLIBCXX_USE_C99 trick that a few other ports use so that gcc48 and its libstdc++ make std::to_string() available. MFH: 2016Q1
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portrac/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ports-mgmt/portrac/Makefile b/ports-mgmt/portrac/Makefile
index e3ea27681b1e..33971eedac47 100644
--- a/ports-mgmt/portrac/Makefile
+++ b/ports-mgmt/portrac/Makefile
@@ -11,7 +11,6 @@ COMMENT= Simple GUI tool for tracking port updates
LICENSE= BSD2CLAUSE
-BROKEN_FreeBSD_9= does not build (lacking c++11 support)
BROKEN_sparc64= fails to compile: error in C++ code
PLIST_FILES= bin/portrac \
@@ -19,6 +18,9 @@ PLIST_FILES= bin/portrac \
share/portrac/up-to-date.png \
share/portrac/updates-available.png
+# Unhide std::to_string() to fix build with GCC (ports/193528)
+CXXFLAGS= -D_GLIBCXX_USE_C99
+
USES= compiler:c++11-lib qmake tar:bzip2
USE_CXXSTD= c++11
USE_QT5= widgets buildtools_build