aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-30 16:25:34 +0800
committerbapt <bapt@FreeBSD.org>2012-07-30 16:25:34 +0800
commit8aa1100403b707993016756054cfc4366d82c2e2 (patch)
tree2dd3f385ae2d240babb8d27dc0bb8d6acdaf1386 /ports-mgmt
parent81404f50ff7af227475ae149f1731870cb051920 (diff)
downloadfreebsd-ports-gnome-8aa1100403b707993016756054cfc4366d82c2e2.tar.gz
freebsd-ports-gnome-8aa1100403b707993016756054cfc4366d82c2e2.tar.zst
freebsd-ports-gnome-8aa1100403b707993016756054cfc4366d82c2e2.zip
Fix a regression appending newline to commments
Reported by: avilla
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile1
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_manifest.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 5ec5251b3ff9..1c58ba8acf4b 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pkg
DISTVERSION= 1.0-rc5
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_manifest.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_manifest.c
new file mode 100644
index 000000000000..0772f6227d73
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__pkg_manifest.c
@@ -0,0 +1,12 @@
+--- ./libpkg/pkg_manifest.c.orig 2012-07-30 01:08:44.000000000 +0200
++++ ./libpkg/pkg_manifest.c 2012-07-30 10:23:20.768918130 +0200
+@@ -189,8 +189,7 @@
+ {
+ int ret = EPKG_OK;
+
+- while (val->data.scalar.length > 1 &&
+- val->data.scalar.value[val->data.scalar.length - 2] == '\n' &&
++ while (val->data.scalar.length > 0 &&
+ val->data.scalar.value[val->data.scalar.length - 1] == '\n') {
+ val->data.scalar.value[val->data.scalar.length - 1] = '\0';
+ val->data.scalar.length--;