aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /ports-mgmt
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg_cutleaves/Makefile7
-rw-r--r--ports-mgmt/pkg_tree/Makefile7
-rw-r--r--ports-mgmt/portlint/Makefile12
3 files changed, 10 insertions, 16 deletions
diff --git a/ports-mgmt/pkg_cutleaves/Makefile b/ports-mgmt/pkg_cutleaves/Makefile
index b8d47a5cd164..10ed92bc501b 100644
--- a/ports-mgmt/pkg_cutleaves/Makefile
+++ b/ports-mgmt/pkg_cutleaves/Makefile
@@ -13,9 +13,9 @@ COMMENT= Interactive script for deinstalling 'leaf' packages
LICENSE= BSD2CLAUSE
NO_BUILD= yes
-USES= perl5
-
-WRKSRC= ${WRKDIR}
+USES= perl5 shebangfix
+SHEBANG_FILES= pkg_cutleaves
+NO_WRKSUBDIR= yes
PLIST_FILES= sbin/pkg_cutleaves man/man1/pkg_cutleaves.1.gz
@@ -31,7 +31,6 @@ post-patch:
-e 's,/usr/local/etc/pkg_leaves.exclude,${PREFIX}/etc/pkg_leaves.exclude,' \
-e 's,/usr/local/sbin/pkg delete -y,${PKG_DELETE},' \
-e 's,/usr/local/sbin/pkg query,${PKG_QUERY},' \
- -e 's,/usr/bin/perl,${PERL},' \
${WRKSRC}/pkg_cutleaves
do-install:
diff --git a/ports-mgmt/pkg_tree/Makefile b/ports-mgmt/pkg_tree/Makefile
index fc8148f2cbd8..ddabcc663555 100644
--- a/ports-mgmt/pkg_tree/Makefile
+++ b/ports-mgmt/pkg_tree/Makefile
@@ -3,14 +3,15 @@
PORTNAME= pkg_tree
PORTVERSION= 1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ports-mgmt
MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
COMMENT= Get a 'graphical' tree-overview of installed packages
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= pkg_tree
NO_ARCH= yes
@@ -20,7 +21,5 @@ post-patch:
@${REINPLACE_CMD} -e 's|__PREFIX__|${STAGEDIR}${PREFIX}|g ; \
s|__INSTALL_MAN__|${INSTALL_MAN}|g ; \
s|__INSTALL_SCRIPT__|${INSTALL_SCRIPT}|g' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|#!/usr/bin/perl -w|#!${PERL5} -w|' \
- ${WRKSRC}/pkg_tree
.include <bsd.port.mk>
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 02018037df27..1105549da127 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -17,7 +17,8 @@ LICENSE_PERMS= auto-accept dist-mirror dist-sell pkg-mirror pkg-sell
NO_BUILD= yes
WRKSRC= ${WRKDIR}/src
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= *.pl
USE_PERL5= run
SRC= ${.CURDIR}/src
@@ -29,13 +30,8 @@ PORTEXAMPLES= portlintgrep
OPTIONS_DEFINE= EXAMPLES
-pre-patch:
- @${CP} -R ${SRC} ${WRKDIR}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/portlint.pl \
- ${WRKSRC}/portlintgrep.pl
+do-extract:
+ @${CP} -R ${SRC}/ ${WRKSRC}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/portlint.pl \