aboutsummaryrefslogtreecommitdiffstats
path: root/print/auctex
diff options
context:
space:
mode:
authoryoichi <yoichi@FreeBSD.org>2002-02-04 18:22:47 +0800
committeryoichi <yoichi@FreeBSD.org>2002-02-04 18:22:47 +0800
commit2ce769919180cba61ce431c6fb779e56442ed7a0 (patch)
tree5f6b1654ae90f68f8b97b30728471453dce13701 /print/auctex
parent683c26607f8086f12c526f6ce701b922a5655174 (diff)
downloadfreebsd-ports-gnome-2ce769919180cba61ce431c6fb779e56442ed7a0.tar.gz
freebsd-ports-gnome-2ce769919180cba61ce431c6fb779e56442ed7a0.tar.zst
freebsd-ports-gnome-2ce769919180cba61ce431c6fb779e56442ed7a0.zip
Use Emacs21 by default.
Terminate XEmacs support (ports/editors/xemacs-packages includes auctex). Arrange Makefile with bsd.emacs.mk. Approved by: maintainer
Diffstat (limited to 'print/auctex')
-rw-r--r--print/auctex/Makefile34
-rw-r--r--print/auctex/pkg-plist224
2 files changed, 121 insertions, 137 deletions
diff --git a/print/auctex/Makefile b/print/auctex/Makefile
index 555f54989c02..2bc5d9b70253 100644
--- a/print/auctex/Makefile
+++ b/print/auctex/Makefile
@@ -13,34 +13,18 @@ MASTER_SITE_SUBDIR= support/auctex
MAINTAINER= mkamm@gmx.net
-# NOTE: AUC TeX 10 requires Emacs version to be >= 20
-# EMACS_NAME must be 'emacs' or 'xemacs' - it is used for byte compiling
-# emacs lisp files (*.el => *.elc)
-# EMACS_PORT is only used for dependency registration, the installed bits
-# are always the same (regardless of what [x]emacs version is used)
-.if !defined(EMACS_NAME)
-.if exists(${LOCALBASE}/bin/xemacs)
-EMACS_NAME = xemacs
-EMACS_PORT = xemacs21
-.else
-EMACS_NAME = emacs
-EMACS_PORT = emacs20
-.endif
-.endif
-MAKE_ENV += EMACS='${EMACS_NAME}'
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
-BUILD_DEPENDS = ${EMACS_NAME}:${PORTSDIR}/editors/${EMACS_PORT}
-RUN_DEPENDS = ${EMACS_NAME}:${PORTSDIR}/editors/${EMACS_PORT} \
- latex:${PORTSDIR}/print/teTeX
+EMACS_PORT_NAME?= emacs21
+EMACS_NO_RUN_DEPENDS= yes
+LISPDIR= ${EMACS_SITE_LISPDIR}
+MAKE_ARGS+= lispdir=${PREFIX}/${LISPDIR}
+PLIST_SUB+= LISPDIR=${LISPDIR}
-.include <bsd.port.pre.mk>
-
-.if ${PREFIX} != /usr/local
# adjust a hardcoded '/usr/local' string
post-patch:
@${ECHO_MSG} "===> Substituting hardcoded '/usr/local' paths"
- ${PERL} -wpi -e 's¦/usr/local¦${PREFIX}¦g' ${WRKSRC}/tex.el
-.endif
+ ${PERL} -wpi -e 's?/usr/local?${PREFIX}?g' ${WRKSRC}/tex.el
post-install:
.if !defined(NOPORTDOCS)
@@ -51,6 +35,6 @@ post-install:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} install-info >/dev/null
install-info --entry='* AUC-Tex mode: (auctex). Emacs mode for editing TeX and LaTeX files.' --section='TeX' ${PREFIX}/info/auctex ${PREFIX}/info/dir
.endif
- @${CAT} ${PKGMESSAGE} | ${SED} 's¦/usr/local¦${PREFIX}¦g'
+ @${CAT} ${PKGMESSAGE} | ${SED} 's?/usr/local?${PREFIX}?g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/auctex/pkg-plist b/print/auctex/pkg-plist
index 789aefa44335..cd6ad243a0a4 100644
--- a/print/auctex/pkg-plist
+++ b/print/auctex/pkg-plist
@@ -8,115 +8,115 @@ share/doc/auctex/CHANGES
share/doc/auctex/INSTALLATION
share/doc/auctex/README
@dirrm share/doc/auctex
-share/emacs/site-lisp/tex-site.el
-share/emacs/site-lisp/auctex/auc-old.el
-share/emacs/site-lisp/auctex/auc-old.elc
-share/emacs/site-lisp/auctex/auto/.nosearch
-@dirrm share/emacs/site-lisp/auctex/auto
-share/emacs/site-lisp/auctex/latex.el
-share/emacs/site-lisp/auctex/latex.elc
-share/emacs/site-lisp/auctex/multi-prompt.el
-share/emacs/site-lisp/auctex/multi-prompt.elc
-share/emacs/site-lisp/auctex/style/.nosearch
-share/emacs/site-lisp/auctex/style/amsart.el
-share/emacs/site-lisp/auctex/style/amsart.elc
-share/emacs/site-lisp/auctex/style/amsbook.el
-share/emacs/site-lisp/auctex/style/amsbook.elc
-share/emacs/site-lisp/auctex/style/amsbsy.el
-share/emacs/site-lisp/auctex/style/amsbsy.elc
-share/emacs/site-lisp/auctex/style/amsmath.el
-share/emacs/site-lisp/auctex/style/amsmath.elc
-share/emacs/site-lisp/auctex/style/amsopn.el
-share/emacs/site-lisp/auctex/style/amsopn.elc
-share/emacs/site-lisp/auctex/style/amstex.el
-share/emacs/site-lisp/auctex/style/amstex.elc
-share/emacs/site-lisp/auctex/style/amstext.el
-share/emacs/site-lisp/auctex/style/amstext.elc
-share/emacs/site-lisp/auctex/style/amsthm.el
-share/emacs/site-lisp/auctex/style/amsthm.elc
-share/emacs/site-lisp/auctex/style/article.el
-share/emacs/site-lisp/auctex/style/article.elc
-share/emacs/site-lisp/auctex/style/book.el
-share/emacs/site-lisp/auctex/style/book.elc
-share/emacs/site-lisp/auctex/style/czech.el
-share/emacs/site-lisp/auctex/style/czech.elc
-share/emacs/site-lisp/auctex/style/danish.el
-share/emacs/site-lisp/auctex/style/danish.elc
-share/emacs/site-lisp/auctex/style/dinbrief.el
-share/emacs/site-lisp/auctex/style/dinbrief.elc
-share/emacs/site-lisp/auctex/style/dk.el
-share/emacs/site-lisp/auctex/style/dk.elc
-share/emacs/site-lisp/auctex/style/dutch.el
-share/emacs/site-lisp/auctex/style/dutch.elc
-share/emacs/site-lisp/auctex/style/epsf.el
-share/emacs/site-lisp/auctex/style/epsf.elc
-share/emacs/site-lisp/auctex/style/fancyref.el
-share/emacs/site-lisp/auctex/style/fancyref.elc
-share/emacs/site-lisp/auctex/style/foils.el
-share/emacs/site-lisp/auctex/style/foils.elc
-share/emacs/site-lisp/auctex/style/german.el
-share/emacs/site-lisp/auctex/style/german.elc
-share/emacs/site-lisp/auctex/style/graphics.el
-share/emacs/site-lisp/auctex/style/graphics.elc
-share/emacs/site-lisp/auctex/style/graphicx.el
-share/emacs/site-lisp/auctex/style/graphicx.elc
-share/emacs/site-lisp/auctex/style/harvard.el
-share/emacs/site-lisp/auctex/style/harvard.elc
-share/emacs/site-lisp/auctex/style/index.el
-share/emacs/site-lisp/auctex/style/index.elc
-share/emacs/site-lisp/auctex/style/j-article.el
-share/emacs/site-lisp/auctex/style/j-article.elc
-share/emacs/site-lisp/auctex/style/j-book.el
-share/emacs/site-lisp/auctex/style/j-book.elc
-share/emacs/site-lisp/auctex/style/j-report.el
-share/emacs/site-lisp/auctex/style/j-report.elc
-share/emacs/site-lisp/auctex/style/jarticle.el
-share/emacs/site-lisp/auctex/style/jarticle.elc
-share/emacs/site-lisp/auctex/style/jbook.el
-share/emacs/site-lisp/auctex/style/jbook.elc
-share/emacs/site-lisp/auctex/style/jreport.el
-share/emacs/site-lisp/auctex/style/jreport.elc
-share/emacs/site-lisp/auctex/style/latexinfo.el
-share/emacs/site-lisp/auctex/style/latexinfo.elc
-share/emacs/site-lisp/auctex/style/letter.el
-share/emacs/site-lisp/auctex/style/letter.elc
-share/emacs/site-lisp/auctex/style/makeidx.el
-share/emacs/site-lisp/auctex/style/makeidx.elc
-share/emacs/site-lisp/auctex/style/mdwlist.el
-share/emacs/site-lisp/auctex/style/mdwlist.elc
-share/emacs/site-lisp/auctex/style/multind.el
-share/emacs/site-lisp/auctex/style/multind.elc
-share/emacs/site-lisp/auctex/style/natbib.el
-share/emacs/site-lisp/auctex/style/natbib.elc
-share/emacs/site-lisp/auctex/style/ngerman.el
-share/emacs/site-lisp/auctex/style/ngerman.elc
-share/emacs/site-lisp/auctex/style/plfonts.el
-share/emacs/site-lisp/auctex/style/plfonts.elc
-share/emacs/site-lisp/auctex/style/plhb.el
-share/emacs/site-lisp/auctex/style/plhb.elc
-share/emacs/site-lisp/auctex/style/psfig.el
-share/emacs/site-lisp/auctex/style/psfig.elc
-share/emacs/site-lisp/auctex/style/report.el
-share/emacs/site-lisp/auctex/style/report.elc
-share/emacs/site-lisp/auctex/style/slides.el
-share/emacs/site-lisp/auctex/style/slides.elc
-share/emacs/site-lisp/auctex/style/slovak.el
-share/emacs/site-lisp/auctex/style/slovak.elc
-share/emacs/site-lisp/auctex/style/swedish.el
-share/emacs/site-lisp/auctex/style/swedish.elc
-share/emacs/site-lisp/auctex/style/varioref.el
-share/emacs/site-lisp/auctex/style/varioref.elc
-share/emacs/site-lisp/auctex/style/virtex.el
-share/emacs/site-lisp/auctex/style/virtex.elc
-@dirrm share/emacs/site-lisp/auctex/style
-share/emacs/site-lisp/auctex/tex-buf.el
-share/emacs/site-lisp/auctex/tex-buf.elc
-share/emacs/site-lisp/auctex/tex-info.el
-share/emacs/site-lisp/auctex/tex-info.elc
-share/emacs/site-lisp/auctex/tex-mik.el
-share/emacs/site-lisp/auctex/tex-mik.elc
-share/emacs/site-lisp/auctex/tex.el
-share/emacs/site-lisp/auctex/tex.elc
-share/emacs/site-lisp/auctex/texmathp.el
-share/emacs/site-lisp/auctex/texmathp.elc
-@dirrm share/emacs/site-lisp/auctex
+%%LISPDIR%%/tex-site.el
+%%LISPDIR%%/auctex/auc-old.el
+%%LISPDIR%%/auctex/auc-old.elc
+%%LISPDIR%%/auctex/auto/.nosearch
+@dirrm %%LISPDIR%%/auctex/auto
+%%LISPDIR%%/auctex/latex.el
+%%LISPDIR%%/auctex/latex.elc
+%%LISPDIR%%/auctex/multi-prompt.el
+%%LISPDIR%%/auctex/multi-prompt.elc
+%%LISPDIR%%/auctex/style/.nosearch
+%%LISPDIR%%/auctex/style/amsart.el
+%%LISPDIR%%/auctex/style/amsart.elc
+%%LISPDIR%%/auctex/style/amsbook.el
+%%LISPDIR%%/auctex/style/amsbook.elc
+%%LISPDIR%%/auctex/style/amsbsy.el
+%%LISPDIR%%/auctex/style/amsbsy.elc
+%%LISPDIR%%/auctex/style/amsmath.el
+%%LISPDIR%%/auctex/style/amsmath.elc
+%%LISPDIR%%/auctex/style/amsopn.el
+%%LISPDIR%%/auctex/style/amsopn.elc
+%%LISPDIR%%/auctex/style/amstex.el
+%%LISPDIR%%/auctex/style/amstex.elc
+%%LISPDIR%%/auctex/style/amstext.el
+%%LISPDIR%%/auctex/style/amstext.elc
+%%LISPDIR%%/auctex/style/amsthm.el
+%%LISPDIR%%/auctex/style/amsthm.elc
+%%LISPDIR%%/auctex/style/article.el
+%%LISPDIR%%/auctex/style/article.elc
+%%LISPDIR%%/auctex/style/book.el
+%%LISPDIR%%/auctex/style/book.elc
+%%LISPDIR%%/auctex/style/czech.el
+%%LISPDIR%%/auctex/style/czech.elc
+%%LISPDIR%%/auctex/style/danish.el
+%%LISPDIR%%/auctex/style/danish.elc
+%%LISPDIR%%/auctex/style/dinbrief.el
+%%LISPDIR%%/auctex/style/dinbrief.elc
+%%LISPDIR%%/auctex/style/dk.el
+%%LISPDIR%%/auctex/style/dk.elc
+%%LISPDIR%%/auctex/style/dutch.el
+%%LISPDIR%%/auctex/style/dutch.elc
+%%LISPDIR%%/auctex/style/epsf.el
+%%LISPDIR%%/auctex/style/epsf.elc
+%%LISPDIR%%/auctex/style/fancyref.el
+%%LISPDIR%%/auctex/style/fancyref.elc
+%%LISPDIR%%/auctex/style/foils.el
+%%LISPDIR%%/auctex/style/foils.elc
+%%LISPDIR%%/auctex/style/german.el
+%%LISPDIR%%/auctex/style/german.elc
+%%LISPDIR%%/auctex/style/graphics.el
+%%LISPDIR%%/auctex/style/graphics.elc
+%%LISPDIR%%/auctex/style/graphicx.el
+%%LISPDIR%%/auctex/style/graphicx.elc
+%%LISPDIR%%/auctex/style/harvard.el
+%%LISPDIR%%/auctex/style/harvard.elc
+%%LISPDIR%%/auctex/style/index.el
+%%LISPDIR%%/auctex/style/index.elc
+%%LISPDIR%%/auctex/style/j-article.el
+%%LISPDIR%%/auctex/style/j-article.elc
+%%LISPDIR%%/auctex/style/j-book.el
+%%LISPDIR%%/auctex/style/j-book.elc
+%%LISPDIR%%/auctex/style/j-report.el
+%%LISPDIR%%/auctex/style/j-report.elc
+%%LISPDIR%%/auctex/style/jarticle.el
+%%LISPDIR%%/auctex/style/jarticle.elc
+%%LISPDIR%%/auctex/style/jbook.el
+%%LISPDIR%%/auctex/style/jbook.elc
+%%LISPDIR%%/auctex/style/jreport.el
+%%LISPDIR%%/auctex/style/jreport.elc
+%%LISPDIR%%/auctex/style/latexinfo.el
+%%LISPDIR%%/auctex/style/latexinfo.elc
+%%LISPDIR%%/auctex/style/letter.el
+%%LISPDIR%%/auctex/style/letter.elc
+%%LISPDIR%%/auctex/style/makeidx.el
+%%LISPDIR%%/auctex/style/makeidx.elc
+%%LISPDIR%%/auctex/style/mdwlist.el
+%%LISPDIR%%/auctex/style/mdwlist.elc
+%%LISPDIR%%/auctex/style/multind.el
+%%LISPDIR%%/auctex/style/multind.elc
+%%LISPDIR%%/auctex/style/natbib.el
+%%LISPDIR%%/auctex/style/natbib.elc
+%%LISPDIR%%/auctex/style/ngerman.el
+%%LISPDIR%%/auctex/style/ngerman.elc
+%%LISPDIR%%/auctex/style/plfonts.el
+%%LISPDIR%%/auctex/style/plfonts.elc
+%%LISPDIR%%/auctex/style/plhb.el
+%%LISPDIR%%/auctex/style/plhb.elc
+%%LISPDIR%%/auctex/style/psfig.el
+%%LISPDIR%%/auctex/style/psfig.elc
+%%LISPDIR%%/auctex/style/report.el
+%%LISPDIR%%/auctex/style/report.elc
+%%LISPDIR%%/auctex/style/slides.el
+%%LISPDIR%%/auctex/style/slides.elc
+%%LISPDIR%%/auctex/style/slovak.el
+%%LISPDIR%%/auctex/style/slovak.elc
+%%LISPDIR%%/auctex/style/swedish.el
+%%LISPDIR%%/auctex/style/swedish.elc
+%%LISPDIR%%/auctex/style/varioref.el
+%%LISPDIR%%/auctex/style/varioref.elc
+%%LISPDIR%%/auctex/style/virtex.el
+%%LISPDIR%%/auctex/style/virtex.elc
+@dirrm %%LISPDIR%%/auctex/style
+%%LISPDIR%%/auctex/tex-buf.el
+%%LISPDIR%%/auctex/tex-buf.elc
+%%LISPDIR%%/auctex/tex-info.el
+%%LISPDIR%%/auctex/tex-info.elc
+%%LISPDIR%%/auctex/tex-mik.el
+%%LISPDIR%%/auctex/tex-mik.elc
+%%LISPDIR%%/auctex/tex.el
+%%LISPDIR%%/auctex/tex.elc
+%%LISPDIR%%/auctex/texmathp.el
+%%LISPDIR%%/auctex/texmathp.elc
+@dirrm %%LISPDIR%%/auctex