aboutsummaryrefslogtreecommitdiffstats
path: root/print/cups/Makefile
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2001-01-07 08:52:07 +0800
committerjeh <jeh@FreeBSD.org>2001-01-07 08:52:07 +0800
commitbf692b5bcdacfc40b3aba6b72bdd08a1944ac554 (patch)
tree7e9d1a084858a35815467b4ef68538f1237b45a9 /print/cups/Makefile
parentab01a380eb48cf821f45391e7169704a23c9371f (diff)
downloadfreebsd-ports-gnome-bf692b5bcdacfc40b3aba6b72bdd08a1944ac554.tar.gz
freebsd-ports-gnome-bf692b5bcdacfc40b3aba6b72bdd08a1944ac554.tar.zst
freebsd-ports-gnome-bf692b5bcdacfc40b3aba6b72bdd08a1944ac554.zip
New Ports: print/cups
CUPS provides a portable printing layer for UNIX-based operating systems. PR: 240877 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'print/cups/Makefile')
-rw-r--r--print/cups/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/print/cups/Makefile b/print/cups/Makefile
new file mode 100644
index 000000000000..c75fe7baee51
--- /dev/null
+++ b/print/cups/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: cups
+# Date created: 05 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cups
+PORTVERSION= 1.1.5
+CATEGORIES= print
+MASTER_SITES= ftp://ftp.easysw.com/pub/cups/${PORTVERSION}/ \
+ ftp://ftp2.easysw.com/pub/cups/${PORTVERSION}/ \
+ ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${PORTVERSION}/ \
+ ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-2-source
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+USE_BZIP2= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+GNU_CONFIGURE= yes
+
+MAN1= backend.1 cancel.1 filter.1 lp.1 lpoptions.1 lpq.1 \
+ lpr.1 lprm.1 lpstat.1
+MAN5= classes.conf.5 cupsd.conf.5 mime.convs.5 mime.types.5 \
+ printers.conf.5
+MAN8= accept.8 cups-lpd.8 cups-polld.8 cupsd.8 disable.8 \
+ enable.8 lpadmin.8 lpc.8 lpinfo.8 lpmove.8
+MLINKS= accept.8 reject.8
+
+.include <bsd.port.mk>