aboutsummaryrefslogtreecommitdiffstats
path: root/print/cups
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-06-23 04:16:06 +0800
committerahze <ahze@FreeBSD.org>2006-06-23 04:16:06 +0800
commit6ae12a612cb33dfdcecac3de2ab7d5a7d3f2ce1c (patch)
tree9009ecd1778597b4298ee687d91670da0ce243ce /print/cups
parent8562926c459c7e6f375a2e8cb3321cf38e846752 (diff)
downloadfreebsd-ports-gnome-6ae12a612cb33dfdcecac3de2ab7d5a7d3f2ce1c.tar.gz
freebsd-ports-gnome-6ae12a612cb33dfdcecac3de2ab7d5a7d3f2ce1c.tar.zst
freebsd-ports-gnome-6ae12a612cb33dfdcecac3de2ab7d5a7d3f2ce1c.zip
- Update to 1.2.0
PR: ports/97783 ports/97782 Submitted by: maintainer
Diffstat (limited to 'print/cups')
-rw-r--r--print/cups/Makefile20
-rw-r--r--print/cups/Makefile.common93
-rw-r--r--print/cups/pkg-descr3
-rw-r--r--print/cups/pkg-message1
4 files changed, 6 insertions, 111 deletions
diff --git a/print/cups/Makefile b/print/cups/Makefile
index 78f615796a8a..de826a596d53 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -8,9 +8,7 @@
#
PORTNAME= cups
-PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= ${CUPS_PORTREV}
-PORTEPOCH= ${CUPS_PORTEPOCH}
+PORTVERSION= 1.2.0
CATEGORIES= print
MASTER_SITES= # empty
DISTFILES= # empty
@@ -19,23 +17,17 @@ EXTRACT_ONLY= # empty
MAINTAINER= asa@agava.com
COMMENT= The Common UNIX Printing System: Metaport to install complete system
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
-RUN_DEPENDS+= espgs:${PORTSDIR}/print/cups-pstoraster \
- ${LOCALBASE}/sbin/cupsaddsmb:${PORTSDIR}/print/cups-lpr
-
.if make(package)
DEPENDS_TARGET="package"
.endif # make(package)
-USE_PERL5= yes
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+RUN_DEPENDS+= espgs:${PORTSDIR}/print/cups-pstoraster
+
NO_BUILD= true
-do-patch:
- ${DO_NADA}
+do-build:
do-install:
- ${DO_NADA}
-.include "${.CURDIR}/../../print/cups/Makefile.common"
-.include <bsd.port.pre.mk>
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
deleted file mode 100644
index 31db67605dc1..000000000000
--- a/print/cups/Makefile.common
+++ /dev/null
@@ -1,93 +0,0 @@
-# ex:ts=8 -*-mode: makefile-*-
-# Common file for CUPS ports
-# $FreeBSD$
-
-CUPS_MASTER_SITES=\
- ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
- ftp://ftp.ntua.gr/pub/gnu/cups/${CUPS_VERSION}/ \
- ftp://ftp.easysw.com/pub/cups/${CUPS_VERSION}/ \
- ftp://ftp.fisek.com.tr/pub/cups/${CUPS_VERSION}/ \
- ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${CUPS_VERSION}/
-
-CUPS_VERSION= 1.1.23
-CUPS_REVISION= 0
-CUPS_PORTVER= ${CUPS_VERSION}.${CUPS_REVISION}
-CUPS_PORTREV= 1
-CUPS_PORTEPOCH= 0
-CUPS_FILESDIR= ${.CURDIR}/../../print/cups/files
-CUPS_ETCDIR= ${PREFIX}/etc/cups
-CUPS_RCDIR= ${PREFIX}/etc/rc.d
-CUPS_DOCSDIR= ${PREFIX}/share/doc/cups
-CUPS_SPOOLDIR= /var/spool/cups
-
-# file, dir ownership
-CUPSGRP= daemon
-CUPSOWN= root
-
-######################################################################
-# The rest of the file is for components (cups-base, cups-lpr) only.
-######################################################################
-
-.if ${PORTNAME} == "cups-base" || ${PORTNAME} == "cups-lpr"
-
-MANLANG= "" es fr
-
-.if ${CUPS_REVISION} < 1
-DISTNAME= cups-${CUPS_VERSION}-source
-.else
-DISTNAME= cups-${CUPS_VERSION}-${CUPS_REVISION}-source
-.endif # ${CUPS_REVISION} < 1
-
-DISTFILES= ${DISTNAME}.tar.bz2
-
-MD5_FILE= ${.CURDIR}/../../print/cups/distinfo
-WRKSRC= ${WRKDIR}/cups-${CUPS_VERSION}
-
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
-
-.if defined(WITH_PHP)
-CONFIGURE_ARGS+= --with-php
-RUN_DEPENDS+= php:${PORTSDIR}/lang/php4
-.endif
-
-.if defined(WITH_PYTHON)
-CONFIGURE_ARGS+= --with-python
-USE_PYTHON= yes
-.endif
-
-.if defined(WITH_CUPS_LIBPAPER)
-CONFIGURE_ARGS+= --enable-libpaper
-LIB_DEPENDS+= paper.2:${PORTSDIR}/print/libpaper
-.endif
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_RUN= yes
-GNU_CONFIGURE= yes
-
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-CONFIGURE_ARGS+= --localstatedir=/var \
- --disable-pam \
- --disable-slp \
- --with-cups-user=${CUPSOWN} \
- --with-cups-group=${CUPSGRP} \
- --with-docdir=${CUPS_DOCSDIR} \
- --with-rcdir=${CUPS_RCDIR}
-
-.if !defined(WITHOUT_GNUTLS)
-CONFIGURE_ARGS+= --enable-gnutls --disable-openssl
-LIB_DEPENDS+= gnutls-openssl.15:${PORTSDIR}/security/gnutls
-.endif
-
-CONFIGURE_ARGS+= CPPFLAGS="-I.. -I${LOCALBASE}/include"
-CONFIGURE_ARGS+= DSOFLAGS="-Wl,-rpath,${PREFIX}/lib -L${PREFIX}/lib"
-CONFIGURE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
-
-pre-configure::
- @${ECHO_MSG} Configuring CUPS with options:
- @${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
-
-.endif # ${PORTNAME} != "cups"
diff --git a/print/cups/pkg-descr b/print/cups/pkg-descr
index 015c38731b0d..c9ab263133fb 100644
--- a/print/cups/pkg-descr
+++ b/print/cups/pkg-descr
@@ -19,7 +19,4 @@ that use these filters. This software is available in the cups-pstoraster
port.
WWW: http://www.cups.org/
-
-- AlanE (maintainer)
-alane@freebsd.org, ports@geeksrus.net
[original text by greid@ukug.uk.freebsd.org]
diff --git a/print/cups/pkg-message b/print/cups/pkg-message
index a620d3960f6f..9aae2ed36351 100644
--- a/print/cups/pkg-message
+++ b/print/cups/pkg-message
@@ -7,4 +7,3 @@ on how to set up your printer to use CUPS. Basic template configuration files
have been installed in %%PREFIX%%/etc/cups/
======================================================================
-