aboutsummaryrefslogtreecommitdiffstats
path: root/print/enscript-letter
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
committerasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
commit71102e95212bab836c7a1f7b6a46879128507258 (patch)
tree092d32b70a72fb7f03924e677d49b93599639b89 /print/enscript-letter
parent1adcc2f9a259e053ec9c8749e6e4ca4193bd4a56 (diff)
downloadfreebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.tar.gz
freebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.tar.zst
freebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.zip
Remove LOOP_VAR and replace it with tiny Makefiles using MASTERDIR to
share most files. Repository copy the default to explicitly named directories to avoid any confusion. Greatly simplify the shared Makefiles, since we are now in different subdirectories, we don't need "a4-install" stuff. While I'm here, consistently name the variables. Here are the guidelines (master port is in brackets) DOCFORMAT: [html] pdf ps KONFONT: 14dot [16dot] PAPERSIZE: a4 [letter] letterdj RESOLUTION: 118 240 [300] 360 400 600 "math/r" has been copied to "R-a4" and "R-letter", to follow the spirit of the original port. "japanese/kon" is renamed to "kon2-*", since that seems to be the basename.
Diffstat (limited to 'print/enscript-letter')
-rw-r--r--print/enscript-letter/Makefile86
1 files changed, 12 insertions, 74 deletions
diff --git a/print/enscript-letter/Makefile b/print/enscript-letter/Makefile
index d17a739a96e2..0d69f1c1501e 100644
--- a/print/enscript-letter/Makefile
+++ b/print/enscript-letter/Makefile
@@ -1,9 +1,9 @@
-# New ports collection makefile for: enscript
+# New ports collection makefile for: enscript (letter)
# Version required: 1.6.1
# Date created: 24 Jul, 1997
# Whom: kline
#
-# $Id: Makefile,v 1.5 1998/10/30 08:35:33 asami Exp $
+# $Id: Makefile,v 1.6 1998/11/09 01:14:51 steve Exp $
#
DISTNAME= enscript-1.6.1
@@ -13,11 +13,9 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= kline@thought.org
-LOOP_VAR= PAPERSIZE
-LOOP_OPTIONS= A4 Letter Letterdj
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --disable-nls --with-media=${PAPERSIZE}
+CONFIGURE_ARGS= --disable-nls --with-media=${PS}
MAKE_FLAGS= WIDTH=${WIDTH} HEIGHT=${HEIGHT} A4_PAPERSIZE=${A4_PAPERSIZE} -f
MAN1= diffpp.1 enscript.1 sliceprint.1 states.1
@@ -26,83 +24,23 @@ STRIP=
# If you want to build a static binary, uncomment the following line
#LDFLAGS+=-static
-.if !defined(PAPERSIZE)
-PAPERSIZE=A4 # set default
-WIDTH=8.27
-HEIGHT=11.64
-A4_PAPERSIZE=1
-PAPERSIZE_UNSPECIFIED= yes
-.elif ${PAPERSIZE} == A4 || ${PAPERSIZE} == a4
-PAPERSIZE=A4
+PAPERSIZE?= letter
+PS!= echo ${PAPERSIZE} | tr l L | tr a A
+
+.if ${PAPERSIZE} == a4
WIDTH=8.27
HEIGHT=11.64
A4_PAPERSIZE=1
-.elif ${PAPERSIZE} == letter || ${PAPERSIZE} == LETTER || ${PAPERSIZE} == Letter
-PAPERSIZE=Letter
+.elif ${PAPERSIZE} == letter
WIDTH=8.5
HEIGHT=11.0
A4_PAPERSIZE=0
-.elif ${PAPERSIZE} == Letterdj
-.else
-PAPERSIZE_INVALID= yes
-.endif # not defined PAPERSIZE
-
-pre-fetch:
-.if defined(PAPERSIZE_UNSPECIFIED)
- @echo ""
- @echo "This port builds the default A4 paper size."
- @echo "If you want to select the LETTER papersize for enscript,"
- @echo "type a ^C now. Then type:"
- @echo ""
- @echo " % make letter "
- @echo ""
- @echo "Install your port by typing:"
- @echo ""
- @echo "make letter-install {or} % make a4-install"
- @echo ""
- @echo "You can also set the environment variable PAPERSIZE to A4 or"
- @echo "letter to configure enscript for these paper sizes"
- @sleep 5
-.elif defined(PAPERSIZE_INVALID)
- @echo "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @echo "Possible values are: A4 (default) or letter"
+.elif ${PAPERSIZE} != letterdj
+.BEGIN:
+ @${EHCO} "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @${EHCO} "Possible values are: a4 or letter or letterdj"
@${FALSE}
.endif
-letter::
- ${MAKE} PAPERSIZE=Letter
-
-Letter::
- ${MAKE} PAPERSIZE=Letter
-
-letter-install::
- ${MAKE} PAPERSIZE=Letter install
-
-Letter-install::
- ${MAKE} PAPERSIZE=Letter install
-
-a4::
- ${MAKE} PAPERSIZE=A4
-
-A4::
- ${MAKE} PAPERSIZE=A4
-
-Letterdj::
- ${MAKE} PAPERSIZE=Letterdj
-
-letterdj::
- ${MAKE} PAPERSIZE=Letterdj
-
-Letterdj-install::
- ${MAKE} PAPERSIZE=Letterdj install
-
-letterdj-install::
- ${MAKE} PAPERSIZE=Letterdj install
-
-a4-install::
- ${MAKE} PAPERSIZE=a4 install
-
-A4-install::
- ${MAKE} PAPERSIZE=a4 install
post-install:
.for file in enscript mkafmmap states