aboutsummaryrefslogtreecommitdiffstats
path: root/print/gl2ps
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-11-08 01:12:06 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2017-11-08 01:12:06 +0800
commit4b974739d55bf0181285e17c6fee07dd5cf86474 (patch)
treef4a581da9cb6d7829d993553a96d829aee86b29b /print/gl2ps
parent7380d4d27b49e0bc160e800b234336dc456699b1 (diff)
downloadfreebsd-ports-gnome-4b974739d55bf0181285e17c6fee07dd5cf86474.tar.gz
freebsd-ports-gnome-4b974739d55bf0181285e17c6fee07dd5cf86474.tar.zst
freebsd-ports-gnome-4b974739d55bf0181285e17c6fee07dd5cf86474.zip
- Update print/gl2ps to 1.4.0.
- Use upstream build system so the static library is no longer built with -fPIC, the shared library gets a proper version and SONAME, and flags like LDFLAGS are respected. - Drop dependency on libGLU and Xorg libraries. - Add LICENSE. - Update pkg-descr. PR: 223204 Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'print/gl2ps')
-rw-r--r--print/gl2ps/Makefile38
-rw-r--r--print/gl2ps/distinfo5
-rw-r--r--print/gl2ps/files/Makefile.ex19
-rw-r--r--print/gl2ps/files/Makefile.lib13
-rw-r--r--print/gl2ps/files/patch-CMakeLists.txt32
-rw-r--r--print/gl2ps/pkg-descr10
-rw-r--r--print/gl2ps/pkg-plist7
7 files changed, 56 insertions, 68 deletions
diff --git a/print/gl2ps/Makefile b/print/gl2ps/Makefile
index 54e17dc56b9a..e176072ddf1d 100644
--- a/print/gl2ps/Makefile
+++ b/print/gl2ps/Makefile
@@ -2,41 +2,23 @@
# $FreeBSD$
PORTNAME= gl2ps
-PORTVERSION= 1.3.9
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= print graphics
MASTER_SITES= http://www.geuz.org/gl2ps/src/
-EXTRACT_SUFX= .tgz
MAINTAINER= araujo@FreeBSD.org
-COMMENT= C library providing vector output for OpenGL application
+COMMENT= C library providing vector output for OpenGL applications
-USE_GL= yes
-USE_XORG= x11 xmu xi
-USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
-
-OPTIONS_DEFINE= DOCS
+LICENSE= LGPL20+
+LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
-pre-build:
- @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+LIB_DEPENDS= libpng.so:graphics/png
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/libgl2ps.so ${STAGEDIR}${PREFIX}/lib
- ${LN} -s {PREFIX}/lib/libgl2ps.so ${STAGEDIR}${PREFIX}/lib/libgl2ps.so.1
- ${INSTALL_DATA} ${WRKSRC}/libgl2ps.a ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/gl2ps.h ${STAGEDIR}${PREFIX}/include
-
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/gl2psTest.c ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/gl2psTestSimple.c ${STAGEDIR}${EXAMPLESDIR}
- @${SED} -e 's|%%CC%%|${CC}|g; \
- s|%%RM%%|${RM}|g; \
- s|%%CFLAGS%%|${CFLAGS}|g; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' \
- <${FILESDIR}/Makefile.ex >${STAGEDIR}${EXAMPLESDIR}/Makefile
+USES= cmake:outsource tar:tgz
+USE_GL= gl
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/gl2ps.pdf ${STAGEDIR}${DOCSDIR}
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/print/gl2ps/distinfo b/print/gl2ps/distinfo
index 5906419ac8bb..37f49bf839b7 100644
--- a/print/gl2ps/distinfo
+++ b/print/gl2ps/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gl2ps-1.3.9.tgz) = 8a680bff120df8bcd78afac276cdc38041fed617f2721bade01213362bcc3640
-SIZE (gl2ps-1.3.9.tgz) = 294907
+TIMESTAMP = 1508834464
+SHA256 (gl2ps-1.4.0.tgz) = 03cb5e6dfcd87183f3b9ba3b22f04cd155096af81e52988cc37d8d8efe6cf1e2
+SIZE (gl2ps-1.4.0.tgz) = 300339
diff --git a/print/gl2ps/files/Makefile.ex b/print/gl2ps/files/Makefile.ex
deleted file mode 100644
index 6ead2825bec9..000000000000
--- a/print/gl2ps/files/Makefile.ex
+++ /dev/null
@@ -1,19 +0,0 @@
-# You'll need graphics/libglut in order to build example programs
-
-CC=%%CC%%
-RM=%%RM%%
-
-CFLAGS= %%CFLAGS%% -DHAVE_ZLIB -O3 -I%%LOCALBASE%%/include
-LDFLAGS= -lgl2ps -lGL -lGLU -lglut -L%%LOCALBASE%%/lib -lX11 -lXi -lXmu -lm -lz
-
-gl2psTest: gl2psTest.o
- ${CC} ${LDFLAGS} $> -o $@
-
-gl2psTestSimple: gl2psTestSimple.o
- ${CC} ${LDFLAGS} $> -o $@
-
-.c.o:
- ${CC} -c ${CFLAGS} $*.c
-
-clean:
- ${RM} -f gl2psTest gl2psTest.o gl2psTestSimple gl2psTestSimple.o
diff --git a/print/gl2ps/files/Makefile.lib b/print/gl2ps/files/Makefile.lib
deleted file mode 100644
index 546b4a2666f0..000000000000
--- a/print/gl2ps/files/Makefile.lib
+++ /dev/null
@@ -1,13 +0,0 @@
-CFLAGS+= -DHAVE_ZLIB -O3 -fPIC -I${LOCALBASE}/include
-LDFLAGS= -shared -E -lGL -L${LOCALBASE}/lib -L/usr/lib -lX11 -lXi -lXmu -lm -lz
-
-all: libgl2ps.so libgl2ps.a
-
-libgl2ps.a: gl2ps.o
- ${AR} qc $@ $>
-
-libgl2ps.so: gl2ps.o
- ${LD} ${LDFLAGS} $> -o $@
-
-.c.o:
- ${CC} -c ${CFLAGS} $*.c
diff --git a/print/gl2ps/files/patch-CMakeLists.txt b/print/gl2ps/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..4a9683566ee9
--- /dev/null
+++ b/print/gl2ps/files/patch-CMakeLists.txt
@@ -0,0 +1,32 @@
+--- CMakeLists.txt.orig 2017-04-03 23:09:28 UTC
++++ CMakeLists.txt
+@@ -79,10 +79,9 @@ endif(NOT HAVE_VSNPRINTF)
+ find_package(OpenGL)
+ if(OPENGL_FOUND)
+ list(APPEND EXTERNAL_INCLUDES ${OPENGL_INCLUDE_DIR})
+- list(APPEND EXTERNAL_LIBRARIES ${OPENGL_LIBRARIES})
++ list(APPEND EXTERNAL_LIBRARIES ${OPENGL_gl_LIBRARY})
+ endif(OPENGL_FOUND)
+
+-find_package(GLUT)
+ if(GLUT_FOUND)
+ list(APPEND EXTERNAL_INCLUDES ${GLUT_INCLUDE_DIR})
+ list(APPEND EXTERNAL_LIBRARIES ${GLUT_LIBRARIES})
+@@ -138,8 +137,7 @@ endif(WIN32)
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/gl2ps.pdf DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+
+@@ -150,7 +148,6 @@ if(GLUT_FOUND)
+ target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+ endif(GLUT_FOUND)
+
+-find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+ COMMAND ${PDFLATEX_COMPILER} ARGS ${CMAKE_SOURCE_DIR}/gl2ps.tex
diff --git a/print/gl2ps/pkg-descr b/print/gl2ps/pkg-descr
index 80d7d7c2ce7f..bce15638be23 100644
--- a/print/gl2ps/pkg-descr
+++ b/print/gl2ps/pkg-descr
@@ -5,8 +5,12 @@ stretched polygons, as well as non manifold objects. GL2PS provides advanced
smooth shading and text rendering, culling of invisible primitives, mixed
vector/bitmap output, and much more...
-GL2PS can currently create PostScript (PS), Encapsulated PostScript (EPS)
-and Portable Document Format (PDF) files, as well as LATEX files for the
-text fragments.
+GL2PS can currently create PostScript (PS), Encapsulated PostScript (EPS),
+Portable Document Format (PDF) and Scalable Vector Graphics (SVG) files, as
+well as LATEX files for the text fragments. GL2PS also provides limited,
+experimental support for Portable LaTeX Graphics (PGF). Adding new vector
+output formats should be relatively easy; you can also use the excellent
+pstoedit program to transform the PostScript files generated by GL2PS into
+many other vector formats such as xfig, cgm, wmf, etc.
WWW: http://www.geuz.org/gl2ps/
diff --git a/print/gl2ps/pkg-plist b/print/gl2ps/pkg-plist
index 7a4026d237b3..341b57719b67 100644
--- a/print/gl2ps/pkg-plist
+++ b/print/gl2ps/pkg-plist
@@ -2,7 +2,8 @@ include/gl2ps.h
lib/libgl2ps.a
lib/libgl2ps.so
lib/libgl2ps.so.1
-%%EXAMPLESDIR%%/gl2psTest.c
-%%EXAMPLESDIR%%/gl2psTestSimple.c
-%%EXAMPLESDIR%%/Makefile
+lib/libgl2ps.so.1.4.0
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/gl2ps.pdf
+%%PORTDOCS%%%%DOCSDIR%%/gl2psTest.c
+%%PORTDOCS%%%%DOCSDIR%%/gl2psTestSimple.c