aboutsummaryrefslogtreecommitdiffstats
path: root/print/gv
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-08-23 01:48:35 +0800
committerhrs <hrs@FreeBSD.org>2015-08-23 01:48:35 +0800
commit52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2 (patch)
tree445c3e315f03aa972de87391f921c655e4634f60 /print/gv
parent069a5644197c0b8b71f45d29221cd5192af4c720 (diff)
downloadfreebsd-ports-gnome-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.tar.gz
freebsd-ports-gnome-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.tar.zst
freebsd-ports-gnome-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.zip
- Split ghostscript into X11-independent and -dependent parts:
* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
Diffstat (limited to 'print/gv')
-rw-r--r--print/gv/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 45685cbdd37f..4b977bead410 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gv
PORTVERSION= 3.7.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= GNU/${PORTNAME}
@@ -13,7 +13,7 @@ COMMENT= PostScript and PDF previewer
LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
USE_XORG= xpm ice sm xext xmu x11
-USES= cpe ghostscript iconv gmake perl5 shebangfix
+USES= cpe ghostscript:x11 iconv gmake perl5 shebangfix
USE_PERL5= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include