aboutsummaryrefslogtreecommitdiffstats
path: root/print/hp2xx/Makefile
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2014-11-02 22:24:07 +0800
committerrobak <robak@FreeBSD.org>2014-11-02 22:24:07 +0800
commite3dd64502c3026c1b680d2a9346e86a58eb5bf37 (patch)
treee05322daf62c39843eab12c9396011b7b8f9d7be /print/hp2xx/Makefile
parent90f3917b0bab3a9aeaf7de0c36b721db3d2672dc (diff)
downloadfreebsd-ports-gnome-e3dd64502c3026c1b680d2a9346e86a58eb5bf37.tar.gz
freebsd-ports-gnome-e3dd64502c3026c1b680d2a9346e86a58eb5bf37.tar.zst
freebsd-ports-gnome-e3dd64502c3026c1b680d2a9346e86a58eb5bf37.zip
print/hp2xx: multiple fixes
- Fix building on -CURRENT - Add LICENSE - Pet portlint PR: 194500 Submitted by: Kato Tsuguru <tkato432@yahoo.com> Approved by: mentors (implicit)
Diffstat (limited to 'print/hp2xx/Makefile')
-rw-r--r--print/hp2xx/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/print/hp2xx/Makefile b/print/hp2xx/Makefile
index aa4fc266b1bb..983f34bbe8ba 100644
--- a/print/hp2xx/Makefile
+++ b/print/hp2xx/Makefile
@@ -3,39 +3,36 @@
PORTNAME= hp2xx
PORTVERSION= 3.4.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print x11
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
COMMENT= HPGL to vector and raster formats converter and previewer for X11
+LICENSE= GPLv2 # (or later)
+
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
-WRKSRC= ${WRKDIR}/${DISTNAME}/sources
+WRKSRC_SUBDIR= sources
USES= makeinfo
MAKE_ENV= DEFINES="${CPPFLAGS}" ALL_LIBS="${LDFLAGS}"
-PLIST_FILES= bin/hp2xx man/man1/hp2xx.1.gz
-INFO= hp2xx
-
CPPFLAGS+= -DUNIX -I${LOCALBASE}/include
LDFLAGS+= -lm -L${LOCALBASE}/lib -ltiff -lpng -lz
-OPTIONS_DEFINE= X11
-OPTIONS_DEFAULT=X11
+INFO= hp2xx
+PLIST_FILES= bin/hp2xx man/man1/hp2xx.1.gz
-X11_USE= XORG=x11
-X11_CPPFLAGS= -DHAS_UNIX_X11 -I${LOCALBASE}/include
-X11_LDFLAGS= -L${LOCALBASE}/lib -lX11
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT= X11
+
+X11_USE= XORG=x11
X11_MAKE_ENV= PREVIEWER=to_x11
X11_MAKE_ENV_OFF= PREVIEWER=no_prev
-
-post-patch:
- @${REINPLACE_CMD} -E 's,(bin|info|man1)dir),DESTDIR)$$(&,' \
- ${WRKSRC}/Makefile
+X11_CPPFLAGS= -DHAS_UNIX_X11 -I${LOCALBASE}/include
+X11_LDFLAGS= -L${LOCALBASE}/lib -lX11
.include <bsd.port.mk>