aboutsummaryrefslogtreecommitdiffstats
path: root/print/hpijs
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-06-28 07:52:18 +0800
committerperky <perky@FreeBSD.org>2002-06-28 07:52:18 +0800
commit4eed417e8628539ccdb5d6b6d07941f87049b083 (patch)
treed5fbb2fe8db4749eaa3a7dd730be467925c4b2b2 /print/hpijs
parent6f6e5d734c11305b6e53945e264c11172841839f (diff)
downloadfreebsd-ports-gnome-4eed417e8628539ccdb5d6b6d07941f87049b083.tar.gz
freebsd-ports-gnome-4eed417e8628539ccdb5d6b6d07941f87049b083.tar.zst
freebsd-ports-gnome-4eed417e8628539ccdb5d6b6d07941f87049b083.zip
PERL -> REINPLACE_CMD
PR: 39706 39708 39709 39710 Submitted by: Scott Flatman <sf@dsinw.com>
Diffstat (limited to 'print/hpijs')
-rw-r--r--print/hpijs/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/print/hpijs/Makefile b/print/hpijs/Makefile
index 9083990d7708..37acda593b4d 100644
--- a/print/hpijs/Makefile
+++ b/print/hpijs/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= ijs.1:${PORTSDIR}/print/libijs
IJS_CONFIG?= ${LOCALBASE}/bin/ijs-config
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -25,14 +26,14 @@ CPPFLAGS= `${IJS_CONFIG} --cflags`
LDFLAGS= `${IJS_CONFIG} --libs`
post-patch:
- @${PERL} -pi -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS"|g ; \
+ @${REINPLACE_CMD} -e 's|CFLAGS="-O2 -Wall"|CFLAGS="\$$CFLAGS"|g ; \
s|CXXFLAGS="-O2 -Wall"|CXXFLAGS="\$$CXXFLAGS"|g' \
${WRKSRC}/configure
- @${PERL} -pi -e 's| ijs.[cho]||g ; \
+ @${REINPLACE_CMD} -e 's| ijs.[cho]||g ; \
s| ijs_client.h||g ; \
s| ijs_server.[cho]||g ; \
s| ijs_exec_unix.[co]||g' ${WRKSRC}/Makefile.in
- @${PERL} -pi -e 's|#include <malloc.h>||g' ${WRKSRC}/platform.h
+ @${REINPLACE_CMD} -e 's|#include <malloc.h>||g' ${WRKSRC}/platform.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hpijs ${PREFIX}/bin