aboutsummaryrefslogtreecommitdiffstats
path: root/print/hplip
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2015-02-10 20:17:36 +0800
committermakc <makc@FreeBSD.org>2015-02-10 20:17:36 +0800
commiteee29140fb76db024e7268091bc892b667126eda (patch)
tree60fccbecf1cfb1a528d0fe27331ff97d1927910c /print/hplip
parentb7bff2b13f6391b48cafa19d554dcccce40fcd0c (diff)
downloadfreebsd-ports-gnome-eee29140fb76db024e7268091bc892b667126eda.tar.gz
freebsd-ports-gnome-eee29140fb76db024e7268091bc892b667126eda.tar.zst
freebsd-ports-gnome-eee29140fb76db024e7268091bc892b667126eda.zip
print/hplip:
- Update to 3.14.10 [1] - Fix detection of libusb v1.0 and build with it now - Enable JetDirect and scanning support by default (requested by pkg users) - hplip modifies etc/sane.d/dll.conf witch belongs to sane-backends port, and writes to this file in staging area. Add commented entry for it in plist to pacify staging checks. print/hplip-plugin: - Update to 3.14.10 - Add missing entry to plist - Pass MAKE_ENV for installer to prevent writing to ${HOME} PR 197245 [1] Submitted by: chris@bsdjunk.com
Diffstat (limited to 'print/hplip')
-rw-r--r--print/hplip/Makefile12
-rw-r--r--print/hplip/distinfo4
-rw-r--r--print/hplip/files/patch-installer__core_install.py14
-rw-r--r--print/hplip/pkg-plist35
4 files changed, 55 insertions, 10 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index b41c637e997b..31e2940d7224 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hplip
-PORTVERSION= 3.14.4
-PORTREVISION= 4
+PORTVERSION= 3.14.10
CATEGORIES= print
MASTER_SITES= SF
@@ -40,8 +39,7 @@ CONFIGURE_ARGS= --enable-foomatic-ppd-install \
--with-mimedir=${PREFIX}/etc/cups \
--with-docdir=${DOCSDIR} \
--with-htmldir=${DOCSDIR} \
- --with-drvdir=${PREFIX}/libexec/cups/driver \
- --enable-libusb01_build
+ --with-drvdir=${PREFIX}/libexec/cups/driver
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -78,7 +76,7 @@ FILES4FIX= Makefile.in \
PYTHON_SITELIBDIR_REL= ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
OPTIONS_DEFINE= QT FAX SNMP SCAN XSANE DOCS
-OPTIONS_DEFAULT= QT
+OPTIONS_DEFAULT= QT SNMP SCAN
OPTIONS_SUB= yes # QT FAX SCAN
QT_DESC= Graphical User Interface (Qt 4)
@@ -114,6 +112,8 @@ RUN_DEPENDS+= xsane:${PORTSDIR}/graphics/xsane
post-patch:
${REINPLACE_CMD} -e 's|-ldld||g; s|-ldl||g' \
+ -e 's,-lusb-1.0,-lusb,g' \
+ -e 's,libusb-1.0/libusb.h,libusb.h,g' \
${WRKSRC}/configure \
${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e '/[[:space:]]install-dist_rulesDATA/ s,install-dist_rulesDATA,,' \
@@ -152,5 +152,7 @@ post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/hp
${INSTALL_DATA} ${WRKSRC}/hplip.conf ${STAGEDIR}${PREFIX}/etc/hp/hplip.conf.sample
${LN} -sf ${LOCALBASE}/bin/foomatic-rip ${STAGEDIR}${PREFIX}/libexec/cups/filter/foomatic-rip-hplip
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cups/model
+ ${LN} -sf ${LOCALBASE}/share/ppd/HP ${STAGEDIR}${PREFIX}/share/cups/model/hplip
.include <bsd.port.mk>
diff --git a/print/hplip/distinfo b/print/hplip/distinfo
index 3d51b976afe1..fdab5ab63a4f 100644
--- a/print/hplip/distinfo
+++ b/print/hplip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hplip-3.14.4.tar.gz) = ce50c2e0ebc0f469599500257d291ca170c6559a99c8eb312f89be881c2110c9
-SIZE (hplip-3.14.4.tar.gz) = 21414140
+SHA256 (hplip-3.14.10.tar.gz) = 11b3cd8311dea6b22a4c80be1e5d021e84d15a5f3e7e22cbd43798e5c1a89598
+SIZE (hplip-3.14.10.tar.gz) = 21773429
diff --git a/print/hplip/files/patch-installer__core_install.py b/print/hplip/files/patch-installer__core_install.py
index a35c8eb3ed0a..788bfcb860aa 100644
--- a/print/hplip/files/patch-installer__core_install.py
+++ b/print/hplip/files/patch-installer__core_install.py
@@ -1,6 +1,6 @@
---- ./installer/core_install.py.orig 2012-09-04 12:31:53.000000000 +0000
-+++ ./installer/core_install.py 2012-09-12 15:01:59.259583493 +0000
-@@ -885,7 +885,7 @@
+--- installer/core_install.py.orig 2014-10-07 08:55:35 UTC
++++ installer/core_install.py
+@@ -769,14 +769,14 @@ class CoreInstall(object):
if not check_lib('libusb'):
return False
if self.distro_name != "rhel":
@@ -9,3 +9,11 @@
else:
return True
else:
+ if not check_lib('libusb-1.0'):
+ return False
+ if self.distro_name != "rhel":
+- return len(locate_file_contains("libusb.h", '/usr/include/libusb-1.0', 'libusb_init'))
++ return len(locate_file_contains("libusb.h", '%USB_INCLUDE%', 'libusb_init'))
+ else:
+ return True
+
diff --git a/print/hplip/pkg-plist b/print/hplip/pkg-plist
index 0362aca9a6d2..2befef4ffbe9 100644
--- a/print/hplip/pkg-plist
+++ b/print/hplip/pkg-plist
@@ -38,6 +38,7 @@ bin/hpijs
%%FAX%%etc/cups/pstotiff.convs
%%FAX%%etc/cups/pstotiff.types
@sample etc/hp/hplip.conf.sample
+@comment etc/sane.d/dll.conf
%%QT%%etc/xdg/autostart/hplip-systray.desktop
lib/libhpip.so
lib/libhpip.so.0
@@ -61,6 +62,7 @@ libexec/cups/filter/hpcups
libexec/cups/filter/hpps
libexec/cups/filter/pstotiff
%%QT%%share/applications/hplip.desktop
+share/cups/model/hplip
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README_LIBJPG
%%PORTDOCS%%%%DOCSDIR%%/commandline.html
@@ -870,6 +872,7 @@ share/ppd/HP/hp-color_laserjet_pro_mfp_m177fw.ppd.gz
share/ppd/HP/hp-color_laserjet_pro_mfp_m476-ps.ppd.gz
share/ppd/HP/hp-cp1160-hpijs.ppd.gz
share/ppd/HP/hp-cp1160.ppd.gz
+share/ppd/HP/hp-designjet_d5800-ps.ppd.gz
share/ppd/HP/hp-designjet_4000ps.ppd.gz
share/ppd/HP/hp-designjet_4020ps-ps.ppd.gz
share/ppd/HP/hp-designjet_4500mfp.ppd.gz
@@ -893,12 +896,16 @@ share/ppd/HP/hp-designjet_t790ps_24in-ps.ppd.gz
share/ppd/HP/hp-designjet_t790ps_44in-ps.ppd.gz
share/ppd/HP/hp-designjet_t795ps_44in-ps.ppd.gz
share/ppd/HP/hp-designjet_t920-postscript.ppd.gz
+share/ppd/HP/hp-designjet_t3500-ps.ppd.gz
+share/ppd/HP/hp-designjet_t7200-ps.ppd.gz
share/ppd/HP/hp-designjet_z5200_postscript-ps.ppd.gz
share/ppd/HP/hp-designjet_z5400-postscript.ppd.gz
share/ppd/HP/hp-designjet_z6100ps_42in_photo-ps.ppd.gz
share/ppd/HP/hp-designjet_z6100ps_60in_photo-ps.ppd.gz
share/ppd/HP/hp-designjet_z6200_42in_photo-ps.ppd.gz
share/ppd/HP/hp-designjet_z6200_60in_photo-ps.ppd.gz
+share/ppd/HP/hp-designjet_z6600-postscript.ppd.gz
+share/ppd/HP/hp-designjet_z6800_photo-postscript.ppd.gz
share/ppd/HP/hp-deskjet_1000_j110_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1000_j110_series.ppd.gz
share/ppd/HP/hp-deskjet_1010_series-hpijs.ppd.gz
@@ -1267,6 +1274,12 @@ share/ppd/HP/hp-envy_4500_series-hpijs.ppd.gz
share/ppd/HP/hp-envy_4500_series.ppd.gz
share/ppd/HP/hp-envy_5530_series-hpijs.ppd.gz
share/ppd/HP/hp-envy_5530_series.ppd.gz
+share/ppd/HP/hp-envy_5640_series-hpijs.ppd.gz
+share/ppd/HP/hp-envy_5640_series.ppd.gz
+share/ppd/HP/hp-envy_5660_series-hpijs.ppd.gz
+share/ppd/HP/hp-envy_5660_series.ppd.gz
+share/ppd/HP/hp-envy_7640_series-hpijs.ppd.gz
+share/ppd/HP/hp-envy_7640_series.ppd.gz
share/ppd/HP/hp-laserjet_1000-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_1000.ppd.gz
share/ppd/HP/hp-laserjet_1005_series-hpijs.ppd.gz
@@ -1581,6 +1594,7 @@ share/ppd/HP/hp-laserjet_cp_1025-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_cp_1025.ppd.gz
share/ppd/HP/hp-laserjet_cp_1025nw-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_cp_1025nw.ppd.gz
+share/ppd/HP/hp-laserjet_flow_mfp_m630-ps.ppd.gz
share/ppd/HP/hp-laserjet_flow_mfp_m525-ps.ppd.gz
share/ppd/HP/hp-laserjet_flow_mfp_m830-ps.ppd.gz
share/ppd/HP/hp-laserjet_m1005-hpijs.ppd.gz
@@ -1639,6 +1653,7 @@ share/ppd/HP/hp-laserjet_m9059_mfp-pcl3.ppd.gz
share/ppd/HP/hp-laserjet_m9059_mfp-ps.ppd.gz
share/ppd/HP/hp-laserjet_mfp_m521-ps.ppd.gz
share/ppd/HP/hp-laserjet_mfp_m725-ps.ppd.gz
+share/ppd/HP/hp-laserjet_mfp_m630-ps.ppd.gz
share/ppd/HP/hp-laserjet_p1005-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_p1005.ppd.gz
share/ppd/HP/hp-laserjet_p1006-hpijs.ppd.gz
@@ -1752,6 +1767,12 @@ share/ppd/HP/hp-laserjet_pro_mfp_m128fp.ppd.gz
share/ppd/HP/hp-laserjet_pro_mfp_m128fw-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_pro_mfp_m128fw.ppd.gz
share/ppd/HP/hp-laserjet_pro_mfp_m435-ps.ppd.gz
+share/ppd/HP/hp-laserjet_pro_m201_m202-ps.ppd.gz
+share/ppd/HP/hp-laserjet_pro_mfp_m125r-hpijs.ppd.gz
+share/ppd/HP/hp-laserjet_pro_mfp_m125r.ppd.gz
+share/ppd/HP/hp-laserjet_pro_mfp_m125ra-hpijs.ppd.gz
+share/ppd/HP/hp-laserjet_pro_mfp_m125ra.ppd.gz
+share/ppd/HP/hp-laserjet_pro_mfp_m225_m226-ps.ppd.gz
share/ppd/HP/hp-laserjet_professional_m1132_mfp-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_professional_m1132_mfp.ppd.gz
share/ppd/HP/hp-laserjet_professional_m1136_mfp-hpijs.ppd.gz
@@ -1878,6 +1899,8 @@ share/ppd/HP/hp-officejet_5500_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_5500_series.ppd.gz
share/ppd/HP/hp-officejet_5600_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_5600_series.ppd.gz
+share/ppd/HP/hp-officejet_5740_series-hpijs.ppd.gz
+share/ppd/HP/hp-officejet_5740_series.ppd.gz
share/ppd/HP/hp-officejet_6000_e609a-hpijs.ppd.gz
share/ppd/HP/hp-officejet_6000_e609a.ppd.gz
share/ppd/HP/hp-officejet_6000_e609n-hpijs.ppd.gz
@@ -1904,6 +1927,8 @@ share/ppd/HP/hp-officejet_6600-hpijs.ppd.gz
share/ppd/HP/hp-officejet_6600.ppd.gz
share/ppd/HP/hp-officejet_6700-hpijs.ppd.gz
share/ppd/HP/hp-officejet_6700.ppd.gz
+share/ppd/HP/hp-officejet_6800-hpijs.ppd.gz
+share/ppd/HP/hp-officejet_6800.ppd.gz
share/ppd/HP/hp-officejet_7000_e809a-hpijs.ppd.gz
share/ppd/HP/hp-officejet_7000_e809a.ppd.gz
share/ppd/HP/hp-officejet_7000_e809a_series-hpijs.ppd.gz
@@ -1922,6 +1947,8 @@ share/ppd/HP/hp-officejet_7500_e910-hpijs.ppd.gz
share/ppd/HP/hp-officejet_7500_e910.ppd.gz
share/ppd/HP/hp-officejet_7610_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_7610_series.ppd.gz
+share/ppd/HP/hp-officejet_8040_series-hpijs.ppd.gz
+share/ppd/HP/hp-officejet_8040_series.ppd.gz
share/ppd/HP/hp-officejet_9100_series-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-officejet_9100_series-pcl3.ppd.gz
share/ppd/HP/hp-officejet_color_mfp_x585.ppd.gz
@@ -1981,6 +2008,14 @@ share/ppd/HP/hp-officejet_pro_3620.ppd.gz
share/ppd/HP/hp-officejet_pro_451_series-ps.ppd.gz
share/ppd/HP/hp-officejet_pro_476_576_series-ps.ppd.gz
share/ppd/HP/hp-officejet_pro_551_series-ps.ppd.gz
+share/ppd/HP/hp-officejet_pro_6230-hpijs.ppd.gz
+share/ppd/HP/hp-officejet_pro_6230.ppd.gz
+share/ppd/HP/hp-officejet_pro_6830-hpijs.ppd.gz
+share/ppd/HP/hp-officejet_pro_6830.ppd.gz
+share/ppd/HP/hp-officejet_pro_8640-hpijs.ppd.gz
+share/ppd/HP/hp-officejet_pro_8640.ppd.gz
+share/ppd/HP/hp-officejet_pro_8660-hpijs.ppd.gz
+share/ppd/HP/hp-officejet_pro_8660.ppd.gz
share/ppd/HP/hp-officejet_pro_8000_a809-hpijs.ppd.gz
share/ppd/HP/hp-officejet_pro_8000_a809.ppd.gz
share/ppd/HP/hp-officejet_pro_8000_enterprise_a811a-ps.ppd.gz