aboutsummaryrefslogtreecommitdiffstats
path: root/print/lyx/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2011-07-05 06:01:48 +0800
committermakc <makc@FreeBSD.org>2011-07-05 06:01:48 +0800
commit5fec8a0c406ce92d87de131d83f5b4761d3d8710 (patch)
tree46ecee01adc51d5526f508fd60f3a3509daf563b /print/lyx/Makefile
parent4a3547523c43d9946155998b8b5db56ab0254451 (diff)
downloadfreebsd-ports-gnome-5fec8a0c406ce92d87de131d83f5b4761d3d8710.tar.gz
freebsd-ports-gnome-5fec8a0c406ce92d87de131d83f5b4761d3d8710.tar.zst
freebsd-ports-gnome-5fec8a0c406ce92d87de131d83f5b4761d3d8710.zip
Update to 2.0.0
PR: ports/158401 Submitted by: Aldis Berjoza (former maintainer)
Diffstat (limited to 'print/lyx/Makefile')
-rw-r--r--print/lyx/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 0e0acda58be8..3eb971c553c8 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= ${MAJOR_VERSION}.10
+PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
@@ -16,23 +16,25 @@ MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
ftp://ftp.chg.ru/pub/X11/lyx/stable/${MAJOR_VERSION}.x/
MAINTAINER= kubito@gmail.com
-COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG) (stable)
-
-LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs
+COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
LICENSE= GPLv2
-CONFLICTS= lyx-1.4* lyx-devel-*
-MAJOR_VERSION= 1.6
+LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs
+
+CONFLICTS= lyx-1.[0-9]*
+MAJOR_VERSION= 2.0
+MINOR_VERSION= 0
-USE_BZIP= yes
+USE_XZ= yes
USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= gui moc_build uic_build rcc_build
USE_PYTHON= yes
USE_PERL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+CPPFLAGS= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-frontend=qt4 \
--without-included-boost \
--without-included-gettext \