aboutsummaryrefslogtreecommitdiffstats
path: root/print/lyx14/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-05 21:40:55 +0800
committerkrion <krion@FreeBSD.org>2004-03-05 21:40:55 +0800
commit9d9349aa74fe6fbd27b58c6fa672f7553056316a (patch)
tree15c3bc7e79b5c04eb2ce0a639c7e0736925b4007 /print/lyx14/Makefile
parente8355cc613d21e94868cd11e7f6b828ad55f47cf (diff)
downloadfreebsd-ports-gnome-9d9349aa74fe6fbd27b58c6fa672f7553056316a.tar.gz
freebsd-ports-gnome-9d9349aa74fe6fbd27b58c6fa672f7553056316a.tar.zst
freebsd-ports-gnome-9d9349aa74fe6fbd27b58c6fa672f7553056316a.zip
- Fix build on -stable with Qt frontend
- Add CONFLICTS PR: ports/63754 Submitted by: Ports Fury
Diffstat (limited to 'print/lyx14/Makefile')
-rw-r--r--print/lyx14/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/print/lyx14/Makefile b/print/lyx14/Makefile
index 4a13b7ea7d1f..7379ad54cc83 100644
--- a/print/lyx14/Makefile
+++ b/print/lyx14/Makefile
@@ -20,13 +20,15 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
+CONFLICTS= cjk-lyx-*
+
USE_BZIP2= yes
-USE_GETTEXT= yes
+USE_GNOME= gnometarget lthack
USE_PERL5= yes
USE_PYTHON= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 14
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
@@ -58,9 +60,6 @@ RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
-.if defined(WITH_QT)
-BROKEN= QT Frontend coredumps on 4.x. Use the xforms Frontend instead.
-.endif
.endif
pre-everything::