aboutsummaryrefslogtreecommitdiffstats
path: root/print/lyx16
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-04-17 12:25:54 +0800
committermi <mi@FreeBSD.org>2006-04-17 12:25:54 +0800
commitac00cffdbbc1d780f4a66d0c0f8ad4a40f57a13d (patch)
tree3a0af4c7a4709ff115ed7f45ef83d5c5939878d2 /print/lyx16
parent1075fa6cbf85aeb400599293b34ec4d2394eb582 (diff)
downloadfreebsd-ports-gnome-ac00cffdbbc1d780f4a66d0c0f8ad4a40f57a13d.tar.gz
freebsd-ports-gnome-ac00cffdbbc1d780f4a66d0c0f8ad4a40f57a13d.tar.zst
freebsd-ports-gnome-ac00cffdbbc1d780f4a66d0c0f8ad4a40f57a13d.zip
LIB_DEPEND on devel/boost instead of building the bundled-in version
-- and tripping over the same C++ problems already solved by the devel/boost port. Bump PORTREVISION. Error reported by: kris
Diffstat (limited to 'print/lyx16')
-rw-r--r--print/lyx16/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index fedba1318827..7e1383bbb488 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lyx
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
@@ -18,6 +19,7 @@ COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
CONFLICTS= cjk-lyx-*
@@ -31,14 +33,28 @@ USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch] --exclude ${PORTNAME}-${PORTVERSION}/boost
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
+ --without-included-boost \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 tex2lyx.1 lyxclient.1
USE_REINPLACE= yes
+#post-extract:
+# # Removing mention of the bundled boost
+# ${REINPLACE_CMD} -e '/boost\/.*Makefile/d' ${WRKSRC}/configure.ac
+
+post-patch:
+ # Removing mention of the bundled boost
+ ${REINPLACE_CMD} -e 's, boost/[^ ]*Makefile,,g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,detail/nullstream,utils/nullstream,' \
+ ${WRKSRC}/src/pch.h ${WRKSRC}/src/support/pch.h \
+ ${WRKSRC}/src/support/debugstream.h
+ ${REINPLACE_CMD} -e 's,boost/regex\.hpp,boost/cregex.hpp,' \
+ ${WRKSRC}/src/support/filetools.C
+
post-configure:
# Removing explicit linking with -lc
${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile